Вход | Регистрация
 

Открытие формы списка регистра сведений

Открытие формы списка регистра сведений
Я
   LivingStar
 
29.10.19 - 12:10
У справочника команды. Некоторые открываются и закрываются вместе с окном справочника.

например эта

&НаКлиенте
Процедура ОбработкаКоманды(ПараметрКоманды, ПараметрыВыполненияКоманды)

    Отбор = Новый Структура("Владелец", ПараметрКоманды);
    ПараметрыФормы = Новый Структура("Отбор",Отбор );
    ОткрытьФорму("Справочник.ПодразделенияОрганизаций.ФормаСписка",ПараметрыФормы ,ЭтотОбъект,ПараметрыВыполненияКоманды.Уникальность,ПараметрыВыполненияКоманды.Окно);
    
КонецПроцедуры


а вот эта, открывается как бы в отдельном окне, и после его закрытия остается пустое окно, пустая форма

&НаКлиенте
Процедура ОбработкаКоманды(ПараметрКоманды, ПараметрыВыполненияКоманды)
    Если ЗначениеЗаполнено(ПараметрКоманды) Тогда
        КлючФильтрации = Новый Структура;
        КлючФильтрации.Вставить("Организация",ПараметрКоманды);
        ПараметрыОткрытияФормыСписка = Новый Структура("Ключ", КлючФильтрации);
        ФормаРегистра                  = ПолучитьФорму("РегистрСведений.НазваниеРегистра.ФормаСписка", ПараметрыОткрытияФормыСписка);
        ФормаРегистра.Открыть();
    Иначе
        ПоказатьПредупреждение(,"Перед переходом к форме количества отработанных часов необходимо записать объект.");
    КонецЕсли;    
КонецПроцедуры


Нужно вторую команду сделать наподобе первой, что бы аналогично все открывалось? Или как нужно доработать вторую команду, что бы она открывалась как первая?
 
 
   LivingStar
 
1 - 29.10.19 - 12:11
ПолучитьФорму() вроде как и ОткрытьФорму() имеет все те же параметры .
   ДенисЧ
 
2 - 29.10.19 - 12:13
Читай внимательно справку и обрати внимание на параметр Владелец
   LivingStar
 
3 - 29.10.19 - 12:14
(2) Я так понял вторую команду можно сделать по подобию первой. И параметры все эти же использовать.
   ДенисЧ
 
4 - 29.10.19 - 12:27
(3) Можно. Но у тебя не получится.
   LivingStar
 
5 - 29.10.19 - 12:30
(4) Это как?
        ФормаРегистра                  = ПолучитьФорму("РегистрСведений.НазваниеРегистра.ФормаСписка", ПараметрыОткрытияФормыСписка, ЭтотОбъект, ПараметрыВыполненияКоманды.Уникальность, ПараметрыВыполненияКоманды.Окно);

        ФормаРегистра.Открыть();

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.