Вход | Регистрация
 
1С:Предприятие :: 1С:Предприятие 8 общая

Не выделяет целую часть

↓ [Волшебник, 28.10.19 - 17:52]
Не выделяет целую часть
Я
   sidalexsandr
 
28.10.19 - 17:24
Вот функция
Функция ЦифруПоНомеру(M, K)
    
    HH = 1;
    Пока HH < (K-1) Цикл
        
        M = Цел(M / 10);
        HH = HH + 1;
        
        
    КонецЦикла;
    
    Возврат M;

КонецФункции
 
 
   vova1122
 
1 - 28.10.19 - 17:31
(0) и правильно делает что не выделяет. Если у тебя К будет =2 или меньше, то в цикл вообще не попадаешь....
   Жан Пердежон
 
2 - 28.10.19 - 17:35
учу пользоваться отладчиком. ДОРОГО
   sidalexsandr
 
3 - 28.10.19 - 17:43
(1) Исправил
Функция ЦифруПоНомеру(M, K)
    
    HH = 1;     
    Пока HH < K Цикл
        
        M = Цел(M / 10);
        HH = HH + 1;         
        
    КонецЦикла;
    
    Возврат M;

КонецФункции


Теперь выдает всё время 0
   Chum
 
4 - 28.10.19 - 17:48
(3) В чем смысл твоей функции? Вернуть цифру по номеру позиции в числе?

Не проще ли:

М - число
К - позиция

Возврат Число(Сред(М, 1, К))
или
Возврат Число(Сред(Строка(М), 1, К))
   Жан Пердежон
 
5 - 28.10.19 - 17:50
(3) цена растёт с каждым постом
   Волшебник
 
6 - 28.10.19 - 17:50
Жан Пердежон, рекламные объявления платные
   ChMikle
 
7 - 28.10.19 - 17:51
Может быть сразу функцию Цел()
   xXeNoNx
 
8 - 28.10.19 - 17:51
(7) тссс, осознание придет позже)
   sidalexsandr
 
9 - 28.10.19 - 17:51
(4) У меня стоит условие без использования строковых функций
   pechkin
 
10 - 28.10.19 - 17:52
Цел(M % (pow(10,K))/pow(10,K-1))

   Волшебник
 
11 - 28.10.19 - 17:52
(9) Все учебные задачки выполняйте без мисты, пожалуйста.
   sidalexsandr
 
12 - 28.10.19 - 18:07
Понял

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.