Вход | Регистрация
 

Как заменить обработчик Создание?

Как заменить обработчик Создание?
Я
   toypaul
 
28.10.19 - 16:23
Нужно вместо стандартной формы открыть другую и чтобы после записи в новой форме элемент созданный при этом попал в поле из которого была вызвана форма.
Ни разу такого не делал. Допустим с подменой выбора все понятно. А тут как?
 
 
   МимохожийОднако
 
1 - 28.10.19 - 16:24
(0) Используй расширение
   dezss
 
2 - 28.10.19 - 16:28
Как вариант делать через ВладелецФормы.
Не пойму, в чем именно сложность?
   toypaul
 
3 - 28.10.19 - 16:29
мне не нужно расширение. и для этой задачи оно вообще никаким боком
   toypaul
 
4 - 28.10.19 - 16:30
(2) сложность в отсутствии рабочего примера. самый непонятный момент - как передать созданный элемент в то поле откуда была вызвана моя новая форма
   МимохожийОднако
 
5 - 28.10.19 - 16:33
(4) Это уже вторая задача. Как догадаться откуда ты вызываешь нестандартную форму. Должен быть, обработчик события на форме ПриИзменении или ОкончанииРедактирования..
   toypaul
 
6 - 28.10.19 - 16:34
какое такое "ПриИзменении или ОкончанииРедактирования" если речь про обработчик Создание. не закончилось еще редактирование
   Kondarat
 
7 - 28.10.19 - 16:36
Оповестить() не?
   toypaul
 
8 - 28.10.19 - 16:39
(7) хотелось бы рабочий пример. угадайкой я уже пару часов занимаюсь.
   Kondarat
 
9 - 28.10.19 - 16:39
Покажи как открываешь форму нового элемента.
   Ёпрст
 
10 - 28.10.19 - 16:42
(0) так это ж штатное поведение платформы, зачем что-то кодить ? Если уф , то там либо выбрать, либо создать.. а если показать список, то после содания чего либо его и выбрать
   toypaul
 
11 - 28.10.19 - 16:43
(9)
Процедура ПервичнаяПотребностьПредметЗакупкиСоздание(Элемент, СтандартнаяОбработка)
    
    Если УП_ОбщегоНазначенияПовтИсп.РедактированиеКаталогаЧерезЗаявки() Тогда
    
        СтандартнаяОбработка = Ложь;
        ОткрытьФорму("Справочник.УП_КаталогПредметовЗакупкиЗаявка.ФормаОбъекта",,Элемент);
    
    КонецЕсли;
    
КонецПроцедуры
   МимохожийОднако
 
12 - 28.10.19 - 16:44
(11) Откуда вызываешь эту процедуру?
   toypaul
 
13 - 28.10.19 - 16:45
(10) мать моя женщина... ОБРАБОТЧИК СОЗДАНИЕ !!! какое такое список
   toypaul
 
14 - 28.10.19 - 16:46
народ. вы че тут все делаете если даже не знаете что такое обработчик Создание и откуда он вызывается?
   МимохожийОднако
 
15 - 28.10.19 - 16:46
(14) Ответь на (12)
   toypaul
 
16 - 28.10.19 - 16:47
(15) я ни откуда не вызываю. иди мимо :)
   toypaul
 
17 - 28.10.19 - 16:48
для образования необразованных

http://prntscr.com/pp6fkn
http://prntscr.com/pp6g6z
   Kondarat
 
18 - 28.10.19 - 16:48
(14) Да знаем, не шуми. Ты ж указал владельцем формы Элемент. После записи нового он не присваивается как значение владельцу?
   unenu
 
19 - 28.10.19 - 16:49
(11) наводки
ОбработкаПолученияФормы()
КопироватьДанныеФормы()
ЗначениеВДанныеФормы()
ЗначениеВРеквизитФормы()

читаем СП, пишем код
   toypaul
 
20 - 28.10.19 - 16:49
итак. вот открыл я свою форму. передал в нее Элемент

ОткрытьФорму("Справочник.УП_КаталогПредметовЗакупкиЗаявка.ФормаОбъекта",,Элемент);

, в который должен попасть созданный в этой форме элемент

как мне теперь передать-то его? если подменяем Выбор, то делаем ОповеститьОВыборе. а тут как?
   toypaul
 
21 - 28.10.19 - 16:51
(18) стандартный механизм насколько я понял присваивает не после записи, а после закрытия.

тут фишка еще в чем - у меня открывается форма совсем другого справочника. но в этом справочнике есть ссылка на нужный элемент. вот его мне и нужно передать. вопрос - как?
   toypaul
 
22 - 28.10.19 - 16:51
(19) выйди. ты не понял
   unenu
 
23 - 28.10.19 - 16:51
(21) ОткрытьФорму(<ИмяФормы>, <Параметры>, <Владелец>, <Уникальность>, <Окно>, <НавигационнаяСсылка>, <ОписаниеОповещенияОЗакрытии>, <РежимОткрытияОкна>)

ОписаниеОповещенияОЗакрытии - читаем СП, прекращем истерики
   unenu
 
24 - 28.10.19 - 16:53
(22) ошибаешься, я тебя вижу насквозь - тобой овладел лукавый.
покайся.
   МимохожийОднако
 
25 - 28.10.19 - 16:54
(16) Хамишь, парниша... Ты вызываешь свою процедуру из формы списка справочника. Вот оттуда и пляши.
   toypaul
 
26 - 28.10.19 - 17:02
вот так сработало

Процедура ПослеЗаписи(ПараметрыЗаписи)
    
    Если ЭтоНовый Тогда
    
        Если ЗначениеЗаполнено(Объект.СвязанныйЭлемент) Тогда
            ОповеститьОВыборе(Объект.СвязанныйЭлемент);
        КонецЕсли; 
    
    КонецЕсли; 
    
КонецПроцедуры
   Андроны едут
 
27 - 28.10.19 - 17:04
(0)  я в таких случаях  реквизиту назначаю  специальную Форму выбора. И не парюсь с программированием.


Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.