Вход | Регистрация
 
1С:Предприятие :: 1С:Предприятие 8 общая

помогите разобраться с планировщиком

помогите разобраться с планировщиком
Я
   Папай
 
28.10.19 - 14:13
добрый день.взял вот отсюда пример http://catalog.mista.ru/public/333903/   пытаюсь его подключить и посмотреть результаты работы,но не могу понять что такое РезультатПланы
Пока РезультатПланы.Следующий() Цикл
//----------------------------------
Планировщик.ТекущиеПериодыОтображения.Очистить();
Планировщик.ТекущиеПериодыОтображения.Добавить(ПериодОтображенияНачало, ПериодОтображенияКонец);

Измерения можно заполнить таким образом:

    // Инициализируем измерения планировщика
    ИзмеренияПланировщика   = Планировщик.Измерения;
    ИзмеренияПланировщика.Очистить();

    #Область Заполнение_магазинов
    // Создание группы Магазины
    ИзмерениеМагазины       = ИзмеренияПланировщика.Добавить("Магазины");
    Пока ВыборкаМагазинов.Следующий() Цикл

        // Добавление магазинов в группу Магазины
        НовыйМагазин = ИзмерениеМагазины.Элементы.Добавить(ВыборкаМагазинов.Магазин);
        НовыйМагазин.Текст = ВыборкаМагазинов.Магазин.Наименование;

    КонецЦикла;
    #КонецОбласти

    #Область Заполнение_продавцов
    // Создание измерения Продацы
    ИзмерениеПродавцы       = ИзмеренияПланировщика.Добавить("Продавцы");
    Пока ВыборкаПродавцов.Следующий() Цикл

        // Заполнение измерений продавцы
        НовыйПродавец = ИзмерениеПродавцы.Элементы.Добавить(ВыборкаПродавцов.Продавец);
        НовыйПродавец.Текст = ВыборкаПродавцов.Продавец.Наименование;

    КонецЦикла;
    #КонецОбласти

А вот так добавляем Элементы (записи в планировщике):

    // Инициализация элементов планировщика (записи по измерениям)
    ЭлементыПланировщика = Планировщик.Элементы;
    ЭлементыПланировщика.Очистить();

    Пока РезультатПланы.Следующий() Цикл

        // Связка записей с измерениями выполняется через соответствия
        СоответствиеЗначений = Новый Соответствие;
        СоответствиеЗначений.Вставить("Магазины",   РезультатПланы.Магазин);
        СоответствиеЗначений.Вставить("Продавцы",   РезультатПланы.Продавец);

        РазницаВремениНачало    = РезультатПланы.ВремяС     - НачалоДня(РезультатПланы.ВремяС);
        РазницаВремениКонец     = РезультатПланы.ВремяПо    - НачалоДня(РезультатПланы.ВремяПо);

        Начало  = НачалоДаты + РазницаВремениНачало;
        Конец   = НачалоДаты + РазницаВремениКонец;

        // Добавление новой записи в промежуток времени
        НовыйЭлемент = ЭлементыПланировщика.Добавить(Начало, Конец);
        НовыйЭлемент.ЗначенияИзмерений  = Новый ФиксированноеСоответствие(СоответствиеЗначений);
        НовыйЭлемент.Текст              = РезультатПланы.Задание;

    КонецЦикла;
//----------------------------------
 
 
   Vadim_37
 
1 - 28.10.19 - 14:21
ну скорее всего результат выполнения запроса
   Папай
 
2 - 28.10.19 - 14:46
(1)разве не это результат?Пока ВыборкаПродавцов.Следующий() Цикл
   Папай
 
3 - 28.10.19 - 14:46
результаты плана.какого плана....загадка.и скачать не могу с инфостара.нету мани(
   palsergeich
 
4 - 28.10.19 - 14:48
(3) на руборде недорого обработки за СМ качают
   Папай
 
5 - 28.10.19 - 14:57
(4)да что то не нашел там поищу.

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.