Вход | Регистрация
 
1С:Предприятие :: 1С:Предприятие 8 общая

Диаграмма Ганта что такое серия

Диаграмма Ганта  что такое серия
Я
   Папай
 
25.10.19 - 10:04
Добрый день.подскажите визуально что такое Серия.пытаюсь разобраться с Диаграммой
        ДиаграммаГанта.УстановитьСерию("Командировка");
делаю так.визуально нигде не видно  "Командировка" кроме как справа область легенды.Это и есть серия?
 
 
   hhhh
 
1 - 25.10.19 - 10:09
(0) да
   Папай
 
2 - 25.10.19 - 10:13
(1)как то тупо.потому что эту легенду можно скрыть и получается что серии нету?
   Папай
 
3 - 25.10.19 - 10:13
видишь суслика?Нет?а он есть))))
   hhhh
 
4 - 25.10.19 - 10:22
(3) попробуй 10 серий задать на графике этом. Ну или там 20. Увидишь, что такое точка, а что такое серия.
   Папай
 
5 - 25.10.19 - 10:24
(4)попробую спасибо.просто хотелось визуализации.А подскажите можно вместо цветной полоски вывести текст например реквизиты из документа?Пытаюсь на обычных формах реализовать примитивный гугл календарь.Диаграмма Ганта отдаленно напоминает.Но не то конечно.может подскажите что то типа Планировщика на управляемых формах,только для обычных?
   hhhh
 
6 - 25.10.19 - 10:26
(5) ну разные серии разным цветом фигачь. Например, синяя, красная, зеленая. У тебя будет куча разноцветных линий. Но это на обычном графике если. А диаграмма ганта - это там столбики какие-то будут наверно.
   Папай
 
7 - 25.10.19 - 10:33
а как подобие календаря организовать на ОФ?
   Папай
 
8 - 25.10.19 - 10:33
может таблицей значений?и красить ячейки с выводом туда информации?
   dezss
 
9 - 25.10.19 - 10:43
(8) Ну таб доком еще можно.
   Папай
 
10 - 25.10.19 - 10:44
(9)типа обычным отчетом?
   Папай
 
11 - 25.10.19 - 10:45
не заморачиваясь с таблицами значений и диаграммами
   dezss
 
12 - 25.10.19 - 10:45
(10) Зачем отчетом?
Я написал про табличный документ, а не отчет.
   Папай
 
13 - 25.10.19 - 10:50
(12)ну я образно.я понял печатная форма
   hhhh
 
14 - 25.10.19 - 11:06
(13) похоже вы у нашей Джуси секс задачу сперли, она тут всё календари красила:   Диаграмма Ганта в отчете с группировками.
   Папай
 
15 - 25.10.19 - 11:13
(14)к сожалению сам пришел к диаграмме ганта при создании календаря.но вижу что не подходит так как там просто интервалы а мне надо текст вместо полосок
   palsergeich
 
16 - 25.10.19 - 11:26
(15) так есть же планировщик
   dezss
 
17 - 25.10.19 - 11:47
И еще есть СтандартныйПериод. Вот он как раз и выводит календарь.
   Папай
 
18 - 25.10.19 - 11:57
(16)на обычных формах нету
   Папай
 
19 - 25.10.19 - 11:57
(17)подробнее можно?
   dezss
 
20 - 25.10.19 - 11:59
(19) Я не в курсе, есть ли он на ОФ, посмотри в СП про него.

Но вообще я когда-то рисовал в табдоке месяц, просто изучая присоединить и т.п.
Сча найду.
   dezss
 
21 - 25.10.19 - 12:02
(20) +
Во, нашел. Даже как-то слишком быстро). ТабДок - это реквизит формы. В макете просто 2 именованных строки с заданным размером и одна колонка.
        Макет = РеквизитФормыВЗначение("Объект").ПолучитьМакет("МакетКалендарь");
    ДеньЗаполнен = Макет.ПолучитьОбласть("ДеньЗаполнен|Колонка");
    ДеньПустой = Макет.ПолучитьОбласть("ДеньПустой|Колонка");
    
    НачДата = НачалоМесяца(ТекущаяДата());
    КонДата = КонецМесяца(ТекущаяДата());
    ТекДата = НачДата;
    
    Пустых = ДеньНедели(НачДата) - 1;
    
    ТабДокНеделя = Новый ТабличныйДокумент;
    
    Для й = 1 по Пустых Цикл 
        ТабДокНеделя.Присоединить(ДеньПустой);
    КонецЦикла;
    
    Первый = Истина;
    
    Пока ТекДата < КонДата Цикл 
        ТекДеньНедели = ДеньНедели(ТекДата);
        
        Если Не Первый И ТекДеньНедели = 1 Тогда
            ТабДок.Вывести(ТабДокНеделя);
            ТабДокНеделя = Новый ТабличныйДокумент;
            Первый = Ложь;
        КонецЕсли;
        
        ДеньЗаполнен.Параметры.ДеньЧислом = День(ТекДата);
        
        Если ТекДеньНедели = 6 Или ТекДеньНедели = 7 Тогда
            ДеньЗаполнен.Область("R1C1").ЦветФона = WebЦвета.Красный;
        Иначе
            ДеньЗаполнен.Область("R1C1").ЦветФона = Новый Цвет;
        КонецЕсли;
        
        ТабДокНеделя.Присоединить(ДеньЗаполнен);
        
        ТекДата = ТекДата + 60*60*24;
        Первый = Ложь;
    КонецЦикла;
    
    Для й = ТекДеньНедели+1 по 7 Цикл 
        ТабДокНеделя.Присоединить(ДеньПустой);
    КонецЦикла;
    
    ТабДок.Вывести(ТабДокНеделя);
   Папай
 
22 - 25.10.19 - 12:11
(21)спасибочки.попробую заполнить его из документа Заказ покупателя данными
   dezss
 
23 - 25.10.19 - 12:15
(22) Смотри, у меня только на 1 месяц заполнение. Я просто пробовал.
   Папай
 
24 - 25.10.19 - 12:19
(23)СПАСИБО!
   Папай
 
25 - 25.10.19 - 12:28
а табдок это у тебя поле табличного документа на форме?
   dezss
 
26 - 25.10.19 - 15:49
(25) В терминах ОФ, наверное да)))
Я ж писал, я с ОФ не особо. Было это давно и не очень долго.
Вообще это любой табличный документ.


Список тем форума
Рекламное место пустует  Рекламное место пустует
Оптимист верит, что мы живем в лучшем из миров. Пессимист боится, что так оно и есть.
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.