Вход | Регистрация
 

Вывод реквизитов табличной части формы списка на печатную форму.

Вывод реквизитов табличной части формы списка на печатную форму.
Я
   jojojoba2
 
24.10.19 - 12:33
Добрый день!

Помогите разобраться с выводом реквизитов табличной части на печатную форму. В документе(реквизиты каторого тянутся с другого ДокументСписок-Платежное поручениеВходящее) на форме списка есть колонки в которые выводятся данные с табличных частей документа :

Процедура СписокПриВыводеСтроки(Элемент, ОформлениеСтроки, ДанныеСтроки)
    
   Если ДанныеСтроки = Неопределено Тогда
        Возврат;
   КонецЕсли;
   Если ДанныеСтроки.Ссылка.РасшифровкаПлатежа.Количество() > 0 Тогда
        ОформлениеСтроки.Ячейки.ОстатокПоЗаказу.Значение = ДанныеСтроки.Ссылка.РасшифровкаПлатежа[0].Сделка ;
        ОформлениеСтроки.Ячейки.Сумма.Значение = ДанныеСтроки.Ссылка.РасшифровкаПлатежа[0].СуммаВзаиморасчетов + ДанныеСтроки.Ссылка.РасшифровкаПлатежа[0].СуммаНДС  ;

   Конецесли;
КонецПроцедуры



Пытаюсь создать печатную форму с выводом реквизитов с табличной части -  сделка , данные не выводятся.Выводятся только реквизиты документа.


Процедура Печать1(Элемент,ДанныеСтроки)
ТабДок = Новый ТабличныйДокумент;
Макет = Документы.ПлатежноеПоручениеВходящее.ПолучитьМакет("СчетЗаказ");
        
Выборка = Документы.Справки_расчеты_роялти.Выбрать();
Реквизиты = Макет.ПолучитьОбласть("Реквизиты");
Пока Выборка.Следующий() Цикл
Реквизиты.Параметры.Заполнить(Выборка);

ТабДок.Вывести(Реквизиты);
КонецЦикла;
ТабДок.ОтображатьСетку = Ложь;
ТабДок.Защита = Ложь;
ТабДок.ТолькоПросмотр = Ложь;
ТабДок.ОтображатьЗаголовки = Ложь;
ТабДок.Показать();
КонецПроцедуры


Как вывести на печать данные со всех колонок формы списка документа?
Можно ли как - то прикрутить что-то подобное на "вывести список" из меню документа?
И как сделать вывод документов с отбором по дате?

Спасибо.
 
 
   Ёпрст
 
1 - 24.10.19 - 12:58
(0) а чего, кнопка вывести список не спасает ?
   jojojoba2
 
2 - 24.10.19 - 13:06
Нужно создать печатную форму с дополнительной информацией.
   Ёпрст
 
3 - 24.10.19 - 13:06
(2) октрой для себя контруктор отчетов в пофигураторе

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.