Вход | Регистрация
 

Отметка Таблица значений

Отметка Таблица значений
Я
   Nemirov
 
23.10.19 - 14:57
На одной таблице значений отображается чекбокс на другой тз нет одна обработка, 2 страницы. В чем проблема?




Процедура ТП1ПриВыводеСтроки(Элемент, ОформлениеСтроки, ДанныеСтроки)
    
            ОформлениеСтроки.Ячейки.Отметка.ОтображатьФлажок = Истина;
            ОформлениеСтроки.Ячейки.Отметка.ОтображатьТекст  = Ложь;
                
            Если ДанныеСтроки.Отметка = Неопределено ИЛИ ДанныеСтроки.Отметка = Ложь Тогда
                ОформлениеСтроки.Ячейки.Отметка.Флажок = Ложь;
            Иначе
                ОформлениеСтроки.Ячейки.Отметка.Флажок = Истина;
            КонецЕсли;

        КонецПроцедуры
        
Процедура ТП2ПриВыводеСтроки(Элемент, ОформлениеСтроки, ДанныеСтроки)
    
        ОформлениеСтроки.Ячейки.Отметка.ОтображатьФлажок = Истина;
        
        ОформлениеСтроки.Ячейки.Отметка.ОтображатьТекст  = Ложь;
    Если ДанныеСтроки.Отметка = Неопределено ИЛИ ДанныеСтроки.Отметка = Ложь Тогда
            ОформлениеСтроки.Ячейки.Отметка.Флажок = Ложь;
    Иначе
            ОформлениеСтроки.Ячейки.Отметка.Флажок = Истина;
        
    
    КонецЕсли;
    
КонецПроцедуры
 
 

Список тем форума
Рекламное место пустует  Рекламное место пустует
Закон Брукера: Даже маленькая практика стоит большой теории.
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.