Вход | Регистрация
 

Процедура при выводе строки

Процедура при выводе строки
Я
   Nemirov
 
22.10.19 - 11:34
Проблема с отметкой  на первой тз она отображается https://ibb.co/CQY2w5Z
А на второй нет https://ibb.co/PY80bK2 Где ошибка?
 
 
   Nemirov
 
1 - 22.10.19 - 11:34
Процедура ПриОткрытии()
    ///Для ТЗ По Номенклатуре    

    Запрос = Новый Запрос;
    Запрос.Текст = 
    "ВЫБРАТЬ
    | ЛОЖЬ КАК Отметка,
    |    РезервРЦ.Номенклатура КАК Номенклатура,
    |    РезервРЦ.Характеристика КАК Характеристика,
    |    РезервРЦ.ЗарезервированоЗа КАК ЗарезервированоЗа,
    |    РезервРЦ.ЕдиницаИзмерения КАК ЕдиницаИзмерения,
    |    РезервРЦ.ПоДокументу КАК ПоДокументу,
    |    РезервРЦ.Количество КАК Количество
    |ИЗ
    |    РегистрСведений.РезервРЦ КАК РезервРЦ";
    
    ТП1 = Запрос.Выполнить().Выгрузить();
    ЭлементыФормы.ТП1.СоздатьКолонки();
    ////Для ТЗ По Документу       

    ЗРП = Новый Запрос;
    ЗРП.Текст = 
        "ВЫБРАТЬ
        |    ЛОЖЬ КАК Отметка2,
        |    РезервРЦ.ПоДокументу КАК ПоДокументу,
        |    КОЛИЧЕСТВО(РАЗЛИЧНЫЕ РезервРЦ.Количество) КАК Количество
        |ИЗ
        |    РегистрСведений.РезервРЦ КАК РезервРЦ
        |
        |СГРУППИРОВАТЬ ПО
        |    РезервРЦ.ПоДокументу";
    ТП2 = ЗРП.Выполнить().Выгрузить();
    ЭлементыФормы.ТП2.СоздатьКолонки()


КонецПроцедуры



Процедура ОсновныеДействияФормыУдалить(Кнопка,Объект)     
    
    Для Каждого Строка Из ТП1 Цикл  
        Если Строка.Отметка Тогда
            НаборЗаписей = РегистрыСведений.РезервРЦ.СоздатьНаборЗаписей();
            НаборЗаписей.Отбор.Номенклатура.Установить(Строка.Номенклатура);
            НаборЗаписей.Отбор.Характеристика.Установить(Строка.Характеристика);
            НаборЗаписей.Отбор.ЕдиницаИзмерения.Установить(Строка.ЕдиницаИзмерения);
            НаборЗаписей.Отбор.ЗарезервированоЗа.Установить(Строка.ЗарезервированоЗа);
            НаборЗаписей.Отбор.ПоДокументу.Установить(Строка.ПоДокументу);
            
            
            Если НаборЗаписей.Количество() > 0 Тогда
                НаборЗаписей.Удалить(НаборЗаписей[0]);
            КонецЕсли;  
            НаборЗаписей.Записать();
            НаборЗаписей.Прочитать();
        КонецЕсли;
        Запрос = Новый Запрос;
        Запрос.Текст = 
        "ВЫБРАТЬ
        | ЛОЖЬ КАК Отметка,
        |    РезервРЦ.Номенклатура КАК Номенклатура,
        |    РезервРЦ.Характеристика КАК Характеристика,
        |    РезервРЦ.ЗарезервированоЗа КАК ЗарезервированоЗа,
        |    РезервРЦ.ЕдиницаИзмерения КАК ЕдиницаИзмерения,
        |    РезервРЦ.ПоДокументу КАК ПоДокументу,
        |    РезервРЦ.Количество КАК Количество
        |ИЗ
        |    РегистрСведений.РезервРЦ КАК РезервРЦ";
        
        ТП1 = Запрос.Выполнить().Выгрузить();
        ЭлементыФормы.ТП1.СоздатьКолонки();
    КонецЦикла;
    
КонецПроцедуры

Процедура ТП1ПриВыводеСтроки(Элемент, ОформлениеСтроки, ДанныеСтроки)
    
            ОформлениеСтроки.Ячейки.Отметка.ОтображатьФлажок = Истина;
            ОформлениеСтроки.Ячейки.Отметка.ОтображатьТекст  = Ложь;
                
            Если ДанныеСтроки.Отметка = Неопределено ИЛИ ДанныеСтроки.Отметка = Ложь Тогда
                ОформлениеСтроки.Ячейки.Отметка.Флажок = Ложь;
            Иначе
                ОформлениеСтроки.Ячейки.Отметка.Флажок = Истина;
            КонецЕсли;

     КонецПроцедуры
Процедура ТП2ПриВыводеСтроки(Элемент, ОформлениеСтроки, ДанныеСтроки)
    ОформлениеСтроки.Ячейки.Отметка2.ОтображатьФлажок = Истина;
        ОформлениеСтроки.Ячейки.Отметка2.ОтображатьТекст  = Ложь;
    Если ДанныеСтроки.Отметка2 = Неопределено ИЛИ ДанныеСтроки.Отметка2 = Ложь Тогда
            ОформлениеСтроки.Ячейки.Отметка2.Флажок = Ложь;
    Иначе
            ОформлениеСтроки.Ячейки.Отметка2.Флажок = Истина;
        
    
    КонецЕсли;
    
КонецПроцедуры
Процедура ТП1ПриИзмененииФлажка(Элемент, Колонка)
    
    Если Элемент.ТекущаяСтрока.Отметка Тогда
        Элемент.ТекущаяСтрока.Отметка = Ложь
    Иначе
        Элемент.ТекущаяСтрока.Отметка= Истина;
    КонецЕсли;

КонецПроцедуры 
Процедура ТП2ПриИзмененииФлажка(Элемент, Колонка)
        Если Элемент.ТекущаяСтрока.Отметка2 Тогда
        Элемент.ТекущаяСтрока.Отметка2 = Ложь
    Иначе
        Элемент.ТекущаяСтрока.Отметка2= Истина;
    КонецЕсли;

КонецПроцедуры
Процедура ВыбратьВсеНажатие(Элемент)
    
    Для каждого Строка Из ТП1 Цикл
        Строка.Отметка = Истина;
    КонецЦикла;
    ЭлементыФормы.ТП1.СоздатьКолонки();
    
    Для каждого Строка Из ТП1 Цикл
        Строка.Отметка2 = Истина;
    КонецЦикла;
    ЭлементыФормы.ТП2.СоздатьКолонки();

КонецПроцедуры
Процедура СнятьВсеНажатие(Элемент)
    
    Для каждого Строка Из ТП1 Цикл
        Строка.Отметка = Ложь;
    КонецЦикла;
    ЭлементыФормы.ТП1.СоздатьКолонки(); 
    Для каждого Строка Из ТП2 Цикл
        Строка.Отметка2 = Ложь;
    КонецЦикла;
    ЭлементыФормы.ТП2.СоздатьКолонки();
КонецПроцедуры
   Ёпрст
 
2 - 22.10.19 - 12:58
(0) выкинуть все ПриВыводеСтроки и ПриИзмененииФлажка

И так, хотя бы

https://cloud.mail.ru/public/3W6v/515jqjrw2

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.