Вход | Регистрация
 
1С:Предприятие :: 1С:Предприятие 8 общая

Обработка печатной формы WORD клиент-сервер УФ БП 3.0

Обработка печатной формы WORD клиент-сервер УФ БП 3.0
Я
   skupidom
 
21.10.19 - 15:14
ОбщийМодуль.УправлениеПечатью.Модуль(1510)}: Метод объекта не обнаружен (Печать)
ФормаОбработки.Печать(ВыполняемаяКоманда.Идентификатор, ОбъектыНазначения) при печати внешней печатной формы Word
 
 
   Happy Bear
 
1 - 21.10.19 - 15:18
(0) а форма обработки есть? а метод Печать есть?
   skupidom
 
2 - 21.10.19 - 15:31
форма обработки есть и метод Печать есть
   skupidom
 
3 - 21.10.19 - 15:31
&НаКлиенте
Процедура Печать(ИдентификаторКоманды,МассивОбъектов) Экспорт
     
    Для Каждого Элемент Из МассивОбъектов Цикл        
        СобратьМакет(Элемент);
    КонецЦикла;
    
КонецПроцедуры
   Happy Bear
 
4 - 21.10.19 - 15:52
(2) форма назначена основной? выложи листинг функции СведенияОВнешнейОбработке
   skupidom
 
5 - 21.10.19 - 15:58
Функция СведенияОВнешнейОбработке() Экспорт
    
    ПараметрыРегистрации = Новый Структура;
    МассивНазначений = Новый Массив;
    МассивНазначений.Добавить("Справочник.Сотрудники");
    ПараметрыРегистрации.Вставить("Вид", "ПечатнаяФорма");    
    ПараметрыРегистрации.Вставить("Назначение", МассивНазначений);
    ПараметрыРегистрации.Вставить("Наименование", "Трудовой договор с сотрудником ВНЕШНИЙ(WORD)");                              
    ПараметрыРегистрации.Вставить("БезопасныйРежим",ЛОЖЬ);
    ПараметрыРегистрации.Вставить("Версия", "1.0");    
    ПараметрыРегистрации.Вставить("Информация", "Трудовой договор с сотрудником ВНЕШНИЙ(WORD)");   
    ТаблицаКоманд = ПолучитьТаблицуКоманд();
    ДобавитьКоманду(ТаблицаКоманд, "Трудовой договор с сотрудником ВНЕШНИЙ(WORD)","ТрудовойДоговорССотрудником","ВызовКлиентскогоМетода",Истина,"ПечатьMXL");
    ПараметрыРегистрации.Вставить("Команды", ТаблицаКоманд);
    
    Возврат ПараметрыРегистрации;
    
КонецФункции
   Happy Bear
 
6 - 21.10.19 - 16:04
а форма основной назначена?
   skupidom
 
7 - 21.10.19 - 16:06
да, написано надо делать макет через двоичные данные
   skupidom
 
8 - 21.10.19 - 16:11
у меня шаблон макета word: <КраткоеНаименованиеОрганизации>, именуемое в дальнейшем "Работодатель", в лице <ДолжностьРуководителя> <Руководитель> загружаю этот шаблон в макет с типом макета двоичные данные, при печати выходит только сообщение, word не открывается
   Масянька
 
9 - 21.10.19 - 16:13
(8) Ты выясни - ошибка в открытии ворда или чем-то другом.
   skupidom
 
10 - 21.10.19 - 16:15
пишет: команда выполняется Трудовой договор ..
   skupidom
 
11 - 21.10.19 - 16:16
ВариантЗапуска = Вызов клиентского метода
   Масянька
 
12 - 21.10.19 - 16:16
(10) Покажи код с командой.
   skupidom
 
13 - 21.10.19 - 16:17
который в обработке ?
   skupidom
 
14 - 21.10.19 - 16:18
ВыполнитьНазначаемуюКомандуПечати из общего модуля ДополнительныеотчетыиОбработкиКлиент?
   Масянька
 
15 - 21.10.19 - 16:18
(13) Процедура ВыполнитьКоманду(ИдентификаторКоманды, ОбъектыНазначенияМассив) Экспорт
или у тебя что-то другое?
   skupidom
 
16 - 21.10.19 - 16:20
из какого общего модуля ?
   skupidom
 
17 - 21.10.19 - 16:23
ВыполняемаяКоманда.Идентификатор = ТрудовойДоговорССотрудником, ОбъектыНазначения = сотрудник с типом СправочникСсылка.Сотрудники
   skupidom
 
18 - 21.10.19 - 16:23
в моей обработке она в основной форме &НаКлиенте
Процедура Печать(ИдентификаторКоманды,МассивОбъектов) Экспорт
     
    Для Каждого Элемент Из МассивОбъектов Цикл        
        СобратьМакет(Элемент);
    КонецЦикла;
    
КонецПроцедуры
   Масянька
 
19 - 21.10.19 - 16:35
(18) Я делала внешнюю команду. С печ. формой еще не возилась.
Погугли - примеров масса. Не легко (на предыдущих версиях 1Сбыло намного проще и легче), но вполне по силам.
Тут - https://programmist1s.ru/vneshnie-pechatnyie-formyi-v-1s/#i - (по-моему) проще расписано.
   skupidom
 
20 - 21.10.19 - 16:43
может есть у кого пример подобной обработки ?

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.