Вход | Регистрация
 

Выполнение регламентного задания

Выполнение регламентного задания
Я
   shadow1337
 
19.10.19 - 00:17
У меня есть регламентное задание "ОтправкаНапоминаний" со следующими свойствами:
http://ipic.su/img/img7/fs/Skrinshot(19.1571433135.jpg

Код самого регламентного задания представлен ниже. Суть в том, что это регламентное задание вызывает метод "ПоставитьПисьмоВОчередьНаОтправку", который записывает в регистр запись об отправке почты, а уже из пользовательского режима нажатием нужной клавиши можно отправить сообщение.

Процедура ОтправкаНапоминаний() Экспорт

    Получатели = Справочники.Параметры.НайтиПоНаименованию("ПолучателиПланаПроизводства").Строка;
    ТемаПисьма = "НАПОМИНАНИЕ! Сумма плана производства";
    ТекстПисьма = "В течение 3 часов необходимо предоставить Кузнецовой ВМ актуальную информацию по сумме плана производства на ближайшие 4 месяца для формирования отчета ""Загрузка производства СЭТЗ"".";
    РаботаСПочтой.ПоставитьПисьмоВОчередьНаОтправку(Получатели, ТемаПисьма, ТекстПисьма);    

КонецПроцедуры


Собственно в чем проблема: регламентное задание не работает и непонятно для меня почему. Если я делаю внешнюю обработку, которая вызывает соответственный метод, то записать происходит единоразово, т.е. все работает. Но делать такие записи каждые 3 секунды (к примеру) у меня не получается. Что я делаю не так?
 
 
   Консультант Баранов
 
1 - 19.10.19 - 00:22
Где выполняется отправка в обработке на клиенте или на сервере?

> Но делать такие записи каждые 3 секунды (к примеру) у меня не получается.

Если база файловая меньше 60 сек. не получится.
   shadow1337
 
2 - 19.10.19 - 00:32
(1) База клиент-серверная, отправка во внешней обработке тоже выполняется на сервере
   shadow1337
 
3 - 19.10.19 - 00:44
(1) Если поподробнее, на внешней обработке есть кнопка, я жму на нее и собственно вызываю на сервере процедуру, которая уже в свою очередь вызывает процедуру "ОтправкаНапоминаний" из модуля "ВыполнениеРегламентныхЗаданий". А вот уже из нее вызывается "ПоставитьПисьмоВОчередьНаОтправку" (пример выше)

Вот код внешней обработки:

&НаСервере
Процедура Команда1НаСервере()
    ВыполнениеРегламентныхЗаданий.ОтправкаНапоминаний();
    // Вставить содержимое обработчика.

КонецПроцедуры


&НаКлиенте
Процедура Команда1(Команда)
    Команда1НаСервере();
КонецПроцедуры
   shadow1337
 
4 - 19.10.19 - 00:45
(1) Но таким образом все получается единоразово, это было для тестирования. А мне нужно чтобы это было регламентным заданием
   Галахад
 
5 - 19.10.19 - 05:58
Настройка в (0), если я правильно понимаю, выполнена в конфигураторе?
Если посмотреть со стороны предприятия как выглядит настройка?
   shadow1337
 
6 - 20.10.19 - 11:39
(5) А о чем именно речь? Я только в конфигураторе сделал то, что написал выше. То есть в моем понимании, каждые 3 секунды теперь в регистр должна заноситься запись с почтовыми адресами, но ничего не происходит. В пользовательском режиме я ничего не делал.
   shadow1337
 
7 - 20.10.19 - 20:32
(5) Я должен что-то нажать в конфигураторе, чтобы регламентное задание выполнилось?
   Михаил Козлов
 
8 - 20.10.19 - 22:48
Проверьте выполнение регламентного задания в приложении в разделе НСИ и администрирование->Обслуживание->Регламентные задания.

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.