Вход | Регистрация
 
1С:Предприятие :: 1С:Предприятие 8 общая

Запрос вывода данных с табличной части в форму списка документа

Запрос вывода данных с табличной части в форму списка документа
Я
   jojojoba2
 
18.10.19 - 12:16
Добрый день!

1с8.3 УПП. Необходимо создать запрос чтобы вывести информацию о  заказе покупателя (документ-Платежное поручение исходящее) в колонку формы списка.


          
      МассивЗаказов = Новый Массив;
    Для Каждого Стр Из ОформленияСтрок Цикл
        МассивЗаказов.Добавить(Стр.ДанныеСтроки.Ссылка);
    КонецЦикла;
    // Формируем запрос к остаткам заказов
    Запрос = Новый Запрос;
    Запрос.Текст =
"ВЫБРАТЬ
               |    Справки_расчеты_роялти.РасшифровкаПлатежа.(
               |        Сделка
               |    )
               |ИЗ
               |    Документ.Справки_расчеты_роялти.РасшифровкаПлатежа КАК Справки_расчеты_роялти
               |ГДЕ
               |    Справки_расчеты_роялти.Сделка В(&МассивСсылок)";


    
    Запрос.УстановитьПараметр("МассивСсылок", МассивЗаказов);
    Результат = Запрос.Выполнить();
    Выборка = Результат.Выбрать();
    Выборка.Следующий();

Для Каждого Стр Из ОформленияСтрок Цикл
Стр.Ячейки.ОстатокПоЗаказу.Значение = Выборка.Сделка;
КонецЦикла

КонецПроцедуры


1С ругается - поле не найдено.

--- может кто знает   Стр.Ячейки.ОстатокПоЗаказу.Значение = Выборка.Сделка;  правильно ли для вывода данных в ячейку с запроса.
--- как правильно составить запрос для табличной части и механизм вывода в колонку

---Для Каждого Стр Из ОформленияСтрок Цикл
Стр.Ячейки.ОстатокПоЗаказу.Значение = Выборка.Сделка;
КонецЦикла
Этого достаточно или еще нужны какие-то параметры


Программист я  начинающий, помогайте кто чем может.
Спасибо.
 
 
   Ёпрст
 
1 - 18.10.19 - 12:29
(0) ну, запрос твой явно не рабочий. Открой его хотя бы конструктором
   KolPecivanovich
 
2 - 18.10.19 - 12:44
"ВЫБРАТЬ 
               |    Сделка 
               |ИЗ 
               |    Документ.Справки_расчеты_роялти.РасшифровкаПлатежа КАК Справки_расчеты_роялти 
               |ГДЕ 
               |    Справки_расчеты_роялти.Сделка В(&МассивСсылок)";
   KolPecivanovich
 
3 - 18.10.19 - 12:48
--- может кто знает   Стр.Ячейки.ОстатокПоЗаказу.Значение = Выборка.Сделка;  правильно ли для вывода данных в ячейку с запроса.

если ОстатокПоЗаказу - тип Число, то туда не получится присвоить сделку
   KolPecivanovich
 
4 - 18.10.19 - 12:51
используйте событие списка ПриПолученииДанных()
   jojojoba2
 
5 - 18.10.19 - 15:13
Нужно вывести из табличной части РасшифровкаПлатежа информацию о заказе покупателя в строку формы списка документа ПлатежноеПоручениеИсходящее

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.