Вход | Регистрация
 

Добавление команды в отчет

Добавление команды в отчет
Я
   LivingStar
 
18.10.19 - 12:04
Разрабатываю отчет. Добавил его в состав конфигурации. Поместил в хранилище.
Сейчас говорят у отчета нужно сделать команду. Подскажите пожалуйста как у отчета сделать команду ?
 
 
   Kigo_Kigo
 
1 - 18.10.19 - 12:06
кто говорит, когда говорит, зачем говорит?
   LivingStar
 
2 - 18.10.19 - 12:07
(1) Для выполнения задачи. Команду как в отчет добавить? Это несколько новое для меня.
   LivingStar
 
3 - 18.10.19 - 12:07
(2+) Что в ней прописывать, как создавать?
   Kigo_Kigo
 
4 - 18.10.19 - 12:09
(3) хоть написал бы ОФ или УФ?
   spiller26
 
5 - 18.10.19 - 12:09
(3) Если она уже в конфигурации в неё ничего не нужно прописывать.
Если вы хотите разместить где то то это уже другое.
   Kigo_Kigo
 
6 - 18.10.19 - 12:09
и скин давай, где пишет
   МимохожийОднако
 
7 - 18.10.19 - 12:13
(3) По правой клавише мыши в ветке отчета в подразделе Команды
   Kigo_Kigo
 
8 - 18.10.19 - 12:15
Может - интерфейсы -команды
   LivingStar
 
9 - 18.10.19 - 12:41
(4) Конечно управляемые формы, интерфейс такси.
   spiller26
 
10 - 18.10.19 - 12:46
(9) Пихани в Подсистемы. Там есть такое понятие как "Состав"
   spiller26
 
11 - 18.10.19 - 12:47
(10) Ещё там же в "Подсистеме" есть "Командный интерфейс" для отображения
   LivingStar
 
12 - 18.10.19 - 12:49
(11) Да. Команда у отчета нужна для вывода в командный интерфейс.
   LivingStar
 
13 - 18.10.19 - 12:50
(10) Я добавил отчет в 2 подсистемы, по подобию другого отчета.
   LivingStar
 
14 - 18.10.19 - 12:54
Вот общая команда, для отчета по подобию которого я делаю.
Мне нужно добавить команду в отчет.

Подскажите пожалуйста как правильно это сделать? Там такой же код ?


#Область ОбработчикиСобытий 

 

&НаКлиенте
Процедура ОбработкаКоманды(ПараметрКоманды, ПараметрыВыполненияКоманды)
    
    ПараметрыФормы = Новый Структура("ИсточникОтчета, ПериодичностьОтчета", "РегламентированныйОтчетЖурналУчетаСтационарныхИЗАИИхХарактеристик",ПредопределенноеЗначение("Перечисление.ДоступныеПериодыОтчета.Год"));
    ОткрытьФорму("Документ.РегламентированныйОтчет.ФормаСписка", ПараметрыФормы, ПараметрыВыполненияКоманды.Источник, ПараметрыВыполненияКоманды.Уникальность, ПараметрыВыполненияКоманды.Окно, ПараметрыВыполненияКоманды.НавигационнаяСсылка);
    
КонецПроцедуры

#КонецОбласти
   spiller26
 
15 - 18.10.19 - 12:54
(13) Да нужна создай в "Общие команды" новую и пропиши в модуле команды

&НаКлиенте
Процедура ОбработкаКоманды(ПараметрКоманды, ПараметрыВыполненияКоманды)
    
    ПараметрыФормы = Новый Структура("", );
    ОткрытьФорму("Отчет.ТвойОтчет.Форма", ПараметрыФормы, ПараметрыВыполненияКоманды.Источник, Истина, ПараметрыВыполненияКоманды.Окно, ПараметрыВыполненияКоманды.НавигационнаяСсылка);
    
КонецПроцедуры
   LivingStar
 
16 - 18.10.19 - 12:56
(15) Мне нужно создать у отчета команду. В общих нельзя !
Подскажите пожалуйста как у отчета создать команду и что в неё будет?
   spiller26
 
17 - 18.10.19 - 12:57
(16) Почему нельзя?
   spiller26
 
18 - 18.10.19 - 12:58
(16) Зачем вы тогда её в конфигурацию внедряете, для чего? Сделали бы внешним отчетом и не парились.
   LivingStar
 
19 - 18.10.19 - 13:08
(18) Я работаю по постановке задачи. Такая постановка.
Сделать не общую а команду отчета.
Я прописал добавление отчета в справочник в общем модуле. Добавил в подсистемы.
Сейчас нужно создать команду у отчета, это же можно сделать.
Подскажите пожалуйста как. Что будет в команде и как она создается? В ней будет код как в (14) ?
   spiller26
 
20 - 18.10.19 - 13:13
У меня слов нет.
"Общая команда" нужна для того чтобы её запускали в интерфейсе.
А у вас получается, что нужно вызвать из какого либо объекта, так в объекте её и вызывайте тогда.
   LivingStar
 
21 - 18.10.19 - 13:21
(20) говорят её нужно создать у отчета и у него будет такой же код как в (14)
   LivingStar
 
22 - 18.10.19 - 13:27
ну сказали зачем её делать общей, когда можно сделать то же самое у отчета, и код такой же
   LivingStar
 
23 - 18.10.19 - 14:38
Добавил команду, как отчет теперь увидеть в интерфейсе?
   LivingStar
 
24 - 18.10.19 - 14:45
Команду у отчета сделал вот такую, по подобию той что общая, для отчета на подобие которого я делал свой.


#Область ОбработчикиСобытий

&НаКлиенте
Процедура ОбработкаКоманды(ПараметрКоманды, ПараметрыВыполненияКоманды)
    ПараметрыФормы = Новый Структура("ИсточникОтчета, ПериодичностьОтчета", "РегламентированныйОтчетЖурналУчетаРаботыГиПУстановок",ПредопределенноеЗначение("Перечисление.ДоступныеПериодыОтчета.Год"));
    ОткрытьФорму("Документ.РегламентированныйОтчет.ФормаСписка", ПараметрыФормы, ПараметрыВыполненияКоманды.Источник, ПараметрыВыполненияКоманды.Уникальность, ПараметрыВыполненияКоманды.Окно, ПараметрыВыполненияКоманды.НавигационнаяСсылка);
КонецПроцедуры


#КонецОбласти


Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.