Вход | Регистрация
 
1С:Предприятие :: 1С:Предприятие 8 общая

Картинка на форме не очищается, в чем может быть причина?

Картинка на форме не очищается, в чем может быть причина?
Я
   KIraA
 
18.10.19 - 10:02
Добрый...
8.3 УФ. Есть таблица в ней несколько путей на картинки (типа E:\Картинки\DC00000003208.jpg и т.д). Отдельно на форме есть реквизит Объект.Фото ТИП (строка), вид(картинка). И реквизит УникальныйИд(строка).
Так вот код при активации строки, подгружаю картинку...

&НаКлиенте
Процедура ДанныеПриАктивизацииСтроки(Элемент)
    Если ЗначениеЗаполнено(Элементы.Данные.ТекущиеДанные.ПутьККартинке) Тогда;
        Путь = Элементы.Данные.ТекущиеДанные.ПутьККартинке;
        УстановитьКартинку(Путь);
    КонецЕсли;
    
КонецПроцедуры


&НаСервере
Процедура УстановитьКартинку(Путь)
        
    ПутьККартинке =  Путь;
    Картинка = Новый Картинка(ПутьККартинке);
    
    Если Объект.УникальныйИд <> "" Тогда
        УдалитьИзВременногоХранилища(Объект.УникальныйИд);
    КонецЕсли;
    АдресВоВременномХранилище = ПоместитьВоВременноеХранилище(Картинка, Новый УникальныйИдентификатор);

    Объект.УникальныйИд = АдресВоВременномХранилище ;
    Объект.Фото = АдресВоВременномХранилище;
    
КонецПроцедуры


Картинка то появляется, но когда я выбираю последующие, то картинки у меня накладываются одна на одну, хотя я ведь временное хранилище по старому "УникальныйИд" очищаю? Подскажите решение???
 
 
   KIraA
 
1 - 24.10.19 - 08:56
АП

ну может буду  идеи?
Уже делаю вот так...а на форме все равно куча картинок в одном окошке

Путь = C:\1С\ПОСТАВЩИКИ\111.jpg

&НаСервере
Процедура УстановитьКартинку(Путь)
    Путь = 
    Если Объект.Фото <>""Тогда
        рез = ЭтоАдресВременногоХранилища(Объект.Фото);
        УдалитьИзВременногоХранилища(Объект.Фото);
        Объект.Фото = "";
    КонецЕсли;
    
    ФаилНаДиске = Новый Файл(Путь);
    
    Если ФаилНаДиске.Существует() Тогда                           
        Объект.Фото = ПоместитьВоВременноеХранилище(Неопределено, ЭтаФорма.УникальныйИдентификатор);
        Объект.Фото = ПоместитьВоВременноеХранилище(Новый Картинка(Путь, Истина), ЭтаФорма.УникальныйИдентификатор);
    КонецЕсли;
        
    
КонецПроцедуры


Хранилище значений не использую, т.к. желание руководства хранить картинки на сервере с правом чтения и без раздувания базы.

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.