Вход | Регистрация
 
1С:Предприятие :: 1С:Предприятие 8 общая

Как активировать проводки документа операция програмно?

Как активировать проводки документа операция програмно?
Я
   Обработка
 
17.10.19 - 10:07
Вот так мне не помогло

Для Каждого НаборЗаписей Из Объект.Движения Цикл
    НаборЗаписей.Прочитать();
    НаборЗаписей.УстановитьАктивность(Истина);
    НаборЗаписей.Записать();
КонецЦикла;


Вот так тоже не помогает



НаборЗаписейБУ = РегистрыБухгалтерии.Типовой.СоздатьНаборЗаписей();
   НаборЗаписейБУ.Отбор.Регистратор.Использование = Истина;
   НаборЗаписейБУ.Отбор.Регистратор.Значение = Объект.ссылка;
   НаборЗаписейБУ.Прочитать();
   Для Каждого ЗаписьБУ Из НаборЗаписейБУ Цикл
  ЗаписьБУ.СтруктурноеПодразделениеДт = Объект.СтруктурноеПодразделение;
  ЗаписьБУ.СтруктурноеПодразделениеКт = Объект.СтруктурноеПодразделение;
   КонецЦикла;
  
      НаборЗаписейБУ.Записать();
НаборЗаписейБУ.УстановитьАктивность(Истина);

Даже местами менял

НаборЗаписейБУ.УстановитьАктивность(Истина);
НаборЗаписейБУ.Записать();
 
 
   Cyberhawk
 
1 - 17.10.19 - 10:09
Ну подгляди в коде кнопки в этом документе, которая меняет активность
   ДенисЧ
 
2 - 17.10.19 - 10:09
Для Каждого ЗаписьБУ Из НаборЗаписейБУ Цикл 
  ЗаписьБУ.Активность = Истина;
  ЗаписьБУ.СтруктурноеПодразделениеДт = Объект.СтруктурноеПодразделение; 
  ЗаписьБУ.СтруктурноеПодразделениеКт = Объект.СтруктурноеПодразделение; 
   КонецЦикла; 

?
   Обработка
 
3 - 17.10.19 - 10:19
(1) кнопка работает с формой. всякие там картинки и пиктораммы меняет.

но чтоб с набором записей работал пока не увидел
   palsergeich
 
4 - 17.10.19 - 10:21
А чем проверял? Запросом или проводки документа смотрел? У меня просто стандартный отчёт багался и без переоткрытия не обновлял данные.
Вариант 2 хитрая подписка в РБ
   Обработка
 
5 - 17.10.19 - 10:24
(4) ОСВ нет просто по ним нет данные.
   Обработка
 
6 - 17.10.19 - 10:24
() попробовал не помогло.
   Обработка
 
7 - 17.10.19 - 10:24
(2) попробовал не помогло.
   Обработка
 
8 - 17.10.19 - 10:28
Открываю отперацию пиктограмки цветные не серые типа включенные.
Но в ОСВ нет по ним движения.

А вот если на кнопку выключить и включить и потом записать документ то все норм.
Получается только интерактивно.
   drcrasher
 
9 - 17.10.19 - 10:36
смотри модуль объекта СинхронизироватьАктивностьДвиженийСПометкойУдаления()
   Обработка
 
10 - 17.10.19 - 10:59
(9) не помогло
упростил так


Для Каждого Движение Из Объект.Движения Цикл
        
        Движение.Прочитать();

        
        Для Каждого Строка Из Движение Цикл
            
            
            Строка.Активность   = Истина;
            Движение.Записывать = Истина; 
            
        КонецЦикла;
        
    КонецЦикла;


не взлетел...
   Обработка
 
11 - 17.10.19 - 11:50
куда мне копать коллеги?
   palsergeich
 
12 - 17.10.19 - 11:53
(11) события набора записей и подписки

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.