Вход | Регистрация
 
1С:Предприятие :: 1С:Предприятие 8 общая

Изменение объектов регламентным заданием

Изменение объектов регламентным заданием
Я
   Zupbp
 
16.10.19 - 09:10
Регламентные задания 1С могут получать изменять и записывать объекты ИБ (справочники, документы)? Задание выполнено без ошибок, но никакие объекты не изменены. В вем может быть причина?
 
 
   piter3
 
1 - 16.10.19 - 09:12
Могут.Нормально описание сделайте
   dka80
 
2 - 16.10.19 - 09:13
Могут.
Нет метода Записать(), например.
Выполнено без ошибок означает, что не возникло критических ошибок. Но это не значит, что код задания написан сколь-нибудь корректно. Отладчиком уже конечно же заходили?
   Zupbp
 
3 - 16.10.19 - 09:23
Максимально просто:
Процедура ВыполнитьОбработку() Экспорт

    Запрос = Новый Запрос;
    Запрос.Текст = "ВЫБРАТЬ РАЗЛИЧНЫЕ
                   |    СправочникНоменклатура.Ссылка КАК Ссылка
                   |ИЗ
                   |    Справочник.Номенклатура КАК СправочникНоменклатура
                   |ГДЕ
                   |    СправочникНоменклатура.Наименование ПОДОБНО ""%удалить%""";
    Выборка = Запрос.Выполнить().Выбрать();
    Пока Выборка.Следующий() Цикл
        Если ЗначениеЗаполнено(Выборка.Ссылка) Тогда
            ОбъектНоменклатура = Выборка.Ссылка.ПолучитьОбъект();
            ОбъектНоменклатура.Наименование = СтрЗаменить(ОбъектНоменклатура.Наименование, "удалить", "");
            ОбъектНоменклатура.Записать();
        КонецЕсли;    
    КонецЕсли;        
        
КонецПроцедуры
   Zupbp
 
4 - 16.10.19 - 09:24
Если вручную нажму выполнение команды, всё обрабатывает. Через регламентное задание никаких действий.
   ДенисЧ
 
5 - 16.10.19 - 09:26
(4) А у пользователя регзадания есть права на изменение этого справочника?
   dka80
 
6 - 16.10.19 - 09:32
ЗаписьЖурналаРегистрации("Начало");
Запрос = Новый Запрос;
    Запрос.Текст = "ВЫБРАТЬ РАЗЛИЧНЫЕ
                   |    СправочникНоменклатура.Ссылка КАК Ссылка
                   |ИЗ
                   |    Справочник.Номенклатура КАК СправочникНоменклатура
                   |ГДЕ
                   |    СправочникНоменклатура.Наименование ПОДОБНО ""%удалить%""";
    Выборка = Запрос.Выполнить().Выбрать();
ЗаписьЖурналаРегистрации("Выборка");
    Пока Выборка.Следующий() Цикл
ЗаписьЖурналаРегистрации("Цикл");
        Если ЗначениеЗаполнено(Выборка.Ссылка) Тогда
ЗаписьЖурналаРегистрации("Если");
            ОбъектНоменклатура = Выборка.Ссылка.ПолучитьОбъект();
            ОбъектНоменклатура.Наименование = СтрЗаменить(ОбъектНоменклатура.Наименование, "удалить", "");
            ОбъектНоменклатура.Записать();
        КонецЕсли;    
    КонецЕсли; 

И зачем вот это:   Если ЗначениеЗаполнено(Выборка.Ссылка) Тогда
как оно может быть не заполнено?
   Zupbp
 
7 - 16.10.19 - 09:32
(5) права есть
   dka80
 
8 - 16.10.19 - 09:34
А ты уверен, что тебе в форме списка или объекта отображается реквизит "Наименование"? После выполнения регзадания консолью запросов выбери данные и посмотри значение реквизита Наименование
   palsergeich
 
9 - 16.10.19 - 09:45
(5) есть, иначе был бы отлуп.
В номенклатуре много наименований, проверьте что меняете и проверяете действительно Наименование
   Zupbp
 
10 - 16.10.19 - 10:01
(9) Все проверил. Вызываю эту же процедуру этой же обработки по кнопке, отрабатывает. Глюк какой-то
   catena
 
11 - 16.10.19 - 10:05
(10)Отсечки из (6) проверил?
   vova1122
 
12 - 16.10.19 - 10:13
(0) Покажи процедуру ПриЗаписи и ПередЗаписю модуля объекта
   hhhh
 
13 - 16.10.19 - 10:30
(10) да, призаписи и послезаписи запускается общий модуль, который недоступен на сервере.
   Cyberhawk
 
14 - 16.10.19 - 10:31
(10) Покажи где кнопка
   Cyberhawk
 
15 - 16.10.19 - 10:31
(13) Вряд ли он прям из формы объекта какую-то там кнопку вызывает
   D_E_S_131
 
16 - 16.10.19 - 10:32
ТС, а зачем запросе конструкция "РАЗЛИЧНЫЕ"? :)
   Cyberhawk
 
17 - 16.10.19 - 10:32
Ну и проверить имя метода, указанное в свойствах РЗ
   hhhh
 
18 - 16.10.19 - 10:38
(15) ну может он в толстом клиенте? из формы всё записывается, а в регзадании на сервере недоступно.
   Cyberhawk
 
19 - 16.10.19 - 10:53
(18) А про что тогда в "призаписи и послезаписи"?
   Cyberhawk
 
20 - 16.10.19 - 10:53
В (13)
   hhhh
 
21 - 16.10.19 - 11:36
(19) передзаписью, ошибся


Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.