Вход | Регистрация
 
1С:Предприятие :: 1С:Предприятие 8 общая

Не разворачивается DT в файловом режиме

Не разворачивается DT в файловом режиме
Я
   Gribok
 
16.10.19 - 06:37
Добрый день. Столкнулся со следующей проблемой.

Делаю выгрузку с серверной базы - администрирования - выгрузить информационную базу

Пытаюсь развернуть на локальной машине, получаю ошибку.

Во вложении все приложено.

При этом если установить более новую технологическую платформу, то локально разворачивается нормально.

Ранее разворачивался без проблем.

Размер базы данных на сервере 38 гигабайт.

размер информационной базы файла 1.6 гигабайт.

Тестирование и исправление - не помогло.

На серверный вариант разворачивается без проблем.

В чем может быть проблема??
В архиве все скрины ошибки и логи ТИИ и т.д. на форуме не проходит по размеру
https://dropmefiles.com/FoguY

Спасибо
 
 
   Йохохо
 
1 - 16.10.19 - 06:51
вроде бывает при смене версии формата хранения и помогает полная реструктуризация перед выгрузкой, по ссылке ничего нет, нужны версии платформ и сколько пациенту годиков
   Gribok
 
2 - 16.10.19 - 06:59
Йохохо
По ссылке кнопка Скачать все
там есть версии и т.д.
   МимохожийОднако
 
3 - 16.10.19 - 06:59
(2) Прикалываешься?
   zva
 
4 - 16.10.19 - 07:14
При этом если установить более новую технологическую платформу, то локально разворачивается нормально.
Что мешает работать локально на новой платформе?
   Gribok
 
5 - 16.10.19 - 07:20
zva
Не хочется пладить версии платформ
Хотелось бы разоблачатся в чем дело
   Gribok
 
6 - 16.10.19 - 07:20
МимохожийОднако
не разу
   Йохохо
 
7 - 16.10.19 - 07:24
(5)(6) Ожегов считает что Вы можете представлять для базы угрозу)
   hhhh
 
8 - 16.10.19 - 07:24
(6) он не идиот, не будет в 6 утра сейчас качать 38 гиг, только чтобы только версию посмотреть. Поэтому придется тебе версию сказать.
   Гость из Мариуполя
 
9 - 16.10.19 - 07:27
(6) Ну, если не прикалываешься (я тоже сначала подумал, что это шутка), а на полном серьезе, тогда ой.
Серьезно ой! Тогда я настолько тупорылых адынэсников еще не видел.

У автора УТП для Казахстана, релиз 2.0.17.2, так русским по-белому написано:
"Внимание! Текущая версия конфигурации "Управление торговым предприятием для Казахстана" предназначена для использования с версией технологической платформы 1С:Предприятие 8 не ниже 8.3.8.2197."

у автора стоит платформа 8.3.7.1759!

комментарии, как говорится, излишни. Ему, видите ли, неохота плодить версии платформ.

:))))))
   Йохохо
 
10 - 16.10.19 - 07:29
(9) ну вот, на 8.3.7 -> 8.3.8 вроде (1) и случался
   Uzyf
 
11 - 16.10.19 - 07:29
(9) *пладить
   Гость из Мариуполя
 
12 - 16.10.19 - 07:30
(5) ты сделал мой день :)

(11) мало того, еще и *РАЗОБЛАЧАТСЯ.
   hhhh
 
13 - 16.10.19 - 07:34
(11) он же казах, русский язык не родной.
   МимохожийОднако
 
14 - 16.10.19 - 07:36
(13) Не важно как он пишет. Важно, что не читает инструкции.
   Gribok
 
15 - 16.10.19 - 07:39
Что б оновить тех платформу на более новую, нужно обновить тех платформу сервера. Она на убунте стоит.
Такова опыта не имею
   NorthWind
 
16 - 16.10.19 - 07:40
(0) ваша конфа предназначена для использования с более новой версией платформы. Бывает что 1Сники пишут такие предупреждения "навырост", но в данном случае, возможно, в очередном обновлении действительно было применено что-то, что не позволяет DT нормально загрузиться в старой версии. Рекомендую поднять версию платформы. "Пладить" ничего не надо, просто удалите старую и работайте с новой.
   mrdc
 
17 - 16.10.19 - 07:40
Ну раньше же на 8.3.7 у него разворачивалась ДТ-ка локально. Скорее всего не хватает ресурсов на локальном компе, вот 8.3.7 и стала затыкаться, база выросла и т.п. Релиз то древний, да и нерекомендуемый для версии конфы.
Понятно, что надо обновлять платформу на сервере, да только там же видно - Postgres, сервак тоже древний, судя по скринам pgAdmin-а, сервак под 1С виндовый, хотя могу и ошибаться... ставилось это все лет 5 назад, если не более, того, кто поставил этот набор давно нет уже... поблизости. А если там Linux-сервак, то вообще может быть засада, так как спецов в КЗ по набору "Linux/Postgres/1C" ну очень мало, знаю по личному опыту.
ТС явно не имеет опыта в таких делах...

Gribok, пригласи спеца по таким серверам, если начальство денег даст...
   NorthWind
 
18 - 16.10.19 - 07:40
(15) наймите того кто имеет
   Gribok
 
19 - 16.10.19 - 07:44
mrdc
Вы совершенно правы
так все и есть
Сервак крутится уже 6 лет
БД на (PostgreSQL) 9.2.1
И отдельно сервер по 1С на убунте тоже древней

По идее бы обновить PostgreSQLна более новую 
и сервер 1С.
Но таких спецов в нашем городе не найти.
   Йохохо
 
20 - 16.10.19 - 07:45
(19) ну время есть, пока вы только обратно базу залить не можете, вовремя спохватились
   Gribok
 
21 - 16.10.19 - 07:47
Она обратно заливается в серверном варианте
Локально не загружается
   DrZombi
 
22 - 16.10.19 - 07:50
(0) Ограничения в файловой "4 Гб на одну таблицу".
К примеру так же нельзя развернуть УПП из серверной в файловую, т.к. ресурсов просто не хватает на вашем ПК. Можно правда использовать 64-х битную платформу 1С, и есть шанс, что развернется.
   DrZombi
 
23 - 16.10.19 - 07:51
(19) Не делай этого
   DrZombi
 
24 - 16.10.19 - 07:52
+(19) Судя по надписям на формуах, 1С затачивает свои платформы на Конкретную версию посгресса, т.е. на другой у вас возможно будет не так все хорошо работать... Нужно читать приложенное описание от 1С к версии платформы :)
   Gribok
 
25 - 16.10.19 - 07:56
(22) Сейчас попробую накатит х64 и накатить на нее
   МимохожийОднако
 
26 - 16.10.19 - 07:57
(19) Есть спецы, которые по удалёнке могут выполнить настройки. Главное-найти деньги на оплату работ.
   Гость из Мариуполя
 
27 - 16.10.19 - 07:58
(19) *Сервак крутится уже 6 лет

хм..
платформа 8.3.7.1759 вышла 19.11.2015
т.е.  как минимум, платформу один раз обновляли. И это было меньше четырех лет назад. Значит, был кто-то, кто это мог делать.

(22) дело точно  не в  "4 Гб на одну таблицу" и вряд ли в ресурсах компа, ибо автор пишет, что на более  новой платформе все разворачивается. правда, он не уточняет, более новая  64-х или 32-х?

ps: не в разжигание, а как прискорбный факт - выживание русских из Средней Азии приводит и вот к таким последствиям. :(
   Gribok
 
28 - 16.10.19 - 08:03
8.3.7.1759 данная платформа не делится на х32 и х64
ну на сайте https://releases.1c.ru/version_files?nick=Platform83&ver=8.3.7.1759
по крайней мере нету
   mrdc
 
29 - 16.10.19 - 08:08
(19) А что за город то?
   Gribok
 
30 - 16.10.19 - 08:09
(29) РК- Павлодар
 
 Рекламное место пустует
   mrdc
 
31 - 16.10.19 - 08:14
(24) УТП2, УПП1 для КЗ нормально работает на Ubuntu 18.04 + PostgreSQL, версия 10.5-24.1C + 1C 8.3.14.1779.
   Gribok
 
32 - 16.10.19 - 08:16
(9) А где это написано
"Внимание! Текущая версия конфигурации "Управление торговым предприятием для Казахстана" предназначена для использования с версией технологической платформы 1С:Предприятие 8 не ниже 8.3.8.2197."

Можно ссылку пж
   Gribok
 
33 - 16.10.19 - 08:21
Нашел
)))
https://releases.1c.ru/version_files?nick=TradeEntrKz20&ver=2.0.17.2
Видать все таки проблема кроется в этом
   Gribok
 
34 - 16.10.19 - 08:26
Просто на обновлениях 
2.0.16.1     11.03.19     
2.0.15.2     31.01.19     
2.0.14.8     30.05.18 

Оно работало норм. и Выгрузка и загрузка.
хотя везде написано
Внимание! Текущая версия конфигурации "Управление торговым предприятием для Казахстана" предназначена для использования с версией технологической платформы 1С:Предприятие 8 не ниже 8.3.8.2197.
   mrdc
 
35 - 16.10.19 - 08:26
(33) У тебя целый комплекс проблем, имхо.
1. Найди спеца, который тебе озвучит сумму за работу.
2. Выбей деньги - ибо это самое главное у нас в КЗ :-).
3. Ну и потом обновись, можно удаленно (если предоставят доступ снаружи), а можно и приехать в Павлодар.
4. Потом по всем рабочим станциям платформу обновишь уже сам.

С другой стороны, если ты разворачиваешь локально для каких-то работ, то какая разница - пользуй новую платформу и делов то.
   Gribok
 
36 - 16.10.19 - 08:28
(35) Да. думаю придется ставить еще 1 платформу локально и уже на ней что то делать.
   mrdc
 
37 - 16.10.19 - 08:29
А Ubuntu какой версии?
   Gribok
 
38 - 16.10.19 - 08:30
(37)
Distributor ID: Ubuntu
Description:    Ubuntu 14.04.3 LTS
Release:        14.04
   mrdc
 
39 - 16.10.19 - 08:41
(38) А разрядность всего это серверного набора Ubuntu 14, Postgres 9, 1C 8.3.7 какая, 32 или 64?
   hhhh
 
40 - 16.10.19 - 08:46
(36) у меня на локальном компе 15 платформ стоят. Это вообще не вопрос. Они никому не мешают
   Gribok
 
41 - 16.10.19 - 08:46
(39)
1С сервер
uname -a
Linux 1chp320 3.16.0-55-generic #74~14.04.1-Ubuntu SMP Tue Nov 17 10:15:59 UTC 2015 x86_64 x86_64 x86_64 GNU/Linux

Сервер БД PostgresSQL
uname -a
Linux post 3.16.0-4-686-pae #1 SMP Debian 3.16.7-ckt20-1+deb8u3 (2016-01-17) i686 GNU/Linux

Информация о PostgreSQL
psql -V
psql (PostgreSQL) 9.2.1-eter8debian
   mrdc
 
42 - 16.10.19 - 08:54
Хотя, как ни крути, тут диагноз один - "древность", а лечение - "обновись по полной" :-)
Епрст, оно все еще и на два сервака разнесено.
Можно попробовать обновить только платформу, 8.3.8.2197 или немного выше должна взлететь. Слишком свежие, типа 8.3.13 вряд ли без шаманства встанут... Но, подозреваю, что если поставишь потом 8.3.8.2197 или немного выше на локальную машину, то ситуация с ДТ не поменяется.
А на какой платформе локально разворачивается - версия, разрядность?
И какие характеристики локального компа, разрядность ОС, ОЗУ, ...?
   Йохохо
 
43 - 16.10.19 - 08:57
(42) почему не 8.3.10? 14.04 ЛТС, тоже всё норм
   Gribok
 
44 - 16.10.19 - 09:02
(42) Много разных пробовал, которые выше версии.
Разворачивается на всех.
Характеристики пк.
WIn 10 pro x64
Озу 24гб
Винт SSD 500
Пробовал так же на более слабых пк
и на виртуальных машинах пробовал, тоже норм.
Все зависит от платформы.
   Gribok
 
45 - 16.10.19 - 09:05
(42) мало того что оно все на 2 сервера раскидано
оно еще все на виртуалках крутится
   mrdc
 
46 - 16.10.19 - 09:14
(45) Мда...
Юзай свежие платформы на локальном компе и не парься :-)
А сервера пока фурычат, лучше не трогай, пока сам не научишься такими наборами рулить.
За обновление этого всего на серверах в КЗ много денег запросят, однозначно :-) или придут виндозники и предложат перевести все это на Винду. Отдашь 1235000 тнг за виндовый набор софта + за работу (сколько тут я не знаю). По софту знаю, позавчера просчитывал такой переход.
   Gribok
 
47 - 16.10.19 - 09:17
(46) Да на винду я и сам смогу перетащить все
Что там, поставить WIN srv 2012 какойнить + SQL+ 1С
Думаю и так должно работать.
Да думаю буду ставить дополнительную платформу себе локально и юзать ее.
Спасибо
   НичегоНеПонятно
 
48 - 16.10.19 - 09:22
1Сники раньше - Знали, зачто отвечает каждый файл в папке с платформой, писали 1С++, опенкофы и формексы, каждый выпуск нового релиза платформы грозил перерасти в корпоратив.
1Сники сейчас - мучительно долго принимает решение поставить другой релиз платформы
   PR
 
49 - 16.10.19 - 09:28
(15) Лучше бросай 1С, не осилишь
Займись лучше Фузиной
   mrdc
 
50 - 16.10.19 - 09:29
(48) :-)
Кто и сейчас, наверное, пишет... - творчество всегда интересно... в молодости :-)
А те, кто знают, за что отвечает и что содержит каждый файл в папке с платформой, да еще и в разных ОС, да еще и в разных home, opt, lib, log - сейчас рубят бабло :-), чтобы отдохнуть зимой в теплых странах :-), ибо молодость прошла и на творчество времени уже нет.
   Гость из Мариуполя
 
51 - 16.10.19 - 10:26
вот как раз переход на 8.3.8 с 8.3.7 критично 
там поменялся формат хранения данных, размер страницы теперь не только 4096, а и другие размеры,  
в общем подробности уже и не помню, давно было, но припоминается, что в связи с такими изменениями иногда например база созданная на 8.3.8, могла вообще не открываться на 8.3.7.

так что 8.3.8 - это как раз некая критичная граница в платформах, и недаром и до сих пор требования во многих конфах - платформа не ниже 8.3.8.ххх

И, судя по всему, автору по-любому и на боевом сервере надо будет переползать эту критичную границу.


Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.