Вход | Регистрация
 
1С:Предприятие :: 1С:Предприятие 8 общая

Получение обновлений программы недоступно в текущем режиме работы.

Получение обновлений программы недоступно в текущем режиме работы.
Я
   pavlushov
 
14.10.19 - 10:01
Пытаюсь обновить типовую БП 3.0 из режима "предприятие", через меню "Администрирование" - "Обслуживание" - "Обновление программы". После нажатия на "Поиск и установка обновлений" появляется предупреждение "Получение обновлений программы недоступно в текущем режиме работы". До этого все было нормально, видимо что то новое в релизе БП. Кто сталкивался?
 
 
   DrZombi
 
1 - 14.10.19 - 10:02
(0) А я из Конфигуратора, по старинке как-то надежнее :)
   DrZombi
 
2 - 14.10.19 - 10:03
+(0) Вы хоть релиз озвучьте, Конфигурации и платформы.
   mikecool
 
3 - 14.10.19 - 10:06
(0) глобальный поиск по коду и все станет ясно
   Chameleon1980
 
4 - 14.10.19 - 10:07
Может полуплатформенное
   pavlushov
 
5 - 14.10.19 - 10:16
Бухня (3.0.72.60)
   МимохожийОднако
 
6 - 14.10.19 - 10:19
екущая версия конфигурации "Бухгалтерия предприятия" предназначена
для использования с версией системы 1С:Предприятие 8.3 не ниже 8.3.12.1685.
   marty0701
 
7 - 14.10.19 - 10:22
(0)Веб клиент или не виндовс
   RoRu
 
8 - 14.10.19 - 10:22
(6) маловероятно 72 60 тоже по идее требует ту же платформу
   pavlushov
 
9 - 14.10.19 - 10:29
платформа 8.3.15.1565
   marty0701
 
10 - 14.10.19 - 10:30
Вот код, смотри сам, по какому условию не пролазишь.
// Определяет возможность использования автоматического обновления программы в

// текущем режиме работы.
//

// Параметры:
//    ПроверитьВозможностьПримененияОбновлений - Булево - проверить для текущего

//        пользователя наличие права применения обновления.
//        Если Истина - проверяется возможность использования в режиме применения

//        обновления, иначе проверить возможность просмотра информации о
//        доступных обновлениях;

//    ПроверитьОС - Булево - проверить возможность применения обновления
//        на текущей операционной системе.

//
// Возвращаемое значение:

//    Булево - признак возможности использования: Истина, если использование
//        возможно, Ложь - в противном случае.

//
Функция ДоступноИспользованиеОбновленияПрограммы(
    ПроверитьВозможностьПримененияОбновлений = Ложь,
    ПроверитьОС = Истина) Экспорт
    
    Если ОбщегоНазначения.ЭтоВебКлиент()
        Или ОбщегоНазначения.РазделениеВключено()
        Или (ПроверитьВозможностьПримененияОбновлений И Не Пользователи.ЭтоПолноправныйПользователь(, Истина, Ложь))
        Или Не Пользователи.РолиДоступны("ПросмотрИнформацииОДоступныхОбновленияхПрограммы", , Ложь)
        Или Пользователи.ЭтоСеансВнешнегоПользователя()
        Или ОбщегоНазначения.ЭтоПодчиненныйУзелРИБ()
        Или ОбщегоНазначения.КлиентПодключенЧерезВебСервер()
        Или Не ПоддерживаетсяПакетныйРежимКонфигуратора() Тогда
        Возврат Ложь;
    КонецЕсли;
    
    Если ПроверитьОС И Не ОбщегоНазначения.ЭтоWindowsКлиент() Тогда
        Возврат Ложь;
    КонецЕсли;
    
    Возврат Истина;
    
КонецФункции
   pavlushov
 
11 - 14.10.19 - 10:31
(10) код то я нашел, не могу отладкой в него попасть, включил отладку на сервере, но по точке останова не попадаю в конфигуратор и все тут
   hhhh
 
12 - 14.10.19 - 10:33
   marty0701
 
13 - 14.10.19 - 10:34
(11)Ну это другая проблема, навесь расширение и выведи все проверки в сообщения, посмотри.
   mikecool
 
14 - 14.10.19 - 10:34
(11) проверить условия и без отладчика можно
   pavlushov
 
15 - 14.10.19 - 10:40
Не понимаю почему отладка не срабатывает
   pavlushov
 
16 - 14.10.19 - 10:42
Включить доступ к отладке фоновых заданий?
   hhhh
 
17 - 14.10.19 - 10:47
(16) это не наш метод, скучно. Лучше отлаживать фоновые задания без галки отладка фоновых заданий.
   pavlushov
 
18 - 14.10.19 - 11:13
хм, НЕ ПоддерживаетсяПакетныйРежимКонфигуратора
   hhhh
 
19 - 14.10.19 - 11:17
(18) ну,, какие-то права значит вам отключили
   pavlushov
 
20 - 14.10.19 - 11:20
не понимаю как включить его
   alexeyskiff
 
21 - 23.10.19 - 11:38
(20) платформа 8.3.15.1700 (64битный сервер), НЕ ПоддерживаетсяПакетныйРежимКонфигуратора из-за отсутствия файла 1cv8.exe в папке:
C:\Program Files\1cv8\8.3.15.1700\bin\1cv8.exe
лечится установкой платформы с 64битным клиентом


Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.