Вход | Регистрация
 
1С:Предприятие :: 1С:Предприятие 8 общая

Формат файла не поддерживается.

Формат файла не поддерживается.
Я
   progaoff
 
10.10.19 - 17:31
ФайлEXCELНаСервере = ПолучитьИмяВременногоФайла(Расширение);
    ДвоичныеДанные.Записать(ФайлEXCELНаСервере);
    
    ТабличныйДокумент = Новый ТабличныйДокумент;
    ТабличныйДокумент.Прочитать(ФайлEXCELНаСервере);
В итоге получаю - Формат файла не поддерживается.
Файлы форматом xls и xlsx. Что не так делаю?
 
 
   WhiteDragon93
 
1 - 10.10.19 - 17:34
(0) а что в переменной Расширение?
   dka80
 
2 - 10.10.19 - 17:35
А почему двоичные данные должны быть в формате эксель? Ты экселем потом этот файл открыть можешь?
   progaoff
 
3 - 10.10.19 - 17:52
(2) нет, ошибку валил сам ексель
   dka80
 
4 - 10.10.19 - 17:53
(3) ну тогда что ты от табличного документа хочешь. Что у тебя в ДвоичныеДанные и как оно туда попало?
   progaoff
 
5 - 10.10.19 - 18:04
(4) да я екселю расширение поменял с xlsb на xlsx не пересохранением а через переименовывание
   progaoff
 
6 - 10.10.19 - 18:04
(4) Кстати не пойму почему xlsb не хочет читать. Не сталкивался никто?
   progaoff
 
7 - 10.10.19 - 18:05
&НаКлиенте
Процедура ИмяФайлаНачалоВыбора(Элемент, ДанныеВыбора, СтандартнаяОбработка)
    Диалог = Новый ДиалогВыбораФайла(РежимДиалогаВыбораФайла.Открытие);
    Диалог.Заголовок = "Выберите файл...";
    Диалог.ПредварительныйПросмотр = Ложь;
    Диалог.МножественныйВыбор = Ложь;
    Диалог.Фильтр = "файлы (*.xls; *.xlsx; *.xlsb)|*.xls;*.xlsx;*.xlsb";
    
    Если Диалог.Выбрать() Тогда
        ИмяФайла = Диалог.ПолноеИмяФайла;
    Иначе
        Возврат;
    КонецЕсли;

КонецПроцедуры

&НаКлиенте
Процедура ПрочитатьФайл(Команда)
    Файл = Новый Файл(ИмяФайла);
    Если НЕ Файл.Существует() Тогда
        Возврат;
    КонецЕсли;
    ДвоичныеДанные = Новый ДвоичныеДанные(ИмяФайла);
    ДокументРезультат = EXCELВТаблицуЗначений(ДвоичныеДанные, Файл.Расширение);
КонецПроцедуры
   progaoff
 
8 - 10.10.19 - 18:06
Ошибка при выполнении файловой операции - вот это ловлю
   progaoff
 
9 - 10.10.19 - 18:06
если формат xlsb

Список тем форума
Рекламное место пустует  Рекламное место пустует
Пользователь не знает, чего он хочет, пока не увидит то, что он получил.
Э. Йодан
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.