Вход | Регистрация
 

Бухгалтерия 2.0 Кладр и 1с отчетность

Бухгалтерия 2.0 Кладр и 1с отчетность
Я
   Ychenik1c
 
10.10.19 - 16:16
Здравствуйте. Ошибка при отправки отчетов: Адрес организации (индивидуального предпринимателя) должен содержать в себе 9 или 12 запятых!
Адрес заполнен по кладр. В нём всего 6 запятых. А проверка идёт если не ошибаюсь по формату фиас.
Пробовал адрес в произвольной форме с проставлением запятых по формату ошибка не ушла.
Как можно решить проблему не переходя на бухгалтерию тройку?
 
 
   Ychenik1c
 
1 - 10.10.19 - 16:18
В произвольной форме делал по формату: Страна,Индекс,Регион,Район,Город, Населенный пункт,Улица,Дом,Корпус,Квартира.
   RomanYS
 
2 - 10.10.19 - 16:21
(1) отладчик в помощь. Там адрес пересобирается
   hhhh
 
3 - 10.10.19 - 16:29
(0) в адресе никогда не было 6 запятых. Это тебя обманули. В кладре всегда было 9 запятых.
   hhhh
 
4 - 10.10.19 - 16:30
(0) если 6 запятых - это у тебя не по кладру, а какая-то отсебятина. Кто-то вручную ввел адрес.
   Ychenik1c
 
5 - 10.10.19 - 16:41
Представление = УправлениеКонтактнойИнформацией.ПолучитьПредставлениеАдреса(?(Запись = Неопределено, ЭтотОбъект, Запись));

Функция ПолучитьПредставлениеАдреса(Запись) Экспорт

    ТекПредставление = "";

    Если СокрЛП(Запись.Поле1) <> "" Тогда
        ТекПредставление = ТекПредставление + ", " + СокрЛП(Запись.Поле1);
    КонецЕсли;

    Если СокрЛП(Запись.Поле2) <> "" Тогда
        ТекПредставление = ТекПредставление + ", " + СокрЛП(Запись.Поле2);
    КонецЕсли;

    Если СокрЛП(Запись.Поле3) <> "" Тогда
        ТекПредставление = ТекПредставление + ", " + СокрЛП(Запись.Поле3);
    КонецЕсли;

    Если СокрЛП(Запись.Поле4) <> "" Тогда
        ТекПредставление = ТекПредставление + ", " + СокрЛП(Запись.Поле4);
    КонецЕсли;

    Если СокрЛП(Запись.Поле5) <> "" Тогда
        ТекПредставление = ТекПредставление + ", " + СокрЛП(Запись.Поле5);
    КонецЕсли;

    Если СокрЛП(Запись.Поле6) <> "" Тогда
        ТекПредставление = ТекПредставление + ", " + СокрЛП(Запись.Поле6);
    КонецЕсли;
    
    ТипДома = Неопределено;
    ТипКорпуса = Неопределено;
    ТипКвартиры = Неопределено;
    Если ТипЗнч(Запись) = Тип("Структура") Тогда
        Запись.Свойство("ТипДома",     ТипДома);
        Запись.Свойство("ТипКорпуса",  ТипКорпуса);
        Запись.Свойство("ТипКвартиры", ТипКвартиры);
    Иначе
        ТипДома     = Запись.ТипДома;
        ТипКорпуса  = Запись.ТипКорпуса;
        ТипКвартиры = Запись.ТипКвартиры;
    КонецЕсли;
    
    Если СокрЛП(Запись.Поле7) <> "" Тогда
        ТекПредставление = ТекПредставление + ", " + ?(ЗначениеЗаполнено(ТипДома), ТипДома, "дом") + " № " + СокрЛП(Запись.Поле7);
    КонецЕсли;

    Если СокрЛП(Запись.Поле8) <> "" Тогда
        ТекПредставление = ТекПредставление + ", " + ?(ЗначениеЗаполнено(ТипКорпуса), ТипКорпуса, "корпус") + " " + СокрЛП(Запись.Поле8);
    КонецЕсли;

    Если СокрЛП(Запись.Поле9) <> "" Тогда
        ТекПредставление = ТекПредставление + ", " + ?(ЗначениеЗаполнено(ТипКвартиры), ТипКвартиры, "кв.") + СокрЛП(Запись.Поле9);
    КонецЕсли;

    Если СтрДлина(ТекПредставление) > 2 Тогда
        ТекПредставление = Сред(ТекПредставление, 3);
    КонецЕсли;
    
    Возврат ТекПредставление;

КонецФункции
   Ychenik1c
 
6 - 10.10.19 - 16:42
Поля как раз пустая строка и запятые нужные не проставляются
   Ychenik1c
 
7 - 10.10.19 - 16:43
(4) Уже не раз перебивал
   Ychenik1c
 
8 - 10.10.19 - 16:45
Проверил что возможная причина что адрес заканчивается на  "дом № 13, этаж 1, помещение 1".
Этаж и помещение можно только в УФ и фиас выбрать. Но причина не в этом.
   hhhh
 
9 - 10.10.19 - 16:54
(8) сделай чтобы было 9 запятых
   Ychenik1c
 
10 - 10.10.19 - 17:00
Пробовал - не помогло
Плюс не даёт редактировать в произвольную форму. Делал через регистр Контактная информация
   Йохохо
 
11 - 10.10.19 - 17:04
где то есть галка "по административно территориальному делению"? там не 9
   Ychenik1c
 
12 - 10.10.19 - 17:07
(11) Тоже вот подумал что где то что то не включено.
Есть обработка РедактированиеКонтактнойИнформации. Так там форма другая с кодом региона.
   RomanYS
 
13 - 10.10.19 - 17:17
(8) Тот адрес, который ты видишь и тот адрес который проверяется - две разные вещи.
Для примера
видимый адрес: 111111, Москва г, Глазовский пер, дом № 99
проверяемй 643,111111,Москва г,,,,Глазовский пер,99,,,дом,,

Первый в хранится в КИ и показывается на форме отчетности. Второй хранится внутри отчетности и используется при выгрузке. Откуда он взялся - без отладчика не разберёшься.
Из простых советов: перебить адрес по классификатору, забить как нужно в произвольном формате точно не получится.
   RomanYS
 
14 - 10.10.19 - 17:19
И что для подтягивания измененного адреса в отчетность нужно нажать кнопку "обновить" (не "Заполнить"!) надеюсь в курсе.
   Ychenik1c
 
15 - 10.10.19 - 17:22
(14) Естественно. Но там не отчет, а исходящие сообщение.
   Ychenik1c
 
16 - 10.10.19 - 17:45
(13) Я в том плане что настроек на той форме больше.
Но судя по отладке форма та.
Сейчас смотрю от каких настроек зависит их видимость

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.