Вход | Регистрация
 

Программное добавление элементов на управляемую форму. Как добавить кнопку открытия?

Программное добавление элементов на управляемую форму. Как добавить кнопку открытия?
Я
   Dunstan
 
10.10.19 - 11:40
Программно добавляю колонки в элемент формы "Таблица Значений". И к одной колонке хочу подкрутить кнопку открытия. Как это сделать программно?
&НаСервере
Процедура ОтображениеРезультата(ТаблицаРезультата,ИмяТаблицыФормы,Родитель)
     Перем _Сын,_Папа;
     Для Каждого Кол Из ТаблицаРезультата.Колонки Цикл
        ДобавитьКолонкуВТаблицуНаСервере(ИмяТаблицыФормы, Кол.Имя, Кол.ТипЗначения);
    КонецЦикла;
    ЗначениеВРеквизитФормы(ТаблицаРезультата,ИмяТаблицыФормы);
    Для Каждого Кол Из ТаблицаРезультата.Колонки Цикл
        СтрукЭлемента = НайтиПоПутиКДанным(ЭтаФорма,ИмяТаблицыФормы + "." + Кол.Имя);
        Если СтрукЭлемента.Количество() = 0 Тогда
            ТекЭл = Элементы.Добавить(ИмяТаблицыФормы + Кол.Имя,Тип("ПолеФормы"),Родитель);
            ТекЭл.ПутьКДанным = ИмяТаблицыФормы + "." + Кол.Имя;
            Если Кол.Имя = "Регистатор" Тогда
                ТекЭл.Вид =    ВидПоляФормы.ПолеВвода;
// Вот сюда прилепит кнопку открытия документа
            Иначе
                ТекЭл.Вид =    ВидПоляФормы.ПолеНадписи;
            КонецЕсли;    
        КонецЕсли    
    КонецЦикла;
КонецПроцедуры
 
 
   vicof
 
1 - 10.10.19 - 11:42
Ты не поверишь...ТекущийЭлемент.КнопкаОткрытия = Истина;
   Dunstan
 
2 - 10.10.19 - 11:54
Вот не поверю. А проверю! просто она  КнопкаОткрытия автоматом не выпадает в списке при наборе "." ТекЭл. и выпадает список выбора свойства. Там Кнопку открытия не увидел.
   Dunstan
 
3 - 10.10.19 - 13:54
Все получилось. СПС

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.