Вход | Регистрация
 
1С:Предприятие :: 1С:Предприятие 8 общая

Перестал работать выбор из справочника

Перестал работать выбор из справочника
Я
   UUmmmmm
 
09.10.19 - 13:23
Есть ТЧ, с реквизитом у которого ссылка на справочник, при выборе стал открываться пустой справочник, почему такое могло произойти?
 
 
   catena
 
1 - 09.10.19 - 13:27
1. Из справочника все удалили
2. Список открывается с отбором
3. Открывается не тот справочник
....
   UUmmmmm
 
2 - 09.10.19 - 13:46
(1) нет, тут в коде ошибка, есть события у тч, может в них что-то не так?

&НаКлиенте
Процедура КафедрыПередНачаломДобавления(Элемент, Отказ, Копирование, Родитель, Группа, Параметр)
    ИсточникКопированияАйдиСтрокиКафедр = -1;
    ТекСтрока = Элементы.Кафедры.ТекущиеДанные;
    Если Копирование Тогда
        Если ТекСтрока = Неопределено Тогда
            Отказ = Истина;
            Возврат;
        КонецЕсли;
        ИсточникКопированияАйдиСтрокиКафедр = ТекСтрока.ПолучитьИдентификатор();
    //Иначе

    //    Отказ = Истина;

КонецЕсли;

КонецПроцедуры



&НаКлиенте
Процедура КафедрыПриНачалеРедактирования(Элемент, НоваяСтрока, Копирование)
        Если НоваяСтрока  Тогда
        Элемент.ТекущиеДанные.КлючКафедры = ПолучитьНовыйКлючКафедрыСервер();    
    КонецЕсли;
    
    Если Копирование Тогда
        //+Копируем дисциплину и подчиненные строки

        СкопироватьПодчиненныеДисциплиныСервер(Элементы.Кафедры.ТекущаяСтрока, ИсточникКопированияАйдиСтрокиКафедр);
        //-Копируем дисциплину и подчиненные строки

        Модифицированность = Истина;
    КонецЕсли;    
КонецПроцедуры

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.