Вход | Регистрация
 

Почему данный код выдает ошибку ?

Почему данный код выдает ошибку ?
Я
   Grekos2
 
08.10.19 - 15:43
&НаКлиенте
Процедура ОбработкаКоманды(ПараметрКоманды, ПараметрыВыполненияКоманды)
    Фор = ПолучитьФорму("Документ.Важный.ФормаОбъекта");
    ДанныеФормы = Фор.Объект;
    ЗаполнитьДокНаСервере(ДанныеФормы);
КонецПроцедуры

&НаСервереБезКонтекста
Процедура ЗаполнитьДокНаСервере(ДанныеФормы)
    ДокОбъект=ДанныеФормыВЗначение(ДанныеФормы,Тип("ДокументОбъект.Важный") );
    ЗначениеВДанныеФормы(ДокОбъект,ДанныеФормы);    
КонецПроцедуры

Говорит " Процедура или функция с указанным именем не определена (ЗаполнитьДокНаСервере)"
 
 
   Grekos2
 
1 - 08.10.19 - 15:45
Это модуль команды.

1С:Предприятие 8.3 (8.3.14.1565)
   D_E_S_131
 
2 - 08.10.19 - 15:46
А если заменить "&НаСервереБезКонтекста" на "&НаСервере", то работает?
   Grekos2
 
3 - 08.10.19 - 15:47
(2) Нет.
   unenu
 
4 - 08.10.19 - 15:48
(1) Вы пытаетесь передать с клиента на сервер данные объекта УФ и надеетесь, что сможете обмануть платформу внеконтекстным вызовом?
   D_E_S_131
 
5 - 08.10.19 - 15:50
(4) Ошибка при передаче данных по другому бы выглядела.
   Grekos2
 
6 - 08.10.19 - 15:50
(2),(4)

Вру. Если просто &НаСервере", то работает если все аккуратно сделать.
   pechkin
 
7 - 08.10.19 - 15:50
можно сделать так: на сервре подготовить структуру нового документа, а на клиенте заполнить поля формы
   unenu
 
8 - 08.10.19 - 15:50
&НаКлиенте
Процедура ОбработкаКоманды(ПараметрКоманды, ПараметрыВыполненияКоманды)
    Фор = ПолучитьФорму("Документ.Важный.ФормаОбъекта");
    ДанныеФормы = Фор.Объект;
    ЗаполнитьДокНаСервере(1);
КонецПроцедуры

&НаСервереБезКонтекста
Процедура ЗаполнитьДокНаСервере(ДанныеФормы)
    а = "";
КонецПроцедуры

попробуйте так, а потом опять приступаете к насилию сервера
   Grekos2
 
9 - 08.10.19 - 15:51
Всем спасибо за внимание :))
   pechkin
 
10 - 08.10.19 - 15:51
ну если процедура не найдена, то просто имя не правильно написано
   Grekos2
 
11 - 08.10.19 - 15:52
(10) Имя правильно написано.
     БезКонтекста нельзя в данном случае.

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.