Вход | Регистрация
    1  2  3  4  5  6  7  8  9  10  11   
О жизни... :: lsFusion

OFF: lsFusion vs 1C

Ø [длинная ветка, 09.10.19 - 11:39]
OFF: lsFusion vs 1C
Я
   CrushBy
 
07.10.19 - 11:12
5. 1С - тупиковая ветвь... она обречена64% (9)
1. От тайги до британских морей 1С нет сильней!21% (3)
3. lsFusion - не светит с пропиндосовским именем7% (1)
4. lsFusion - круче всех7% (1)
2. Платформы паритетные....0% (0)
Всего мнений: 14

Ветка для холивара, троллинга, остроумия и оскорблений. Помните, что тонкий троллинг и просто оскорбление - это разные вещи. Переход на личность - признак слабого ума и дурного воспитания.
В красному углу ринга бесплатная и открытая платформа lsFusion (LGPL лицензия). "Убийца 1С" (c) ПростоГен (aka Devilment)
Сайт : https://lsfusion.org/ . Блог : https://habr.com/ru/company/lsfusion/ . Документация : https://documentation.lsfusion.org/

На бой была вызвана статьей "Почему не 1С" : https://habr.com/ru/company/lsfusion/blog/468415/

Для получения наживы для троллинга есть отдельная ветка : Конкретные вопросы по lsFusion
   _DAle_
 
601 - 08.10.19 - 00:53
(600) Я не смогу ответить на этот вопрос. Это вопрос к Crush'у, я прикладной логикой не занимаюсь совсем.
   Злопчинский
 
602 - 08.10.19 - 00:54
в меня просто - если скидка не задана - берется из родителя. и все.
нуллов, конечно у меня нет, это 77.
скидка или есть (не ноль), или нет (0).
.
такую хрень со скидками - частная на конкретную позицию, если не задана - берем из родителя, если не задана - берем из родителя-родителя - я тупо "не думая сделал", заехав мимоходом к своему одному "лавочнику". Нихера не понял что здесь сложного может быть.
   PR
 
603 - 08.10.19 - 00:54
(599) ok, тогда норм
   RomanYS
 
604 - 08.10.19 - 00:58
(580) Нет якорного заказчика, который бы оплатил подобную разработку.
Нет заказчиков, которым это можно продать. Не пойдет же 1С на форумы/мероприятия саперов/ораклов какое они пользуют г.но и как сказочна 1С.
Нет команд, которые споссобны подобное внедрять глобально.


На локальном рынке все эти аудиторские следы пока никому не нужны. Зато есть пользователи(организации), которые используют УПП, и которым потенциально можно впарить ЕРП. И это цель.
Ну и разрабатывалась она также: как УПП, только лучше. Что выросло, то выросло. Но конкурентов реальных не видно.
   PR
 
605 - 08.10.19 - 01:00
(602) Да не, сделать регистр легко
И сделать скидки только на нужные позиции, а не на все, и брать потом из родителя тоже легко
Сложности начинаются, когда берешь динамический список и когда понимаешь, что событие ДС ПриПолученииДанныхНаСервере из https://wonderland.v8.1c.ru/blog/obrabotka-i-oformlenie-dannykh-dinamicheskogo-spiska/ работает на сервере без контекста, то есть все назначенные локальные скидки ты с клиента не возьмешь, их нужно хранить во временном хранилище и, мало того, этот адрес временного хранилища тоже нужно записать во что-то, доступное при вызове события
В общем было интересно разобраться с новой возможностью платформы

Полный код формы скидок
&НаСервере
Процедура ПриСозданииНаСервере(Отказ, СтандартнаяОбработка)
    
    НастроитьИспользованиеДереваГрупп();
    
КонецПроцедуры

&НаСервере
Процедура ПриЗагрузкеДанныхИзНастроекНаСервере(Настройки)
    
    НастроитьИспользованиеДереваГрупп();
    
КонецПроцедуры

&НаКлиенте
Процедура ИспользованиеДереваГруппПриИзменении(Элемент)
    
    НастроитьИспользованиеДереваГрупп();
    
КонецПроцедуры

&НаСервере
Процедура НастроитьИспользованиеДереваГрупп()
    
    Если ИспользованиеДереваГрупп = 0 Тогда
        Список.КомпоновщикНастроек.Настройки.Отбор.Элементы[0].Использование = Истина;
        Список.КомпоновщикНастроек.Настройки.Отбор.Элементы[1].Использование = Ложь;
    Иначе
        Список.КомпоновщикНастроек.Настройки.Отбор.Элементы[0].Использование = Ложь;
        Список.КомпоновщикНастроек.Настройки.Отбор.Элементы[1].Использование = Истина;
    КонецЕсли;
    
КонецПроцедуры

&НаКлиенте
Процедура ДеревоПриАктивизацииСтроки(Элемент)
    
    ДеревоПриАктивизацииСтрокиНаСервере();
    
КонецПроцедуры

&НаСервере
Процедура ДеревоПриАктивизацииСтрокиНаСервере()
    
    Список.КомпоновщикНастроек.Настройки.Отбор.Элементы[0].ПравоеЗначение = Элементы.Дерево.ТекущаяСтрока;
    Список.КомпоновщикНастроек.Настройки.Отбор.Элементы[1].ПравоеЗначение = Элементы.Дерево.ТекущаяСтрока;
    
КонецПроцедуры

&НаСервереБезКонтекста
Процедура ДеревоПриПолученииДанныхНаСервере(ИмяЭлемента, Настройки, Строки)
    
    МассивТоваров = Новый Массив;
    
    Для Каждого Строка Из Строки Цикл
        
        МассивТоваров.Добавить(Строка.Ключ);
        
        Родитель = Строка.Ключ.Родитель;
        
        Пока Родитель <> Справочники.Товары.ПустаяСсылка() Цикл
            
            Если МассивТоваров.Найти(Родитель) = Неопределено Тогда
                МассивТоваров.Добавить(Родитель);
            КонецЕсли;
            
            Родитель = Родитель.Родитель;
            
        КонецЦикла;
        
    КонецЦикла;
    
    ТекстЗапроса =
    "ВЫБРАТЬ
    |    Скидки.Товар КАК Товар,
    |    Скидки.Скидка КАК Скидка
    |ИЗ
    |    РегистрСведений.Скидки КАК Скидки
    |ГДЕ
    |    Скидки.Товар В(&Товар)";
    
    Запрос = Новый Запрос(ТекстЗапроса);
    Запрос.УстановитьПараметр("Товар", МассивТоваров);
    Результат = Запрос.Выполнить();
    
    ТекущиеСкидки = Новый Соответствие;
    
    Выборка = Результат.Выбрать();
    
    Пока Выборка.Следующий() Цикл
        ТекущиеСкидки.Вставить(Выборка.Товар, Выборка.Скидка);
    КонецЦикла;
    
    АдресСкидокНаГруппуВоВременномХранилище = Неопределено;
    Настройки.ДополнительныеСвойства.Свойство("АдресСкидокНаГруппуВоВременномХранилище", АдресСкидокНаГруппуВоВременномХранилище);
    
    Если АдресСкидокНаГруппуВоВременномХранилище = Неопределено Тогда
        СкидкиНаГруппу = Новый Соответствие;
    Иначе
        СкидкиНаГруппу = ПолучитьИзВременногоХранилища(АдресСкидокНаГруппуВоВременномХранилище);
    КонецЕсли;
    
    Для Каждого Строка Из Строки Цикл
        
        Скидка = СкидкиНаГруппу.Получить(Строка.Ключ);
        
        Родитель = Строка.Ключ;
        
        Пока (Скидка = Неопределено
            ИЛИ Скидка = NULL)
            И Родитель <> Справочники.Товары.ПустаяСсылка() Цикл
            Скидка = СкидкиНаГруппу.Получить(Родитель);
            Родитель = Родитель.Родитель;
        КонецЦикла;
        
        Если Скидка = Неопределено Тогда
            
            Скидка = ТекущиеСкидки.Получить(Строка.Ключ);
            
            Родитель = Строка.Ключ;
            
            Пока Скидка = Неопределено
                И Родитель <> Справочники.Товары.ПустаяСсылка() Цикл
                Скидка = ТекущиеСкидки.Получить(Родитель);
                Родитель = Родитель.Родитель;
            КонецЦикла;
            
            Если Скидка <> Неопределено Тогда
                Строка.Значение.Данные.Скидка = Скидка;
            КонецЕсли;
            
        Иначе
            Строка.Значение.Данные.Скидка = Скидка;
        КонецЕсли;
        
    КонецЦикла;
    
КонецПроцедуры

&НаСервереБезКонтекста
Процедура СписокПриПолученииДанныхНаСервере(ИмяЭлемента, Настройки, Строки)
    
    МассивТоваров = Новый Массив;
    
    Для Каждого Строка Из Строки Цикл
        
        МассивТоваров.Добавить(Строка.Ключ);
        
        Родитель = Строка.Ключ.Родитель;
        
        Пока Родитель <> Справочники.Товары.ПустаяСсылка() Цикл
            
            Если МассивТоваров.Найти(Родитель) = Неопределено Тогда
                МассивТоваров.Добавить(Родитель);
            КонецЕсли;
            
            Родитель = Родитель.Родитель;
            
        КонецЦикла;
        
    КонецЦикла;
    
    ТекстЗапроса =
    "ВЫБРАТЬ
    |    Скидки.Товар КАК Товар,
    |    Скидки.Скидка КАК Скидка
    |ИЗ
    |    РегистрСведений.Скидки КАК Скидки
    |ГДЕ
    |    Скидки.Товар В(&Товар)";
    
    Запрос = Новый Запрос(ТекстЗапроса);
    Запрос.УстановитьПараметр("Товар", МассивТоваров);
    Результат = Запрос.Выполнить();
    
    ТекущиеСкидки = Новый Соответствие;
    
    Выборка = Результат.Выбрать();
    
    Пока Выборка.Следующий() Цикл
        ТекущиеСкидки.Вставить(Выборка.Товар, Выборка.Скидка);
    КонецЦикла;
    
    АдресСкидокНаГруппуВоВременномХранилище = Неопределено;
    Настройки.ДополнительныеСвойства.Свойство("АдресСкидокНаГруппуВоВременномХранилище", АдресСкидокНаГруппуВоВременномХранилище);
    
    Если АдресСкидокНаГруппуВоВременномХранилище = Неопределено Тогда
        СкидкиНаГруппу = Новый Соответствие;
    Иначе
        СкидкиНаГруппу = ПолучитьИзВременногоХранилища(АдресСкидокНаГруппуВоВременномХранилище);
    КонецЕсли;
    
    АдресСкидокНаЭлементВоВременномХранилище = Неопределено;
    Настройки.ДополнительныеСвойства.Свойство("АдресСкидокНаЭлементВоВременномХранилище", АдресСкидокНаЭлементВоВременномХранилище);
    
    Если АдресСкидокНаЭлементВоВременномХранилище = Неопределено Тогда
        СкидкиНаЭлемент = Новый Соответствие;
    Иначе
        СкидкиНаЭлемент = ПолучитьИзВременногоХранилища(АдресСкидокНаЭлементВоВременномХранилище);
    КонецЕсли;
    
    Для Каждого Строка Из Строки Цикл
        
        Скидка = СкидкиНаЭлемент.Получить(Строка.Ключ);
        
        Родитель = Строка.Ключ;
        
        Пока (Скидка = Неопределено
            ИЛИ Скидка = NULL)
            И Родитель <> Справочники.Товары.ПустаяСсылка() Цикл
            Скидка = СкидкиНаГруппу.Получить(Родитель);
            Родитель = Родитель.Родитель;
        КонецЦикла;
        
        Если Скидка = Неопределено Тогда
            
            Скидка = ТекущиеСкидки.Получить(Строка.Ключ);
            
            Родитель = Строка.Ключ;
            
            Пока Скидка = Неопределено
                И Родитель <> Справочники.Товары.ПустаяСсылка() Цикл
                Скидка = ТекущиеСкидки.Получить(Родитель);
                Родитель = Родитель.Родитель;
            КонецЦикла;
            
            Если Скидка <> Неопределено Тогда
                Строка.Значение.Данные.Скидка = Скидка;
            КонецЕсли;
            
        Иначе
            Строка.Значение.Данные.Скидка = Скидка;
        КонецЕсли;
        
    КонецЦикла;
    
КонецПроцедуры

&НаКлиенте
Процедура УстановитьСкидкуНаГруппу(Команда)
    
    НачальнаяСкидка = Неопределено;
    
    Для Каждого Ссылка Из Элементы.Дерево.ВыделенныеСтроки Цикл
        
        Если Ссылка = ПредопределенноеЗначение("Справочник.Товары.ПустаяСсылка") Тогда
            Продолжить;
        КонецЕсли;
        
        Если НачальнаяСкидка = Неопределено Тогда
            НачальнаяСкидка = Элементы.Дерево.ДанныеСтроки(Ссылка).Скидка;
        ИначеЕсли НачальнаяСкидка <> Элементы.Дерево.ДанныеСтроки(Ссылка).Скидка Тогда
            НачальнаяСкидка = 0;
            Прервать;
        КонецЕсли;
        
    КонецЦикла;
    
    Если НачальнаяСкидка <> Неопределено Тогда
        ПоказатьВводЧисла(Новый ОписаниеОповещения("УстановитьСкидкуНаГруппуЗавершение", ЭтотОбъект), НачальнаяСкидка, , 10, 2);
    КонецЕсли;
    
КонецПроцедуры

&НаКлиенте
Процедура УстановитьСкидкуНаЭлемент(Команда)
    
    НачальнаяСкидка = Неопределено;
    
    Для Каждого Ссылка Из Элементы.Список.ВыделенныеСтроки Цикл
        
        Если Ссылка = ПредопределенноеЗначение("Справочник.Товары.ПустаяСсылка") Тогда
            Продолжить;
        КонецЕсли;
        
        Если НачальнаяСкидка = Неопределено Тогда
            НачальнаяСкидка = Элементы.Список.ДанныеСтроки(Ссылка).Скидка;
        ИначеЕсли НачальнаяСкидка <> Элементы.Список.ДанныеСтроки(Ссылка).Скидка Тогда
            НачальнаяСкидка = 0;
            Прервать;
        КонецЕсли;
        
    КонецЦикла;
    
    Если НачальнаяСкидка <> Неопределено Тогда
        ПоказатьВводЧисла(Новый ОписаниеОповещения("УстановитьСкидкуНаЭлементЗавершение", ЭтотОбъект), НачальнаяСкидка, , 10, 2);
    КонецЕсли;
    
КонецПроцедуры

&НаКлиенте
Процедура УбратьСкидкуНаГруппу(Команда)
    
    ОбновитьСкидкиНаГруппу(NULL);
    
    Элементы.Дерево.Обновить();
    Элементы.Список.Обновить();
    
КонецПроцедуры

&НаКлиенте
Процедура УбратьСкидкуНаЭлемент(Команда)
    
    ОбновитьСкидкиНаЭлемент(NULL);
    
    Элементы.Список.Обновить();
    
КонецПроцедуры

&НаКлиенте
Процедура ЗаписатьСкидки(Команда)
    
    ЗаписатьСкидкиНаСервере();
    
КонецПроцедуры

&НаСервере
Процедура ЗаписатьСкидкиНаСервере()
    
    АдресСкидокНаГруппуВоВременномХранилище = Неопределено;
    Дерево.КомпоновщикНастроек.Настройки.ДополнительныеСвойства.Свойство("АдресСкидокНаГруппуВоВременномХранилище", АдресСкидокНаГруппуВоВременномХранилище);
    
    Если АдресСкидокНаГруппуВоВременномХранилище = Неопределено Тогда
        СкидкиНаГруппу = Новый Соответствие;
    Иначе
        СкидкиНаГруппу = ПолучитьИзВременногоХранилища(АдресСкидокНаГруппуВоВременномХранилище);
    КонецЕсли;
    
    АдресСкидокНаЭлементВоВременномХранилище = Неопределено;
    Список.КомпоновщикНастроек.Настройки.ДополнительныеСвойства.Свойство("АдресСкидокНаЭлементВоВременномХранилище", АдресСкидокНаЭлементВоВременномХранилище);
    
    Если АдресСкидокНаЭлементВоВременномХранилище = Неопределено Тогда
        СкидкиНаЭлемент = Новый Соответствие;
    Иначе
        СкидкиНаЭлемент = ПолучитьИзВременногоХранилища(АдресСкидокНаЭлементВоВременномХранилище);
    КонецЕсли;
    
    Для Каждого Элемент Из СкидкиНаГруппу Цикл
        
        Запись = РегистрыСведений.Скидки.СоздатьМенеджерЗаписи();
        Запись.Товар = Элемент.Ключ;
        
        Если Элемент.Значение = NULL Тогда
            Запись.Удалить();
        Иначе
            Запись.Скидка = Элемент.Значение;
            Запись.Записать();
        КонецЕсли;
        
    КонецЦикла;
    
    Для Каждого Элемент Из СкидкиНаЭлемент Цикл
        
        Запись = РегистрыСведений.Скидки.СоздатьМенеджерЗаписи();
        Запись.Товар = Элемент.Ключ;
        
        Если Элемент.Значение = NULL Тогда
            Запись.Удалить();
        Иначе
            Запись.Скидка = Элемент.Значение;
            Запись.Записать();
        КонецЕсли;
        
    КонецЦикла;
    
КонецПроцедуры

&НаКлиенте
Процедура УстановитьСкидкуНаГруппуЗавершение(Число, ДополнительныеПараметры) Экспорт
    
    Если Число = Неопределено Тогда
        Возврат;
    КонецЕсли;
    
    ОбновитьСкидкиНаГруппу(Число);
    
    Элементы.Дерево.Обновить();
    Элементы.Список.Обновить();
    
КонецПроцедуры

&НаКлиенте
Процедура УстановитьСкидкуНаЭлементЗавершение(Число, ДополнительныеПараметры) Экспорт
    
    Если Число = Неопределено Тогда
        Возврат;
    КонецЕсли;
    
    ОбновитьСкидкиНаЭлемент(Число);
    
    Элементы.Список.Обновить();
    
КонецПроцедуры

&НаСервере
Процедура ОбновитьСкидкиНаГруппу(Число)
    
    АдресСкидокНаГруппуВоВременномХранилище = Неопределено;
    Дерево.КомпоновщикНастроек.Настройки.ДополнительныеСвойства.Свойство("АдресСкидокНаГруппуВоВременномХранилище", АдресСкидокНаГруппуВоВременномХранилище);
    
    Если АдресСкидокНаГруппуВоВременномХранилище = Неопределено Тогда
        Скидки = Новый Соответствие;
    Иначе
        Скидки = ПолучитьИзВременногоХранилища(АдресСкидокНаГруппуВоВременномХранилище);
    КонецЕсли;
    
    Для Каждого Ссылка Из Элементы.Дерево.ВыделенныеСтроки Цикл
        
        Если Ссылка = Справочники.Товары.ПустаяСсылка() Тогда
            Продолжить;
        КонецЕсли;
        
        Скидки.Вставить(Ссылка, Число);
        
    КонецЦикла;
    
    Если АдресСкидокНаГруппуВоВременномХранилище = Неопределено Тогда
        АдресСкидокНаГруппуВоВременномХранилище = ПоместитьВоВременноеХранилище(Скидки, Новый УникальныйИдентификатор());
        Дерево.КомпоновщикНастроек.Настройки.ДополнительныеСвойства.Вставить("АдресСкидокНаГруппуВоВременномХранилище", АдресСкидокНаГруппуВоВременномХранилище);
        Список.КомпоновщикНастроек.Настройки.ДополнительныеСвойства.Вставить("АдресСкидокНаГруппуВоВременномХранилище", АдресСкидокНаГруппуВоВременномХранилище);
    Иначе
        ПоместитьВоВременноеХранилище(Скидки, АдресСкидокНаГруппуВоВременномХранилище);
    КонецЕсли;
    
КонецПроцедуры

&НаСервере
Процедура ОбновитьСкидкиНаЭлемент(Число)
    
    АдресСкидокНаЭлементВоВременномХранилище = Неопределено;
    Список.КомпоновщикНастроек.Настройки.ДополнительныеСвойства.Свойство("АдресСкидокНаЭлементВоВременномХранилище", АдресСкидокНаЭлементВоВременномХранилище);
    
    Если АдресСкидокНаЭлементВоВременномХранилище = Неопределено Тогда
        Скидки = Новый Соответствие;
    Иначе
        Скидки = ПолучитьИзВременногоХранилища(АдресСкидокНаЭлементВоВременномХранилище);
    КонецЕсли;
    
    Для Каждого Ссылка Из Элементы.Список.ВыделенныеСтроки Цикл
        
        Если Ссылка = Справочники.Товары.ПустаяСсылка() Тогда
            Продолжить;
        КонецЕсли;
        
        Скидки.Вставить(Ссылка, Число);
        
    КонецЦикла;
    
    Если АдресСкидокНаЭлементВоВременномХранилище = Неопределено Тогда
        АдресСкидокНаЭлементВоВременномХранилище = ПоместитьВоВременноеХранилище(Скидки, Новый УникальныйИдентификатор());
        Список.КомпоновщикНастроек.Настройки.ДополнительныеСвойства.Вставить("АдресСкидокНаЭлементВоВременномХранилище", АдресСкидокНаЭлементВоВременномХранилище);
    Иначе
        ПоместитьВоВременноеХранилище(Скидки, АдресСкидокНаЭлементВоВременномХранилище);
    КонецЕсли;
    
КонецПроцедуры

   Злопчинский
 
606 - 08.10.19 - 01:01
я както слабо понимаю.
почему говорять что в САП аудиторский след есть, а в 1С - нет.
возможность аудиторского следа - это неотключаемая возмоюность, вшитая в платформу? или как? но ведь данные то не в платформе хрантся? а в "хранилище" какомто. всегда можно в хранилище если припрет - зайти "сбоку".
??
   _DAle_
 
608 - 08.10.19 - 01:07
(597) Сейчас, напишу ответ на этот вопрос и пойду спать.

>Изначальную позицию "В 1С нет и не может быть ничего хорошего"

Ну вот не было такой изначальной позиции. Даже в этих миллионах сообщений проскакивало, что понятное дело, в 1С в любом случае есть свои преимущества. Мне кажется, что с этим трудно спорить. И такие утверждения, если они здесь и были, это троллинг и преувеличение.

>Вранье и передергивание кругом и везде

Я понимаю, о чем вы. Но я, читая, как сторонний наблюдатель, весь этот флуд, видел, что в большинстве таких ситуаций - это не вранье, это просто недопонимание как с одной стороны, так и с другой. Вообще, когда люди говорят на разных языках (конкретно здесь, пользуются различными терминологиями), а еще и спорят при этом, часто так и получается.

>Про табличку сравнения и негативный хайп мне сложно что-то возразить. Скажу только, что табличка, если знать, что под каждым пунктом подразумевал ее автор, конечно, с его точки зрения верна. Но да.. мне она тоже не нравится в таком виде :)
   RomanYS
 
610 - 08.10.19 - 01:14
(606) Как я понимаю, речь про типовые. Во всех типовых при наличии  прав можно зайти и поменять любой документ.
В САПе ни у кого таких прав не будет, и ты будешь делать десяток корректировок вместо одной правки документа
   Злопчинский
 
611 - 08.10.19 - 01:15
я как-то слабо понимаю.
почему говорят что в САП аудиторский след есть, а в 1С - нет.
возможность аудиторского следа - это не отключаемая возможность, вшитая в платформу? или как? но ведь данные то не в платформе хранится? а в "хранилище" каком-то. всегда можно в хранилище если припрет - зайти "сбоку".
??
   PR
 
612 - 08.10.19 - 01:17
(602) В твоем случае будет печалька, если ты хочешь на все велосипеды дать ссылку 5%, а на один конкретный не хочешь давать ссылку
   PR
 
613 - 08.10.19 - 01:19
(608) Ну, мягко говоря, в случае Краша и Бро это не совсем и не всегда так, но твоя позиция понятна
Главным изначальным посылом к негативу конечно же была статья с непрофессиональным анализом 1С
   Злопчинский
 
614 - 08.10.19 - 01:20
(610) мы говорим про рядовых пользователей, которые чисто юзеры?
но ведь админы ситсемы могут поменят в обход, например проямой правкой табличек. если мы говорим что в сап админ системы вообще не имеет доступа в продуктивный контур, то и в 1с такую же организационную схему можно организовать.
даже если админ не имеет доступ в прод.контур - что мешает админру в обновлении внутри "спрятать" скриптик, который подотрет что надо, а следующим обновлением скриптик потереть?
   Злопчинский
 
615 - 08.10.19 - 01:26
(612) ну, здесь без нулл нехорошо, это да, если такой велосипед нельзя в другую группу запихнуть.
.
при таком ограничении схема всего лишь чуть усложняется не указанием значений числа скидки, а указанием или неуказанием ссылки на справочник со значениями скидок. короче чистая прикладная задача, проблем каких-то особых не вижу. но вообще если говорить - это в принципе неинтересно такие задачи.
   Мэс33
 
616 - 08.10.19 - 01:48
(611) ты сделал ошибочный документ, и он останется в системе. Если ты через полгода хочешь изменить документ прихода полугодовой давности и перепровести документы - ты не можешь этого сделать. Все исправления через документ сторно, а это часто через аппрувинг вышестоящим руководством.
   Мэс33
 
617 - 08.10.19 - 02:01
(614) могут и в 1с принудительно закрыть, но лазейки останутся, можно все же документ открыть для редактирования и перепровести.
В сапе на уровне платформы запрещено. Через бд и миллионы таблиц можно и попробовать. Только это довольно сложно и затратно.
   Мэс33
 
618 - 08.10.19 - 02:05
(617) в сапе образца 2005 года я слышал в структуре было 25000 таблиц. Ни один консультант не знает всей этой системы. Ни один админ не знает структуры всех таблиц, чтобы куда то руками лезть. И даже консультант по направлению не знает всех используемых таблиц по его направлению (модулю). А если было закрытие периода в сапе - то менять что-либо, не боясь поломать весь учёт из-за хотелки глбуха? Вряд ли.
   rphosts
 
619 - 08.10.19 - 02:27
(1) куда опаснее если будет реакция от товарищей с Дмитровского шоссе 9Б.
   rphosts
 
620 - 08.10.19 - 02:28
Голосувалки не хватает... ща поправлю!
   rphosts
 
621 - 08.10.19 - 02:31
Разумеется!

1. От тайги до британских морей 1С нет сильней!
   Devilment
 
622 - 08.10.19 - 04:28
(437) Силён. Читать диалоги в стиле:
-Это же красное...
-Нет, это тёплое...
, и так на протяжении десятков комментов как-то вообще не прикольно
   shuhard
 
623 - 08.10.19 - 06:41
(597) в команде нет сэйлов, она(команда) не умеет вести коммерческие переговоры и работать с возражениями, не имеет стратегии, не дала себе труд спозиционировать систему



всё остальное следствие и да, мания величия в неоперабельной форме, попытка выдать своё недоразумение за бэст-практик
   DrZombi
 
624 - 08.10.19 - 06:53
Если есть кнопка, на неё обязательно нажмут ;)

5. 1С - тупиковая ветвь... она обречена
   Devilment
 
625 - 08.10.19 - 07:14
(623) А кто тогда у них ведёт переговоры "с крупнейшими игроками рынка" продажи торгового оборудования в РФ? Они грозятся вот-вот их всех окучить, и уже они понесут свет фузины в массы...
   shuhard
 
626 - 08.10.19 - 07:35
(625) а нет переговоров, это очередная дэза, рынок давно поделен и торговое оборудование продаётся уже под существующие фронты,
ту же GESTORI lsFusion не подвинет, при всей архаичности первой, поскольку это СКАН СИТИ, про Атол и Штрих и так понятно




продает скорее всего тех.директор =)
   Devilment
 
627 - 08.10.19 - 08:06
(626) Джестори, конечно, тот ещё адок, вот кому бы пора умереть :)) А переговоры вполне могут идти в стиле - фузиновцы выслали им свои предложения и ждут ответа :))
   strange2007
 
628 - 08.10.19 - 08:33
Ой дурниииии... Неужели так и не понимают, что историю учить надо((((
Знаете, друзья, а мне жаль фужинцев. Они же как дети наивные. Думают, что за правое дело борются.
Почитал хабросрач и понимаю, что фужиновцы вообще уникальные. Ранешние убивцы 1С хотя бы понимали, что надо работать на бизнес, а не на трукодеров, а эти даже этого не понимают.
   Devilment
 
629 - 08.10.19 - 08:45
(628) Ну, это типично же для технарей, синдром "паровозика, который смог"
   Труп
 
630 - 08.10.19 - 08:51
16 лет в этом году как я работаю с 1С, начинал с 7.7. Убеждаюсь этому -

5. 1С - тупиковая ветвь... она обречена
 
 Рекламное место пустует
   ДенисЧ
 
631 - 08.10.19 - 08:52
(630) Уже 20 лет умирает, никак умереть не может...
Может, хватит закапывать стюардессу?
   Труп
 
632 - 08.10.19 - 08:53
(631) умирать можно десятилетиями.
   Devilment
 
633 - 08.10.19 - 08:58
(631) "То, что мертво - умереть не может" :)))
   rphosts
 
634 - 08.10.19 - 08:59
(631) предлагаешь ее не закапывать вообще?
   rphosts
 
636 - 08.10.19 - 09:00
(630) от чела с таким ником ничего другого ожидать нельзя
   ДенисЧ
 
637 - 08.10.19 - 09:00
(634) Всё равно откапывать придётся... Так что хватит разврата...
   strange2007
 
638 - 08.10.19 - 09:01
Помню, была в Красноярске контора, которая делала убийцу 1С. Без пафоса и обзывалок, они просто ставили её везде в качестве бух конфы. Это прям крутая штука была. А потом разработчики разбежались и система померла.
Помню как Парус отвоёвывал позиции при помощи гос-ва. Но, блин, там реакция на изменения бизнеса чуть-чуть получше чем у САПа. Кому такое надо? Тоже уходит лесом даже с медицины.


(630) Обманываешь. Если бы ты работал с 1С, то знал бы, что люди её ставят, а не что-то другое
   Труп
 
639 - 08.10.19 - 09:03
(636) у тебя чему лучше)?
   Простенький вопросик
 
640 - 08.10.19 - 09:15
Вся эта дешефка для мелколаречников. Но захотят ли они сами это все изучать? Нет. Чтобы прогеры из 1с пошли в фузину, это надо двойной зп замотивировать. Могут мелколаречники такое предложить, которые 10к на лицензии базы решили сэкономить? Нет. Вот и все, не взлетит даже на старте.
   Devilment
 
641 - 08.10.19 - 09:26
(640) Так они заявляют, что фузинист будет получать больше 1С - ника уже сейчас, если к ним работать пойдёт. И, при этом, клиенту будет стоить дешевле 1С-ника.
   rphosts
 
642 - 08.10.19 - 09:36
(638) турбо-бухгалтер?

В Нск была одна фирмочка и через агентов свои поделки неплохо так впихивали в разные организации, в основном в коммерческие, в Кмр тоже неплохо у них дела шли, но вдруг они стали жадными до неимоверности и агентское вознагражение за поддержку уменьшили в разы... через несколько месяцев за все города не скажу но Кмр они потеряли. В частности мне поставили задачу внедрить до НГ 1С-Бух на 7.0... вот тут-то меня 1с и укусила.
   CrushBy
 
643 - 08.10.19 - 10:00
Я вижу, что настоящий 1С программист должен быть как минимум :

1. Дизайнером. Легко определять по интерфейсу программы, что она была выпущена в 2007 году, в Тверской области, западный склон с нотками дизайнов 1996 и 2015 года.
2. Психологом. Убеждать пользователей, что им редактировать в списках не надо, нормальных форм с текущими остатками также, а все делать отчетами, печатать их и убегать с листиками подальше от 1С, чтобы случайно ничего там не сломать.
3. Маркетологом. Прекрасно разбираться в бизнесе. Точно знать как продвигать все возможные программные продукты и впаривать свои поделки за кучу денег, не связываясь с нищебродами, которые не могут себе позволить купить лицензии 1С.
   ДенисЧ
 
644 - 08.10.19 - 10:01
(643) Вот именно. Поэтому 1сник - не программист. А намного больше. В отличие от фузионщиков, как бы те не пыжились
   lEvGl
 
645 - 08.10.19 - 10:05
всего не читал, но смотрю - не первый день темы висят, ажиотаж какой то
что за система, есть ли готовые решения автоматизации каких то прикладных областей, каких? дайте ссылку или расскажите в двух словах
   IamAlexy
 
646 - 08.10.19 - 10:09
(645) затишье перед отчетностью.. 1сники скучают..
   Bro
 
647 - 08.10.19 - 10:10
   IamAlexy
 
648 - 08.10.19 - 10:10
(643) интересно, а как вы убеждаете пользователей что ввод по строке с анализом подбираемых данных не нужен а нужно открывать всегда форму и в ней через фильтры курочить поиск?

психологическими методами или тупо откат начальник а пользователь пусть потерпит?
   IamAlexy
 
649 - 08.10.19 - 10:11
(647) то что вы автоматизировали места кассиров-продавцов и так понятно.. производство покажи. где что то считается где много параметров ит д..
   Salimbek
 
650 - 08.10.19 - 10:13
(595) Дык, посмотрел я на то - как они кодят текст и он отображается в виде визуальных элементов на форме и вообще не вижу проблем сделать обратное - т.е. чтобы ты визуально расставлял элементы, а оно потом тебе готовый коды выдавало.
   CrushBy
 
651 - 08.10.19 - 10:15
(650) Да, на самом деле можно. Как только так сделают в React'е (самой популярной GUI библиотеке) и этим будут активно пользоваться, то мы тоже сделаем.
   Bro
 
652 - 08.10.19 - 10:15
(650) Я может что-то путаю, но даже в УФ так не сделали. То есть снизу дизайн readonly, также как в lsFusion во вкладке Design в IDE.
   СложноСпросить
 
653 - 08.10.19 - 10:21
(651)(652)Вместо того, чтобы мешки с наличностью пересчитывать, вы тут фигней занимаетесь.
   СложноСпросить
 
654 - 08.10.19 - 10:23
Шли бы работать, спортом занялись. у вас наверно еще и машины своей нет.
   RomanYS
 
655 - 08.10.19 - 10:24
(614) Представь, что человек имеющие такие права сидит в другой стране, подчиняется финдиректору группы и без открытого тикета даже пальцем не шелохнёт.
   strange2007
 
656 - 08.10.19 - 10:25
(642) >> турбо-бухгалтер?
Вот честно не помню. Она на фоксе делалась и бывшие разработчики говорили, что она была крутейшей системой для бухгалтерии. Охотно им верил, ведь о трупах плохое не говорят
   Salimbek
 
657 - 08.10.19 - 10:32
(652) Ну да, я и хотел сказать - что как в УФ - перетащил мышкой элемент "Группировка", назначил ему вид - Горизонтальный, внутрь накидал элементов - а оно тебе в ответ человеческим голосом:
NEW params AFTER Box(s)
...
MOVE поле;
caption='Параметры';
type = CONTAINERH;
...
   edem911
 
658 - 08.10.19 - 10:33
о, голосовалка) Ну что бы фузиновцы могли давать ссылку на эту ветку со словами "Вот видите даже на профильном форуме по 1С признали- 1С кабзда")))

5. 1С - тупиковая ветвь... она обречена
   strange2007
 
659 - 08.10.19 - 10:33
(643) >> Я вижу, что настоящий 1С программист должен быть как минимум :
Программист, а не 1С-программист. Привыкли, блин, быдлокодерством гордиться, так нечё доброе имя программистов марать)))))
А если без шуток, то ты забыл ещё
4. Хорошо знать методологию автоматизируемого участка
5. Знать проектную деятельность
6. Иметь огромный практический опыт

А вот твои пункты надо поправить!
1. Это как раз не нужно от слова совсем. Программист думает объектами бизнеса. Это некоторые слои кодеров ревностно относятся ко всему, что на них не похоже.
2. Да, психологом. Но как раз для того, что бы находить общий язык с пользователями, которые, не владея всем спектром инструментария, должны попытаться объяснить чего хотят. Вот тут то как раз самое сложное, т.к. там идёт постоянное перекладывание ответственности за косяки и незнания пользователей.
3. Враньё. Программист работает как с ларьками, так и с крупными предприятиями, не деля их на белое и чёрное. Тут ты опять спутал с фьюженцами, у которых через раз пренебрежительное фи
   Мэс33
 
660 - 08.10.19 - 10:42
Выбрал этот пункт чисто поржать

5. 1С - тупиковая ветвь... она обречена
 
 Рекламное место пустует
   Garykom
 
661 - 08.10.19 - 10:43
Согласен насчет поржать

5. 1С - тупиковая ветвь... она обречена
   CrushBy
 
662 - 08.10.19 - 10:44
(605) Уважаем PR, а можно ваш код приложить к статье с Иерархией. Ну, чтобы читатели смогли сравнить, насколько удобно программировать на lsFusion и насколько на 1С.

Я тоже чисто поржать.

1. От тайги до британских морей 1С нет сильней!
   edem911
 
663 - 08.10.19 - 10:48
открыл https://lsfusion.org/ выбрал  галочкой "Бизнесу" - то есть подразумевается что плюсы для бизнеса в  lsfusion будут:
1. Время разработки и внедрения функционала измеряется часами, а не неделями. Быстрее чем когда-либо.
2. Порог вхождения ниже чем когда-либо.
3. Множество оптимизаторов на каждом уровне выжмут максимум из существующей инфраструктуры
4. Высокая отказоустойчивость и масштабируемость.
5. Любая ОС. Любая реляционная СУБД. Веб или десктоп. Любые каналы связи. Сотни одновременных пользователей на 1МБ/с. Cloud-ready.
6. Свободное использование и распространение
7. Гибкая политика безопасности на всех уровнях.
8. Встроенное шифрование передаваемых данных. Corporate-ready.
хотя не пойму зачем эти пункты бизнесу, но все же можно конкретное подтверждение по каждому пункту,  а то когда смотришь "Подробнее" там куча маркетингового мусора, но ничего не расписано.
Особенно интересно "Любая реляционная СУБД" - MS SQL?
   ДенисЧ
 
664 - 08.10.19 - 10:50
(663) "Любая реляционная СУБД" - MS SQL"
База у них постгре.
Вот интересно, Монга субдой считается? Горазды они на ней запуститься? Или на худой конец на SQLite?
   edem911
 
665 - 08.10.19 - 10:53
(664)  То есть не любая все таки а строго определенная?) Хотелось бы подтверждение от представителей lsfusion
   ПускинАС
 
666 - 08.10.19 - 10:54
(0) Просто Батька дал команду! Ребята действуют, сделали что-то им нравится, насильно мил не будешь. Мне не нравится в платформе
1. Постгре
2. Мало кода, он не читаем и не красив
3. Дурацкие фильтры аля 97 год.
4. Название ... Buzzaa подошло бы больше или Baida

1. От тайги до британских морей 1С нет сильней!
   Ещё1
 
667 - 08.10.19 - 10:56
(641) Обещают зп 1000 бел. руб. на этапе обучения, и 2500 - 6000 опосля.
https://news.tut.by/press/656172.html
(Чтоб перевести в доллары, делите на 2).
   CrushBy
 
668 - 08.10.19 - 10:56
(665) В LGPL версии пока (и скорее всего потом) есть поддержка только PostgreSQL. В дальнейшем, возможно, будет коммерческая с поддержкой коммерческих СУБД. А чем Вам PostgreSQL не угодил то ?
   CrushBy
 
669 - 08.10.19 - 10:57
(667) Это после всех налогов, кстати.
   CrushBy
 
670 - 08.10.19 - 10:58
(666) 2. Ну сравните код :
(605) и https://habr.com/ru/company/lsfusion/blog/468047/

Где более читаемый и простой код ?
   Bro
 
671 - 08.10.19 - 10:59
(663) 1. Не надо объяснять?
2. Можно взять человека с улицы (или из компании) и обучить. Есть прецеденты
3. Железо дешевое.
4. Не надо объяснять?
5. TCO дешевое. Не нужно доплицензии.
6. Бесплатно
7-8. Безопасность

Подробнее кидает на возможности. Что там непонятно?
   Bro
 
672 - 08.10.19 - 10:59
(663) MS SQL поддержка есть, в продакшне просто ни кого не удалось убедить поставить. Потому как и на PostgreSQL отлично работает
   Труп
 
673 - 08.10.19 - 11:00
(670) (671) жесть, вы находитесь в логове ос. Как до сих пор удается продержаться, не понимаю))
   СложноСпросить
 
674 - 08.10.19 - 11:03
(671) все дешевое и бесплатное и бац отдавай чуваку с улицы 3 штуки баков каждый месяц, разрыва шаблонов у бизнеса не будет?
   СложноСпросить
 
675 - 08.10.19 - 11:06
обслуживание софта за три копейки не может стоить тысячей долларов в месяц
   Ещё1
 
676 - 08.10.19 - 11:08
(669) Учитывая, что зазываете всех, осиливших тест (менеджеров, секретарш, водителей), и имея ввиду ср. з/п по Беларуси 1117 рублей, думаю нормально.
https://myfin.by/wiki/term/srednyaya-zarplata-v-belarusi
   Bro
 
677 - 08.10.19 - 11:12
(675) ну учитывая что один разработчик lsFusion решает в раза 4 больше задач, чем  1с никакого разрыва нет.
   3achem
 
678 - 08.10.19 - 11:13
(430) Что вы впариваете свой BI. Ещё раз вам задам вопрос, вы знаете, что такое XBRL и почему удобно это делать на СКД?
   СложноСпросить
 
679 - 08.10.19 - 11:13
(677) работает больше, получает меньше? он идиот?
   Bro
 
680 - 08.10.19 - 11:16
(679) не работает, а решает задач. Понимаете разницу?
   gSha
 
681 - 08.10.19 - 11:16
В рублях разницу можно. Согласен даже в беларусских.
   3achem
 
682 - 08.10.19 - 11:18
(680) Уважаемый, не игнорируйте неудобные вопросы, а то снова Троцким обзывать начну
   СложноСпросить
 
683 - 08.10.19 - 11:18
(680) разницу я понимаю в долларах.
   edem911
 
684 - 08.10.19 - 11:20
(680) Можно где нибудь увидеть вакансию "Разработчика lsFusion", они кому то нужны?
   gSha
 
685 - 08.10.19 - 11:20
Например ставка программиста/консультанта/пи ар менеджера у вас за час
и ставка у конкурента ..
а то может лучше жаву учить ..
   Bro
 
686 - 08.10.19 - 11:21
(678) тут что такое суд объяснить не могут, а вы собрались объяснять почему на нем что то удобно делать. Ну ок на lsFusion это ещё удобнее делать.
   СложноСпросить
 
687 - 08.10.19 - 11:21
в Белоруссии с прогерами очень сложно, все работают на забугорных галерах типа эпама и прочих за доллары.
   Bro
 
688 - 08.10.19 - 11:22
*СКД
   СложноСпросить
 
689 - 08.10.19 - 11:22
(686) допустим удобнее, а на 1С платят больше, не говоря про всякие джавы и питоны
   Bro
 
690 - 08.10.19 - 11:23
   Flyd-s
 
691 - 08.10.19 - 11:23
(688), и вы не поняв что такое СКД утверждаете, что он не нужен
   Bro
 
692 - 08.10.19 - 11:23
(689) ну то есть сама платформа дороже так ещё и разработчики?
   Bro
 
693 - 08.10.19 - 11:24
(691) ну вы тоже про lsFusion ничего не знаете, но что то утверждаете
   СложноСпросить
 
694 - 08.10.19 - 11:25
(692) вы на форуме разработчиков, если вы хотите что то нам предложить, то предлагайте доллары.
   Ещё1
 
695 - 08.10.19 - 11:26
(681) На jobs.tut.by сейчас 200 вакансий на программиста 1С. З/п - от 500 бел. руб. до 5500 бел руб. Что немного ниже предложенных ЛюксСофт.
   Flyd-s
 
696 - 08.10.19 - 11:26
(691), я по большей части задаю вопросы, а не утверждаю и на вопросы ответов не нахожу
   СложноСпросить
 
697 - 08.10.19 - 11:26
не нужно нам предлагать платформу за три копейки
   edem911
 
698 - 08.10.19 - 11:31
(690) то есть на все СНГ с количеством пользователей информационных систем более 180 млн(или сколько вы писали) всего 1 вакансия разработчика LSfusion и та у головного разработчика.
Исходя из этого я могу сделать вывод, что lsFusion на рынке просто нет.
   strange2007
 
699 - 08.10.19 - 11:31
А тестовое задание прикольное. Сразу выявляется кто сможет быстро изучить платформу, а кто нет.
   gSha
 
700 - 08.10.19 - 11:35
(695) Люкс софт это понимаю единственный работодатель и альтернатива ему это 0 рублей ?
  1  2  3  4  5  6  7  8  9  10  11   

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Тема не обновлялась длительное время, и была помечена как архивная. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.