Вход | Регистрация
 
1С:Предприятие :: 1С:Предприятие 8 общая

Возможна ли печать чека коррекции без бумаги на ККТ АТОЛ-50Ф.

Возможна ли печать чека коррекции без бумаги на ККТ АТОЛ-50Ф.
Я
   jobkostya1c
 
16.08.19 - 09:48
Здравствуйте. Приобрели онлайн-кассу АТОЛ-50Ф. Вопрос бухгалтера: можно ли напечатать чек коррекции на данной модели ККТ без бумаги?
Пробовали через 1С Бухгалтерия 3.0 КОРП и через драйвер (везде последние релизы, ПО кассы обновлено) - при снятии галки "не печатать" для чека коррекции - все равно выходит на бумагу.
Люди, кто сталкивался с подобным вопросом. Это зависит от каких-то настроек ККТ, программы фронт-офиса: 1С, фронтол. или такая возможность методологически для данного типа чека не предусмотрена (например ККТ Казначей КА вообще работает без бумаги).  Для "обычных" чеков возможность печать без бумаги есть - только нужно указать е-майл или телефон покупателя. Как через 1С, так и через драйвер. Тег 1008 по ФЗ-54 в данном случае обязателен к заполнению и его можно посмотреть в памяти фискального накопителя через драйвер. Прочитал по законодательству что данный тег 1008 - для чека коррекции не обязателен и его я не могу прочитать в фискальной памяти.
Где-то читал, что "покупатель ушел безвозвратно и чек ему все равно не передать".
Задаю данный вопрос в связи с необходимостью доработки своей внешней обработки для пакетной печати чеков коррекции для физических ККТ.
Заранее спасибо. Константин.
 
 
   jobkostya1c
 
1 - 16.08.19 - 13:05
Дополнительно, раз тут нельзя приложить скриншоты всех настроек вот ссылка https://forum.infostart.ru/forum28/topic223918/
Заранее всем спасибо за любую информацию.
   isa2net
 
2 - 16.08.19 - 13:16
Вы KaaS свой делаете? 1000 чеков коррекции - это методологически не очень адекватное решение, ИМХО.
   Йохохо
 
3 - 16.08.19 - 13:23
брр "если конец месяца приходится на выходной день и бухгалтерия работать не будет, то на следующий рабочий день мы обязаны пробить чек коррекции по "непробитому" документу" то есть вы хотите методически торговать без ккт?
   цтошник
 
4 - 16.08.19 - 14:13
То что налоговая разрешает делать только в исключительных случаях после согласования с ней вы хотите сделать как штатный механизм да ещё и бухам сказать работать в обход действующего законодательства про прибитою чеков
   jobkostya1c
 
5 - 16.08.19 - 14:26
Никто не торгует. Допустим, уже был факт поступления денежных средств от физ. лица на р/с и нужно в этот же день по-законодательству пробить обычный чек прихода. Тоже самое по реализациям. Допускается пробить чеки только последним днем месяца. Еще куча нюансов когда, как и какие чеки нужно пробивать. Вопрос не в методологии бухгалтерии, а в технической возможности самой ККТ-онлайн пробить чек коррекции без бумаги. Понимаю, есть кассы типа "Казначей КА" и там можно пробить без бумаги.

Дальше уже если ККТ поддерживает можно копать как без изменения типовых механизмов Бухгалтерии 3.0 КОРП можно реализовать данную задачу. Печать "обычного" чека из обработки печати в Бух 3.0 без бумаги уже 1С-никами реализована. Для нее уже готова пакетная печать без бумаги. Пакетную печать чеков коррекции я тоже реализовал, но на бумаге. На несколько ККТ - тоже реализовано.

А насчет пробития 1000 чеков/сутки, гм. еще, возможно, нолик к цифре хорошо если один.
   isa2net
 
6 - 16.08.19 - 15:37
"Схему оплаты «на расчетный счет» следует принципиально отличать от схемы, при которой покупатель товаров и услуг рассчитывается с продавцом непосредственно на его сайте — с помощью банковской карты или иного электронного средства платежа." - что у вас конкретно?
Если на р/с , тогда "5.4. При осуществлении расчетов, указанных в пункте 5.3 настоящей статьи, кассовый чек (бланк строгой отчетности) должен быть сформирован не позднее рабочего дня, следующего за днем осуществления расчета, но не позднее момента передачи товара.". То есть вам нужно автоматизировать фискализацию по событию получения выписок, а это обычно происходит в рабочие дни. Если же у вас оплата через сайт, то берите сервис или реализуйте его сами.
А сейчас вы автоматизируете нарушение.
   jobkostya1c
 
7 - 19.08.19 - 14:38
Насчет законодательства, вопрос спорный. Вот нашел по документации ИТС что подобное невозможно. На методы (ОбъектДрайвера - внешняя компонента *.dll (оба нашел опытным путем):
1. Печать обычных чеков (прихода, расхода, возврата прихода, возврата расхода): СформироватьЧек (ProcessCheck)
Параметр: Электронно (Electronically) 
Тип:    BOOL (IN)    
Описание: Формирование чека в только электроном виде. Печать чека не осуществляется.

2. Для чеков коррекции метод СформироватьЧекКоррекции (ProcessCorrectionCheck)
И у данного метода в описании ничего нет :( для формирования только в электронном виде.

Ссылка на документацию ИТС (не было раньше доступа, закончился некстати).

У меня вопросы как искать актуальную версию описания (видимо, одна из архивных).
В регистре сведений "Версии подсистем" бухгалтерии 3.0 КОРП установлено:

БиблиотекаПодключаемогоОборудования: 2.1.1.10 
СтандартныеПодсистемы: 3.0.1.428 

А документация только от раздела 2.2 Архив версий на ИТС.

В коде для обычного чека в отладчике:

Если ПараметрыФискализации.СформироватьЧекКоррекции Тогда
            Если ПараметрыФискализации.РевизияИнтерфейса >= 3000 Тогда// Версия стандарта 3.0 (ОФД 1.1)

                Результат = ОбъектДрайвера.СформироватьЧекКоррекции(ПараметрыПодключения.ИДУстройства, ПараметрыФискализации.ДанныеЧекаXML, ПараметрыФискализации.РезультатОперацииXML);
            Иначе
                Результат = ОбъектДрайвера.СформироватьЧекКоррекции(ПараметрыПодключения.ИДУстройства, ПараметрыФискализации.ДанныеЧекаXML, ПараметрыФискализации.НомерЧекаККТ, ПараметрыФискализации.НомерСменыККТ, 
                    ПараметрыФискализации.ФискальныйПризнак, ПараметрыФискализации.АдресСайтаПроверки); 
                ПараметрыФискализации.ДатаВремяЧека = ДатаСеанса;
            КонецЕсли;
        Иначе
            Попытка
                Если ПараметрыФискализации.РевизияИнтерфейса >= 3000 Тогда// Версия стандарта 3.0 (ОФД 1.1)

                    Результат = ОбъектДрайвера.СформироватьЧек(ПараметрыПодключения.ИДУстройства, ПараметрыФискализации.Электронно, ПараметрыФискализации.ДанныеЧекаXML, ПараметрыФискализации.РезультатОперацииXML); 
                ИначеЕсли ПараметрыФискализации.РевизияИнтерфейса > 2001 Тогда// Версия стандарта 2.2 (ОФД 1.0.5)

                    Результат = ОбъектДрайвера.СформироватьЧек(ПараметрыПодключения.ИДУстройства, ПараметрыФискализации.Электронно, 
                        ПараметрыФискализации.ДанныеЧекаXML, ПараметрыФискализации.НомерЧекаККТ, ПараметрыФискализации.НомерСменыККТ, ПараметрыФискализации.ФискальныйПризнак, ПараметрыФискализации.АдресСайтаПроверки); 
                    ПараметрыФискализации.ДатаВремяЧека = ДатаСеанса;
                Иначе// Версия стандарта 2.1 (ОФД 1.0)

                    Кассир = ?(ВходныеПараметры <> Неопределено И ВходныеПараметры.Свойство("Кассир"), ВходныеПараметры.Кассир, НСтр("ru='Администратор'"));
                    Результат = ОбъектДрайвера.СформироватьЧек(ПараметрыПодключения.ИДУстройства, Кассир, ПараметрыФискализации.Электронно, 
                        ПараметрыФискализации.ДанныеЧекаXML, ПараметрыФискализации.НомерЧекаККТ, ПараметрыФискализации.НомерСменыККТ, ПараметрыФискализации.ФискальныйПризнак, ПараметрыФискализации.АдресСайтаПроверки); 
                    ПараметрыФискализации.ДатаВремяЧека = ДатаСеанса;
                КонецЕсли;
            Исключение
                Результат = Ложь;
                ВыходныеПараметры.Очистить();
                ВыходныеПараметры.Добавить(999);
                ВыходныеПараметры.Добавить(НСтр("ru='Ошибка вызова метода <ОбъектДрайвера.СформироватьЧек>.'") + Символы.ПС + ОписаниеОшибки());
            КонецПопытки;
        КонецЕсли;
   jobkostya1c
 
8 - 19.08.19 - 14:39
Выполняется строчка вот эта:

ИначеЕсли ПараметрыФискализации.РевизияИнтерфейса > 2001 Тогд// Версия стандарта 2.2 (ОФД 1.0.5)


                    Результат = ОбъектДрайвера.СформироватьЧек(ПараметрыПодключения.ИДУстройства, ПараметрыФискализации.Электронно, 
                        ПараметрыФискализации.ДанныеЧекаXML, ПараметрыФискализации.НомерЧекаККТ, ПараметрыФискализации.НомерСменыККТ, ПараметрыФискализации.ФискальныйПризнак, ПараметрыФискализации.АдресСайтаПроверки);
   jobkostya1c
 
9 - 19.08.19 - 14:39
Ссылка на последний раздел ИТС 2.5 https://its.1c.ru/db/metod8dev#content:5965:hdoc
   Звездец
 
10 - 20.08.19 - 00:05
чек коррекции необходимо потом предоставить в ФНС с пояснением причины коррекции. Что предоставлять будешь?

еще раз. действия неправильны и являются нарушением. Не может быть 1000 чеков коррекции в день. даже если не пробили 1000 чеков, то и коррекцию можно сделать одну
   isa2net
 
11 - 20.08.19 - 07:28
   Сияющий в темноте
 
12 - 20.08.19 - 08:19
не знаю как Атол,а у штрих м есть выключение печати,которое работаеи вне зависимости от того,есть в чеке какой то тег или нет,и даже на отчеты без гашения,которые в фн вообще не попадают.

насколько я помню,чек коррекции пробивается или по предписанию или к нему должно прилагаться заявление о причинах пробития чека коррекции-вы и автоматизацию заполнения заявлений будете делать?

опять же,хотя в чеке коррекции есть дата документа,в системе он ложится по датк его формирования,и никак в прошлый месяц не попадет.
   isa2net
 
13 - 20.08.19 - 12:32
Согласно описанию отсюда https://integration.atol.ru/api/#32139c76c1 : "Чтобы чек не печатался (электронный чек), нужно установить параметру LIBFPTR_PARAM_RECEIPT_ELECTRONICALLY значение true и передать реквизит 1008 (электронный адрес или телефон получателя)."- добжно пройти
Попробуйте передать "электронно" в чек коррекции с тегом 1008.

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.