Вход | Регистрация
 

Розница. Обновление РИБ

Розница. Обновление РИБ
Я
   Ychenik1c
 
16.08.19 - 05:12
Здравствуйте. Обновляю базу с релиз 2.2.6. Последовательно. При обновлении центральной базы на 2.2.12 всё проходит без ошибок. А при обновление периферийной на 94%  ошибка. Вот что в журнале регистрации.
Вот что есть в журнале регистраций. Может кто сталкивался. В интернете про эту ошибку нашел, но ока безрезультатно.

Обмен данными.Проведение документа "Ввод начальных остатков узла"
Ошибка чтения файла сообщения обмена: {Обработка.КонвертацияОбъектовРаспределенныхИнформационныхБаз.МодульОбъекта(219)}: Ошибка при вызове метода контекста (ЗакончитьЧтение): Ошибка при выполнении обработчика - 'ПередЗаписью': {ПланОбмена.ПоМагазину.МодульОбъекта(113)}: Ошибка при вызове метода контекста (Следующий): В данной транзакции уже происходили ошибки!
Обмен данными.ПоМагазину.Получение данных. Сообщение обмена удалено из кэша.
{ОбщийМодуль.ОбменДаннымиСервер.Модуль(12929)}: Получение данных из главного узла завершилось с ошибками.
                    ВызватьИсключение НСтр("ru = 'Получение данных из главного узла завершилось с ошибками.'");
 
 
   Ychenik1c
 
1 - 16.08.19 - 05:21
Как я понимаю он удаляет файл обмена, а потом не может его найти
   Галахад
 
2 - 16.08.19 - 05:41
Гм. Наверное проблема в "В данной транзакции уже происходили ошибки!".
   Ychenik1c
 
3 - 16.08.19 - 05:58
ВыборкаДокументов = Документы.ВводНачальныхОстатковУзла.Выбрать(,, Новый Структура("КодУзлаОбмена", ПредопределенныйУзел.Код), "Дата");
            Пока ВыборкаДокументов.Следующий() Цикл
                ДокументВыборки = ВыборкаДокументов.ПолучитьОбъект();
                Если ДокументВыборки <> Неопределено
                    И НЕ ДокументВыборки.ПометкаУдаления
                    И НЕ ДокументВыборки.Проведен Тогда
                    ДокументВыборки.Узел = Ссылка;
                    Если НЕ ОбменДаннымиПереопределяемый.ЗаписатьВводОстатков(ДокументВыборки, РежимЗаписиДокумента.Проведение) Тогда
                        Отказ = Истина;
                    КонецЕсли;
                КонецЕсли;
            КонецЦикла;


Видел я этот код. Что до обновления, что после он не поменялся.
Только ещё посмотреть проблему в данных после обновления
   Ychenik1c
 
4 - 16.08.19 - 07:24
В РИБе отладчик не работает?
   Ychenik1c
 
5 - 16.08.19 - 07:35
Мне вот это ещё не нравится. Я один в базе
Ошибка разделенного доступа к базе данных
База данных заблокирована:
компьютер: DESKTOP-SLD2QNG, пользователь: Отладка, сеанс: 242, начат: 16.08.2019 в 11:32:03, приложение: Тонкий клиент
   Pro1001C
 
6 - 16.08.19 - 08:35
Обновляете РИБ в пользовательском режиме или после после загрузки обновления через конфигуратор? У меня еще не разу нормально в пользовательском режиме не обновилась база РИБ, все время какие-то ошибки, только через конфигуратор
Второй способ, попробуйте пока отменить документы по вводу остатков, потом перепроведете
   assasu
 
7 - 16.08.19 - 08:46
(0) не обновляйте через предприятие, только через конфигуратор .

перед отправкой в узел надо убить регистрацию с "ввод начальных остатков..". работаете же не первый день? все должно быть уже введено
   Ychenik1c
 
8 - 16.08.19 - 08:54
(7) В регистрации нет документов Ввода остатков
Ошибка возникает уже при обновлении в режиме предприятия на 94%
   Ychenik1c
 
9 - 16.08.19 - 13:32
Базу отвязал.
Обновилась без проблем.
А потом не могу вновь ей указать главный узел.
Его нет
https://i87.fastpic.ru/big/2019/0816/f6/7e5b1809719e671028a695284f68f6f6.jpg
   Ychenik1c
 
10 - 17.08.19 - 04:49
РИБ обновился.
Пришлось закомментировать код в модуле объекта плана обмена по магазину
ВыборкаДокументов = Документы.ВводНачальныхОстатковУзла.Выбрать(,, Новый Структура("КодУзлаОбмена", ПредопределенныйУзел.Код), "Дата"); 
Пока ВыборкаДокументов.Следующий() Цикл 
ДокументВыборки = ВыборкаДокументов.ПолучитьОбъект(); 
Если ДокументВыборки <> Неопределено 
И НЕ ДокументВыборки.ПометкаУдаления 
И НЕ ДокументВыборки.Проведен Тогда 
ДокументВыборки.Узел = Ссылка; 
Если НЕ ОбменДаннымиПереопределяемый.ЗаписатьВводОстатков(ДокументВыборки, РежимЗаписиДокумента.Проведение) Тогда 
Отказ = Истина; 
КонецЕсли; 
КонецЕсли; 
КонецЦикла;
   Ychenik1c
 
11 - 17.08.19 - 05:05
Есть одна проблема которую не учёл при обновление. Есть свой регистр накопления. По нему делают движение два документа. Эти движения теперь не попадают в регистрацию для обмена. Где можно посмотреть? До обновления база есть я там не нашел. В плане обмена по магазину в макете правила регистрации его нет.
   МимохожийОднако
 
12 - 17.08.19 - 07:06
(11) Обычно переносят документы, а не движения
   Pro1001C
 
13 - 17.08.19 - 09:52
(11) насколько помню через подписку работает регистрация объектов в Рознице
   Ychenik1c
 
14 - 17.08.19 - 11:07
Где можно регистрировать данные для отправки у меня пропал этот регистр из списка
   Pro1001C
 
15 - 17.08.19 - 12:23
в составе подписки по регистрам
   Ychenik1c
 
16 - 17.08.19 - 12:23
(13) Спасибо. В одной из подписок галочки не было

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.