Вход | Регистрация
 
1С:Предприятие :: 1С:Предприятие 8 общая

Табличная часть на управляемой форме

Табличная часть на управляемой форме
Я
   I_learn_1c
 
14.08.19 - 18:08
Доброго вечера

Помогите пожалуйста, запуталась в конец уже.. управляемые формы, 8.3.12

Есть документ1 с реквизитом заказчик и другими, есть документ2 с реквизитом заказчик и табличной частью. В табличной части должен быть список документов1, колонки повторяют реквизиты.

Но на форме у тч в командной панели есть кнопка "добавить", она добавляет просто строку. Мне же нужно чтобы по кнопке "добавить" открывалась форма выбора документа 1 с отбором по заказчику (только определенные документы 1), и после выбора данными выбранного лота заполнилась строка.

Как изменить обработчик кнопки Добавить?

Пробовала стандартную не использовать, добавила свою, по кнопке открывается выбор, выбираю и в ОбработкаВыбора пыталась добавить строку в тч и заполнить, но не вышло. ВыбранноеЗначение=ДокументСсылка и по ней данные не вытащить, новая строка типа ДанныеФормыЭлементКоллекции на сервер не передать. если на сервере добавляю строку в тч заполняю из ВыбранноеЗначение.ПолучитьОбъект() - не выводится новая строка на форме..

Может есть у кого пример какой? или ссылка где почитать посмотреть? торможу где то...
 
 
   I_learn_1c
 
1 - 15.08.19 - 09:04
(0) ау...
   Дмитрий
 
2 - 15.08.19 - 09:09
Откройте для себя Подбор
   НадюшаЯ
 
3 - 15.08.19 - 09:15
НоваяСтрока = Объект.ТвояТЧ.Добавить()
   Uzyf
 
4 - 15.08.19 - 09:49
&НаКлиенте
Процедура Добавить(Команда)
    ПараметрыФормы = Новый Структура("ЗакрыватьПриВыборе, МножественныйВыбор", Истина, Истина);
    ОткрытьФорму("Справочник.КлючиРеестраДокументов.ФормаВыбора", ПараметрыФормы, Элементы.МояТаблицаФормы);
КонецПроцедуры

&НаКлиенте                
Процедура МояТаблицаФормыОбработкаВыбора(Элемент, ВыбранноеЗначение, СтандартнаяОбработка)
    Для Каждого ВыбранныйЭлемент Из ВыбранноеЗначение Цикл
        НоваяСтрока = МояТаблицаФормы.Добавить();
        НоваяСтрока.МойРеквизитТаблицы = ВыбранныйЭлемент;
    КонецЦикла;
КонецПроцедуры

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.