Вход | Регистрация
 

Корректировка поступления КА 2.4

Корректировка поступления КА 2.4
Я
   НадюшаЯ
 
14.08.19 - 11:35
Было поступления в 2018 году, доставка проводки 44.01.1 - 60.01 В документе ставка ндс 0%. В этом году выяснилось что нужно 18%.
Делаю корректировку - проводки
19.04 - 60.01 на сумму ндс
44.01.1 - 60.01 на минусовую сумму НДС
А хотелось бы видеть проводку
60.01 - 91.01
Как можно такое сделать?
 
 
   НадюшаЯ
 
1 - 14.08.19 - 11:38
Поступление услуг было
   Cyberhawk
 
2 - 14.08.19 - 11:39
Ну так на 44 ведь упало больше в 2018, чем должно было, вот от него и отнимается
   piter3
 
3 - 14.08.19 - 11:40
Эээ а откуда 60.01 - 91.01?
   Cyberhawk
 
4 - 14.08.19 - 11:41
Ну и взаиморасчеты не меняются из-за корректировки, сумма документа-то не изменилась же?
   НадюшаЯ
 
5 - 14.08.19 - 11:41
(4) не сумма документа не изменилась
   НадюшаЯ
 
6 - 14.08.19 - 11:44
(3) в пользу этой проводки бухгалтерия) и КА 1.1, там прямо в коде эта проводка зашита.
   НадюшаЯ
 
7 - 14.08.19 - 12:18
Процентов на 90 уверена что счета подбираются из-за Поля вариант отражения, где стоит Увеличить стоимость и уменьшить стоимость, которое изменить я не могу. А момент его заполнения в плане услуг выглядит вот так

Функция ВариантОтраженияПоСтроке(СтрокаРасхождений, ТипНоменклатуры, КорректировкаПрошлогоПериода, ИспользуетсяДокументПоступлениеТоваров)
    
    ВариантОтражения = Неопределено;
    
    Если (ТипНоменклатуры <> Перечисления.ТипыНоменклатуры.Товар
        И ТипНоменклатуры <> Перечисления.ТипыНоменклатуры.МногооборотнаяТара)
        Или СтрокаРасхождений.КоличествоУпаковок = 0 Тогда
        
        Если (СтрокаРасхождений.СуммаСНДС < 0 ИЛИ СтрокаРасхождений.СуммаСНДС - СтрокаРасхождений.СуммаНДС < 0)
            И Не ИспользуетсяДокументПоступлениеТоваров Тогда
            ВариантОтражения = Перечисления.ВариантыОтраженияКорректировокПоступлений.УменьшитьСтоимостьТовара;
        ИначеЕсли Не ИспользуетсяДокументПоступлениеТоваров Тогда
            ВариантОтражения = Перечисления.ВариантыОтраженияКорректировокПоступлений.УвеличитьСтоимостьТовара;
        КонецЕсли;
        
    КонецЕсли;
    
    Возврат ВариантОтражения;
    
КонецФункции

Для товара как то можно изменять, для услуги похоже глухо.

Запущу чудо обработку по отражению доков, может с помощью нее получится что то выяснить из того что поможет.
   piter3
 
8 - 14.08.19 - 12:22
(6) По моему это у вас такое)Не помню точно
   НадюшаЯ
 
9 - 14.08.19 - 12:27
(8) не поняла
   piter3
 
10 - 14.08.19 - 12:28
(9) Я сильно сомневаюсь,что в ка 1.1 типовой такая проводка.Попробую найти такую базу и глянуть
   НадюшаЯ
 
11 - 14.08.19 - 12:33
(10) процедура модуля объекта корректировки поступления СформироватьПроводки()
Если СтрСуммаБУ < 0 Тогда//Доходы

                Проводка                 = ПроводкиБУ.Добавить();
                Проводка.Период         = СтруктураШапкиДокумента.Дата;
                Проводка.Организация     = СтруктураШапкиДокумента.Организация;
                Проводка.Содержание     = Содержание;
                
                Проводка.СчетКт       = ПланыСчетов.Хозрасчетный.ПрочиеДоходы;
                БухгалтерскийУчет.УстановитьСубконто(Проводка.СчетКт, Проводка.СубконтоКт, "ПрочиеДоходыИРасходы", СтруктураШапкиДокумента.СтатьяПрочихДоходовИРасходов);
                
НУ собственно, вот эта строка
Проводка.СчетКт       = ПланыСчетов.Хозрасчетный.ПрочиеДоходы;

Сейчас проверю еще раз доработки в этом документе, хотя 99 процентов что их не было
                Проводка.СчетДт = СтруктураШапкиДокумента.СчетУчетаРасчетовСКонтрагентом;
                БухгалтерскийУчет.УстановитьСубконто(Проводка.СчетДт,Проводка.СубконтоДт,"Контрагенты",        СтруктураШапкиДокумента.Контрагент, Истина, Заголовок);
                БухгалтерскийУчет.УстановитьСубконто(Проводка.СчетДт,Проводка.СубконтоДт,"Договоры",           СтруктураШапкиДокумента.ДоговорКонтрагента);
                
                Если Проводка.СчетДт.Валютный Тогда
                    Проводка.ВалютаДт        = СтруктураШапкиДокумента.ВалютаВзаиморасчетов;
                    Проводка.ВалютнаяСуммаДт = -СтрСуммаВал;
                КонецЕсли;
                
                Проводка.Сумма = -СтрСуммаБУ;
   piter3
 
12 - 14.08.19 - 12:35
Это о другом.Видимо я неправильно тебя понял
19.04 - 60.01 на сумму ндс 
44.01.1 - 60.01 на минусовую сумму НДС 
вместо этого 
60.01 - 91.01
   НадюшаЯ
 
13 - 14.08.19 - 12:37
(12) ну т.е в КА 1.1 счета выглядят так
19.04 - 60.01 на сумму НДС
60.01 - 91.01 на сумму НДС
   Cyberhawk
 
14 - 14.08.19 - 12:46
(13) А 44 тоже в КА есть?
   НадюшаЯ
 
15 - 14.08.19 - 12:56
(14) да поступление такое же
   НадюшаЯ
 
16 - 14.08.19 - 12:56
(14) Ну вернее проводки по поступлению
   Cyberhawk
 
17 - 14.08.19 - 13:06
Хм. Тогда что насчет (2) в КА 1.1?
При поступлении услуги на 44 падает сумма же за вычетом НДС (если НДС в документе поступления есть)?
   НадюшаЯ
 
18 - 14.08.19 - 14:04
(17) а ставка ндс в поступлении 0, затем корректировкой меняем на 18
   НадюшаЯ
 
19 - 14.08.19 - 14:06
Анализ запроса, чудо обработки, просигналил о невозможности данной проводки в принципе
Вот так определяется тип счета ДТ 
ВЫБОР
    КОГДА Строки.ВариантОтражения = ЗНАЧЕНИЕ(Перечисление.ВариантыОтраженияКорректировокПоступлений.СписатьНаРасходы)
            И Операция.СтатьяРасходов ССЫЛКА ПланВидовХарактеристик.СтатьиРасходов
        ТОГДА ЗНАЧЕНИЕ(Перечисление.ВидыСчетовРеглУчета.Расходы)
    КОГДА Строки.ВариантОтражения = ЗНАЧЕНИЕ(Перечисление.ВариантыОтраженияКорректировокПоступлений.СписатьНаРасходы)
                И Операция.СтатьяРасходов ССЫЛКА ПланВидовХарактеристик.СтатьиАктивовПассивов
            ИЛИ Строки.ВариантОтражения = ЗНАЧЕНИЕ(Перечисление.ВариантыОтраженияКорректировокПоступлений.ОтразитьНаПрочихДоходах)
                И Операция.СтатьяДоходов ССЫЛКА ПланВидовХарактеристик.СтатьиАктивовПассивов
        ТОГДА ЗНАЧЕНИЕ(Перечисление.ВидыСчетовРеглУчета.ПрочиеАктивыПассивы)
    КОГДА Строки.ВариантОтражения = ЗНАЧЕНИЕ(Перечисление.ВариантыОтраженияКорректировокПоступлений.ОтразитьНаПрочихДоходах)
            И Операция.СтатьяДоходов ССЫЛКА ПланВидовХарактеристик.СтатьиДоходов
        ТОГДА ЗНАЧЕНИЕ(Перечисление.ВидыСчетовРеглУчета.Доходы)
    КОГДА Строки.СтатьяРасходов = ЗНАЧЕНИЕ(ПланВидовХарактеристик.СтатьиРасходов.ПустаяСсылка)
        ТОГДА ЗНАЧЕНИЕ(Перечисление.ВидыСчетовРеглУчета.Производство)
    ИНАЧЕ ЗНАЧЕНИЕ(Перечисление.ВидыСчетовРеглУчета.Расходы)
КОНЕЦ

А т.к у нас варинаты увеличить или уменьшить стоимость то всегда как я поняла будет Расходы
   НадюшаЯ
 
20 - 14.08.19 - 14:26
В БП 3.0 отрабатывает также как в КА 1.1
   piter3
 
21 - 14.08.19 - 14:28
А итс чего говорит?
   НадюшаЯ
 
22 - 14.08.19 - 14:36
(21) Нужной инфы не нашла, только общее описание.
   piter3
 
23 - 14.08.19 - 14:37
(22) не может быть,ксф расписано.По бп точно
   piter3
 
24 - 14.08.19 - 14:37
тим?
   НадюшаЯ
 
25 - 14.08.19 - 14:39
(23) что вы имеете ввиду по БП, по бух учету? или по конфе? Если в конфе то в (20) уже проверила в БП 3.0 все как надо.
   piter3
 
26 - 14.08.19 - 14:44
(25) конфу
   piter3
 
27 - 14.08.19 - 14:44
давайте подключусь удаленно
   НадюшаЯ
 
28 - 14.08.19 - 14:48
(27) К сожалению нет такой возможности
   piter3
 
29 - 14.08.19 - 14:49
(28) тогда не пойму есть вообще такой код у тебя?И точно не правленный кусок?
   НадюшаЯ
 
30 - 14.08.19 - 14:53
(29) Какой именно код? Так как я описала делала уже в трех база
КА 1.1 и БП 3.0 - типовые
19.04 - 60.01 на сумму НДС
60.01 - 91.01 на сумму НДС

КА 2.4 - типовая 
19.04 - 60.01 на сумму ндс 
44.01.1 - 60.01 на минусовую сумму НДС 

Доработок нет, это так отрабатывают типовые механизмы, можно на любой демке собрать поступление услуги и корректировку, результаты будут теже. Например БП 3 было демо версии с сайта ИТС
 
 Рекламное место пустует
   piter3
 
31 - 14.08.19 - 14:54
(30) А 44 откуда берется?Жестко или же
   НадюшаЯ
 
32 - 14.08.19 - 14:56
(31) 44 берется из статьи расходов, 91, там не указать
   piter3
 
33 - 14.08.19 - 14:57
(32) Почему?Я не о Перечисление.ВидыСчетовРеглУчета.Расходы.
   НадюшаЯ
 
34 - 14.08.19 - 15:04
(33) ну стоит встроенный отбор, я конечно могу разобраться почему стоит именно такой отбор, только смысл. Ведь при поступлении счета указываются нужные счета и берутся они оттуда же
   piter3
 
35 - 14.08.19 - 15:12
Надо смотреть,так не могу понять.
   НадюшаЯ
 
36 - 14.08.19 - 15:16
не нашла к сожалению ссылки для вас на дему базу в инете, можно с Юзерс скачать демо и попробовать на ней, все будет идентично тому что я описала.
   piter3
 
37 - 14.08.19 - 15:21
Да толку от демо.Надо проблемную смотреть.ну не верю я в такую проводку 60.01 - 91.01
   НадюшаЯ
 
38 - 14.08.19 - 15:26
(37) Если есть интерес можете здесь сделать поступление услуги и корректировку поступления и увидете ее
http://v8.1c.ru/buhv8/demo/
   НадюшаЯ
 
39 - 14.08.19 - 15:27
да даже наверно она сохранилась корректировка которую я делала
   piter3
 
40 - 14.08.19 - 15:31
(39) Тааакк,а с чего у тебя в КА появилась вообще запись 
44.01.1 - 60.01 на минусовую сумму НДС
У тебя же тока ндс поменялся.И как было указано ранее с чего бы это
   piter3
 
41 - 14.08.19 - 15:33
Может скрины дашь дока и проводок,я так лучше понимаю
   НадюшаЯ
 
42 - 14.08.19 - 15:35
(40) ну как я поняла, сумма ндс пошла на 19.04, и ее минусуют с 44.01
   piter3
 
43 - 14.08.19 - 15:39
А релиз какой?
   НадюшаЯ
 
44 - 14.08.19 - 15:40
2.4.8.84
   НадюшаЯ
 
45 - 14.08.19 - 15:43
если насильно поменять вариант отражения "Отразить на доходах/пассивах" то делает проводки 
19.04 - 60.01 на сумму ндс 
91.01 - 60.01 на минусовую сумму НДС 
Это ведь равно 60.01 - 91.01 на сумму НДС?
   piter3
 
46 - 14.08.19 - 15:44
А какая сф какая исправительная или корректировочная?
   НадюшаЯ
 
47 - 14.08.19 - 15:47
(46) не могу сказать, наверно исправительная, а причем тут СФ? все проводки делаются в рамках документа корректировки и там же указывается куда разницу нужно отражать
   НадюшаЯ
 
48 - 14.08.19 - 15:47
(46) если только оформлять другим документов все это
   piter3
 
49 - 14.08.19 - 15:48
(47) Давайте сначала какая узнаем,потом доки будем мучать
   НадюшаЯ
 
50 - 14.08.19 - 15:51
(49) а давайте оба варианта рассмотрим
   piter3
 
51 - 14.08.19 - 15:53
(50) Неттттттттттт
   piter3
 
52 - 14.08.19 - 15:53
там вообще может быть 3 варианта
   НадюшаЯ
 
53 - 14.08.19 - 15:57
(52) меня интересует вариант, в результате которого получатся данные проводки и набор документов, с помощью которых мы сможем их получить
   piter3
 
54 - 14.08.19 - 16:02
(53) Если судить по этому http://catalog.mista.ru/public/832909/
то ручками только.
   НадюшаЯ
 
55 - 14.08.19 - 16:05
(54) читала ее, блин создала тему раньше чем в 1с написала) нехорошо
   piter3
 
56 - 14.08.19 - 16:06
(55) проще допилить,не?
   НадюшаЯ
 
57 - 14.08.19 - 16:08
(56) да теперешние конфы хрен допилишь по нормальному, два миллиона условий и столько же различных модулей и функций.
Это еще я представляю как должны пойти проводки благодаря старым базам и БП 3.0, ну может как то получится определить ситуацию в которой, нужно новые проводки делать, а как быть с остальными регистрами их там тоже не мало...
   Cyberhawk
 
58 - 14.08.19 - 18:17
(18) Я про ставку 0 ничего не спрашивал
   НадюшаЯ
 
59 - 14.08.19 - 21:40
(58) так, а что тогда нужно рассказать?
   palsergeich
 
60 - 14.08.19 - 21:43
(57)
Вот то что модификация стала сложнее согласен.
   palsergeich
 
61 - 14.08.19 - 21:51
И вроде бы убрали дублирование кода и поместили все в одно место, но, если раньше было дублирование кода, то сейчас система флажков и хитрых входных параметров.
ЕстьПризнакПоступления    = ТаблицаИсточник.Колонки.Найти("ПоступилВПериоде") <> Неопределено;
ЕстьСписатьИсточник       = ТаблицаИсточник.Колонки.Найти("СписатьИсточник") <> Неопределено;
ЕстьИсточникКоличество    = ТаблицаИсточник.Колонки.Найти("ИсточникКоличество") <> Неопределено;
ЕстьИсточникСостояние     = ТаблицаИсточник.Колонки.Найти("ИсточникСостояние") <> Неопределено;
ЕстьДатаПартии            = ТаблицаИсточник.Колонки.Найти("ДатаПартии") <> Неопределено;
ЕстьИсточникДатаПартии    = ТаблицаИсточник.Колонки.Найти("ИсточникДатаПартии") <> Неопределено;
ЕстьДатаПараметровРасчета = ТаблицаИсточник.Колонки.Найти("ДатаРасчетаАмортизации") <> Неопределено;
Вот флажки
И по коду на системе флажков делаются проводки. ИМХО стало ничуть не легче
   Cyberhawk
 
62 - 15.08.19 - 09:15
(59) Обычное поступление услуги с НДС в КА 1.1 какую сумму на 44 кладет - с НДС или без?
   НадюшаЯ
 
63 - 15.08.19 - 09:20
(62) на 44 кладет сумму без НДС, сумма ндс идет на 19.04
   Cyberhawk
 
64 - 15.08.19 - 09:22
(63) Ну вот и получается, что если в первичном документе НДС 0, а правильно должно быть 20, то значит по ошибке на 44 упало больше, чем долждно было.
Почему тогда оно не должно откорректироваться?
   НадюшаЯ
 
65 - 15.08.19 - 09:30
(64) Понятия не имею, если честно, могу только предполагать. Вероятнее всего это связано с другим периодом. Как я понимаю 44 счет закрылся на 91 и корректировать нужно его, но это только догадки.
   НадюшаЯ
 
66 - 15.08.19 - 09:32
(65) или же даже не так. Т.е 44 - затраты которые были распределены на себестоимость или еще куда то. Затем выясняется, что себестоимость должна быть ниже, т.к вычитается сумма НДС и организация получает прочий доход.
 
 Рекламное место пустует
   Cyberhawk
 
67 - 15.08.19 - 09:42
Ну вот вроде как 60 будет меняться только если сумма (цены) изменились. А тут раз сумма общая не поменялась, а поменялось только доля НДС, поэтому 60 либо вообще не должен трогаться, либо должен схлопываться (от пары проводок), т.е. остаток не меняться.
Другое дело, какая пара проводок должна быть - это скорее всего от того, в одном или в разных периодах, зависит, это да.
В интернетах пишут, что ребятки из 1С особо не стали заморачиваться и предоставили выбор, как там пользователю самому виднее, отражать.
Вот в бухии так:
https://buhexpert8.ru/wp-content/uploads/2018/12/image002-45.png
   НадюшаЯ
 
68 - 15.08.19 - 09:54
(67) В БП 3.0 нужный набор проводок получается, в КА 2.4, никак не получается, может попробовать еще месяца позакрывать и с этим поиграться.


Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.