Вход | Регистрация
 

Нужна помощь с сохранением данных.

Нужна помощь с сохранением данных.
Я
   Hazeee
 
12.08.19 - 22:55
В общем, есть список значений СписокEMail. Как сделать еще такой же список, например СписокEMail2, и чтобы эти данные сохранялись. Сохраняются только СписокEMail, как только не пробовал.

Функция ПрочитатьНастройки() Экспорт
    
    ЕстьНастройки = Ложь;
    
    ИмяНастройки = "ВыгрузкаПродТранс_Настройки";
    
    СтруктураНастройки = Новый Структура;
    СтруктураНастройки.Вставить("ИмяОбъекта", ИмяНастройки);
    СтруктураНастройки.Вставить("Пользователь",  Справочники.ГруппыПользователей.ВсеПользователи);
    СтруктураНастройки.Вставить("НаименованиеНастройки", "Основная");
    
    
    Если УниверсальныеМеханизмы.ПолучитьНастройку(СтруктураНастройки) Тогда
        
        ЕстьНастройки = Истина;
        
        ТекущаяНастройка = СтруктураНастройки.СохраненнаяНастройка;
        ТекущаяНастройка.Свойство("СписокEMail", СписокEMail);    
        
        
    КонецЕсли;

    Возврат ЕстьНастройки;
    
КонецФункции

Процедура ЗаписатьНастройки() Экспорт
    
    ИмяНастройки = "ВыгрузкаПродТранс_Настройки";
    
    СтруктураНастройки = Новый Структура;
    СтруктураНастройки.Вставить("ИмяОбъекта", ИмяНастройки);
    СтруктураНастройки.Вставить("Пользователь", Справочники.ГруппыПользователей.ВсеПользователи);
    СтруктураНастройки.Вставить("НаименованиеНастройки", "Основная");
    
    ТекущаяНастройка = СформироватьСтруктуруДляСохраненияНастроек("СписокEMail",СписокEMail);


    
    СтруктураНастройки.Вставить("СохраненнаяНастройка", ТекущаяНастройка);
    
    УниверсальныеМеханизмы.СохранитьНастройку(СтруктураНастройки);
    
КонецПроцедуры

Функция СформироватьСтруктуруДляСохраненияНастроек(ИмяСохранения,ЧтоСохраняем)
    ТекущаяНастройка = Новый Структура;
    ТекущаяНастройка.Вставить(ИмяСохранения,ЧтоСохраняем);
    Возврат ТекущаяНастройка;
КонецФункции
 
 
   Злопчинский
 
1 - 12.08.19 - 23:51
При копировании ссылок - копируются ссылки. объекты не множатся.
   Hazeee
 
2 - 13.08.19 - 01:51
Спасибо

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.