Вход | Регистрация
 

УТ 11 ошибка в Внешней печатной форме торг 12 (ВПФ)

УТ 11 ошибка в Внешней печатной форме торг 12 (ВПФ)
Я
   lite777
 
12.08.19 - 14:58
УТ 11,4 базовая , ошибка в Внешней печатной форме торг 12 (ВПФ),
пишет метод объекта не обнаружен-ПолучитьДанныеДляПечатнойФормыТОРГ12 ,ГДе тут копать ?

Функция СформироватьПечатнуюФормуТОРГ12(СтруктураТипов, ОбъектыПечати, ПараметрыПечати, КомплектыПечати = Неопределено) Экспорт
    
    УстановитьПривилегированныйРежим(Истина);
    
    ТабличныйДокумент = Новый ТабличныйДокумент;
    ТабличныйДокумент.ПолеСлева = 5;
    ТабличныйДокумент.ПолеСправа = 5;
    ТабличныйДокумент.РазмерКолонтитулаСверху = 0;
    ТабличныйДокумент.РазмерКолонтитулаСнизу = 0;
    ТабличныйДокумент.АвтоМасштаб = Истина;
    ТабличныйДокумент.ОриентацияСтраницы = ОриентацияСтраницы.Ландшафт;
    
    ТабличныйДокумент.КлючПараметровПечати = "ПАРАМЕТРЫ_ПЕЧАТИ_ТОРГ12_2";
    
    НомерТипаДокумента = 0;
    
    Для Каждого СтруктураОбъектов Из СтруктураТипов Цикл
        
        НомерТипаДокумента = НомерТипаДокумента + 1;
        Если НомерТипаДокумента > 1 Тогда
            ТабличныйДокумент.ВывестиГоризонтальныйРазделительСтраниц();
        КонецЕсли;
        
        МенеджерОбъекта = ОбщегоНазначения.МенеджерОбъектаПоПолномуИмени(СтруктураОбъектов.Ключ);
        
    !!!!      ДанныеДляПечати = МенеджерОбъекта.ПолучитьДанныеДляПечатнойФормыТОРГ12(ПараметрыПечати, СтруктураОбъектов.Значение);

                
        
        ЗаполнитьТабличныйДокументТОРГ12(ТабличныйДокумент, ДанныеДляПечати, ОбъектыПечати, ПараметрыПечати, КомплектыПечати);
    КонецЦикла;
    Возврат ТабличныйДокумент;
    
КонецФункции
 
 
   Злопчинский
 
1 - 12.08.19 - 15:04
в модуле менеджера объекта нет процедуры/функции требуемой
как вариант - попытка подключить ВПФ к обьекту, где формирование такой формы не предусмотрено. Например Документ.ПоступлениеТМЦ - м.б. торг12 печать не предусмотрена, т.к. торг12 к напр приходит "снаружи" и торг12 уже есть, а поступление - только регистрирует данные этого документа.
   yzimin
 
2 - 12.08.19 - 15:06
Замени на

        МенеджерОбъекта = ОбщегоНазначенияУТ.ПолучитьМодульЛокализации(СтруктураОбъектов.Ключ);
        Если МенеджерОбъекта = Неопределено Тогда
            МенеджерОбъекта = ОбщегоНазначения.МенеджерОбъектаПоПолномуИмени(СтруктураОбъектов.Ключ);
        КонецЕсли;
   lite777
 
3 - 12.08.19 - 15:40
Счас попробую
   lite777
 
4 - 12.08.19 - 15:54
ЗАРАБОТАЛО ! СПАСИБО!
   lite777
 
5 - 12.08.19 - 15:58
кто бы знал что надо-
МенеджерОбъекта = ОбщегоНазначенияУТ.ПолучитьМодульЛокализации(СтруктураОбъектов.Ключ);
        Если МенеджерОбъекта = Неопределено Тогда
            МенеджерОбъекта = ОбщегоНазначения.МенеджерОбъектаПоПолномуИмени(СтруктураОбъектов.Ключ);
        КонецЕсли;

Список тем форума
Рекламное место пустует  Рекламное место пустует
Требовать и эффективности, и гибкости от одной и той же программы — все равно, что искать очаровательную и скромную жену... по-видимому, нам следует остановиться на чем-то одном из двух.
Фредерик Брукс-младший
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.