Вход | Регистрация
 
1С:Предприятие :: 1С:Предприятие 8 общая

Дополнительные реквизиты документа.

Дополнительные реквизиты документа.
Я
   JuixyJes
 
12.08.19 - 11:16
Добрый день! Мне нужно как то в доп реквизиты типового документа добавить ссылку на нетиповой справочник. может кто подсказать?
 
 
   НадюшаЯ
 
1 - 12.08.19 - 11:20
План видов характеристик - тип значения
   JuixyJes
 
2 - 12.08.19 - 11:32
(1) А по подробнее?
   yzimin
 
3 - 12.08.19 - 11:34
(2) начни с себя
   JuixyJes
 
4 - 12.08.19 - 11:34
(1) Просто они добавлены через режим предприятия
   JuixyJes
 
5 - 12.08.19 - 11:35
(4) и я еще ни разу не добавляла их ни в один документ(
   JuixyJes
 
6 - 12.08.19 - 11:36
(3) кто бы говорил)) Кроме никнейма нет ничего
   JuixyJes
 
7 - 12.08.19 - 11:38
Давайте расскажу всё ТЗ по этой теме. Нужно создать доп реквизиты у типового документа Приходный кассовый ордер, в последствии заполнить их из нетипового документа. 3 из 5 доп реквизитов - ссылка на нетиповой справочник.
   yzimin
 
8 - 12.08.19 - 11:40
в конфигураторе тип посмотреть предлагать или нет? хотя (1) уже всё сказал
   НадюшаЯ
 
9 - 12.08.19 - 11:40
(2) а куда подробнее, заходите в конфигуратор и добавляете свои нетиповые справочники в тип значение для плана видов характеристик ДополнительныеРеквизитыИСведения
   JuixyJes
 
10 - 12.08.19 - 11:46
(9) Дак там в значении стоит тип ЛюбаяСсылка, значит мои не типовые справочники тоже должны туда попадать
   НадюшаЯ
 
11 - 12.08.19 - 11:48
(10) ну так мы то не знаем где и что у вас, простите, стоит)
   JuixyJes
 
12 - 12.08.19 - 11:50
(11) это типовой ТипЗначения для планов вида характеристик ДополнительныеРеквизитыИСведения
   НадюшаЯ
 
13 - 12.08.19 - 11:52
(12) А что тогда не получается?
   JuixyJes
 
14 - 12.08.19 - 11:54
(13) Нет там многих типов ссылок
   JuixyJes
 
15 - 12.08.19 - 11:54
+(14) ощущение, что какие-то предопределенные моменты имеются, если что это УТ 11 Проф
   unregistered
 
16 - 12.08.19 - 11:56
(10) >> там в значении стоит тип ЛюбаяСсылка.

Не пи*дите! Это невозможно. Платформа пока так не умеет.
Тип значения характеристик не может быть ЛюбаяСсылка.

(12) Опять гонево! Вы куда-то явно не туда смотрите. Или не понимаете о чём пишете.
   unregistered
 
17 - 12.08.19 - 12:00
Проверьте, что всё сделано согласно инструкции:
https://its.1c.ru/db/bsp302doc#content:68:1
   JuixyJes
 
18 - 12.08.19 - 12:12
   JuixyJes
 
19 - 12.08.19 - 12:15
(16) и к тому же мне типовой механизм изменять нельзя
   НадюшаЯ
 
20 - 12.08.19 - 12:20
(18) это не то
(19) это очень плохо, т.к через расширение это вроде бы тоже не поменять, а значит добро пожаловать в дивный мир извращений.
   hhhh
 
21 - 12.08.19 - 12:31
(18) это тип у значения. А вам нужно "Состав" у плана видов характеристик
   JuixyJes
 
22 - 12.08.19 - 12:51
(21) Это в конфигураторе или же в предприятии тоже возможно?
   НадюшаЯ
 
23 - 12.08.19 - 12:52
(22) это возможно только в конфигураторе
   JuixyJes
 
24 - 12.08.19 - 12:53
(23) и это изменит типовой механизм, правильно понимаю?
   НадюшаЯ
 
25 - 12.08.19 - 12:54
(24) смотря что вы подразумеваете под "изменит типовой механизм". Нужно будет включить возможность изменения конфигурации и конкретно для данного ПВХ и поменять его состав.
   JuixyJes
 
26 - 12.08.19 - 12:58
(25) конфигурация останется на поддержке при этом, нооо, при обновлении не слетит ли то, что я наворотила?
   НадюшаЯ
 
27 - 12.08.19 - 13:00
(26) конфигурация будет на поддержке, но уже измененная, т.е при обновлении нужно будет на это обращать внимание. И да есть вероятность что при обновлении все затрется, если невнимательно обновить.
   unregistered
 
28 - 12.08.19 - 13:36
(18) Сходите что ли на курсы по платформе. Если вы не в состоянии отличить регистр сведений от плана видов характеристик.

Тип значения ресурса "Значение" регистра (то, что вы на картинке прислали) должен быть Характеристика.ДополнительныеРеквизитыИСведения. И никакой другой.
А менять вы должны тип значения характеристик в плане видов характеристик ДополнительныеРеквизитыИСведения. Вот там состав типов и надо расширять, дополнив его типами своих самописных объектов. Можно ли это делать в расширении - не знаю, не пробовал. Если нельзя, то придётся в конфигурации включать возможность изменения (если у вас уже есть самописные объекты, то он уже должен быть включен). Снимать с поддержки не нужно. При обновлении необходимо будет следить, чтобы случайно не затереть внесенные изменения.

PS Позвали бы вы специалиста, пока базу не грохнули своим творчеством.
   JuixyJes
 
29 - 12.08.19 - 14:04
(28) в ней нет данных, поэтому вольна делать то, что посчитаю нужным)
   JuixyJes
 
30 - 12.08.19 - 14:05
+(29) Исключительно тестовые.
 
 Рекламное место пустует
   НадюшаЯ
 
31 - 12.08.19 - 14:19
ну в статье с ИТС все в деталях и для дела и для обучения
   JuixyJes
 
32 - 14.08.19 - 09:26
Вроде бы всю статью вдоль и поперек перечитала. Решила что данные текстовой строкой туда занесу, но даже строковое значение не могу поместить в доп реквизиты, подскажите, что я делаю не так?


Функция ЗаписатьЗначениеДопРеквизита(Ссылка, Свойство, Значение)
    
    Попытка
        ОбъектСсылки = Ссылка.ПолучитьОбъект();
        
        ПараметрыОтбора = Новый Структура;
        ПараметрыОтбора.Вставить("Свойство",Свойство);
        Массив = ОбъектСсылки.ДополнительныеРеквизиты.НайтиСтроки(ПараметрыОтбора);
        
        Если Массив.Количество() = 0 Тогда
            НовоеСвойство = ОбъектСсылки.ДополнительныеРеквизиты.Добавить();
            НовоеСвойство.Свойство = Свойство;
            НовоеСвойство.Значение = Значение;
        Иначе
            Массив[0].Значение = Значение;
        КонецЕсли;    
        
        ОбъектСсылки.Записать();    
    Исключение
        Возврат Ложь;
    КонецПопытки
    
КонецФункции
Функция ЗаполнитьДР(Док,ДокН);
    ЗаписатьЗначениеДопРеквизита(Док,ПланыВидовХарактеристик.ДополнительныеРеквизитыИСведения.НайтиПоНаименованию("Номер проживания",истина), Строка(ДокН.НомерПроживания));
    ЗаписатьЗначениеДопРеквизита(Док,ПланыВидовХарактеристик.ДополнительныеРеквизитыИСведения.НайтиПоНаименованию("Комната проживания",истина), ДокН.КомнатаПроживания);
    ЗаписатьЗначениеДопРеквизита(Док,ПланыВидовХарактеристик.ДополнительныеРеквизитыИСведения.НайтиПоНаименованию("Койка проживания",истина), ДокН.КойкаПроживания);
КонецФункции


&НаКлиенте
Процедура НачислениеВыбор(Элемент, ВыбраннаяСтрока, Поле, СтандартнаяОбработка)
    Если Поле.Имя = "НачислениеЧек" Тогда
        СЗ = Новый СписокЗначений;
        СЗ.Добавить("Наличные");
        СЗ.Добавить("Карта");                    
        СЗ.Добавить("Банк");
        Строка=Элементы.Начисление.ТекущиеДанные;
        Ответ= Вопрос("Выберите тип оплаты",СЗ);
        Если Ответ= "Наличные" Тогда
            Док = создатьдокПКО(Строка.ФизЛицо,Строка.ДокументНачисления,Строка.Сумма);
            ЗаполнитьДР(Док,Строка.ДокументНачисления);
            ОткрытьЗначение(Док);
        ИначеЕсли Ответ = "Карта" Тогда
            Док = создатьдокЭО(Строка.ФизЛицо,Строка.ДокументНачисления,Строка.Сумма);
            ОткрытьЗначение(Док);
        ИначеЕсли Ответ = "Банк" Тогда
            СЗ.Очистить();
            СЗ.Добавить("Выгрузка");
            СЗ.Добавить("Новый");
            Ответ2 = Вопрос("Использовать выгрузку или создать новый?",СЗ);
            Если Ответ2 = "Новый" Тогда
                Док = создатьдокБДС(Строка.ФизЛицо,Строка.ДокументНачисления,Строка.Сумма);
                ОткрытьЗначение(Док);
            Иначе 
                ОткрытьФорму("Обработка.ЖурналДокументовБезналичныеПлатежи.Форма.ФормаСписка");
            КонецЕсли;
        КонецЕсли;
    КонецЕсли;    
КонецПроцедуры
   JuixyJes
 
33 - 14.08.19 - 11:27
И никто не подскажет, что я сделала не так?
   НадюшаЯ
 
34 - 14.08.19 - 11:30
а что не получается?
   JuixyJes
 
35 - 14.08.19 - 11:34
(34) Ну вроде бы я задаю значение, записываю документ, потом открываю его, а доп реквизиты пустуют, не написано в них ничего.
   НадюшаЯ
 
36 - 14.08.19 - 11:36
(35) Отсутствие проверяете путем отсутствия на форме документа? или вы можете затем просмотреть ТЧ доп реквизитов и она пустая?
   JuixyJes
 
37 - 14.08.19 - 11:46
(36) Да, отсутствием на форме. Сейчас попробую посмотреть состав ТЧ доп реквизитов
   JuixyJes
 
38 - 14.08.19 - 11:48
   НадюшаЯ
 
39 - 14.08.19 - 11:49
(38) свойство пустое
   JuixyJes
 
40 - 14.08.19 - 11:52
(39) тоесть свойство не задается моим методом, правильно понимаю?
   JuixyJes
 
41 - 14.08.19 - 11:55
ПланыВидовХарактеристик.ДополнительныеРеквизитыИСведения.НайтиПоНаименованию("Комната проживания",истина)

Вот так я задавала свойство. А доп реквизит создавала не программно а в режиме предприятия
   НадюшаЯ
 
42 - 14.08.19 - 11:57
ну значит оно называется подругому, очевидно же
   НадюшаЯ
 
43 - 14.08.19 - 11:58
да и вообще есть же поле имя, которое для разработчика, оно как раз должно и использоваться в таких случаях
   JuixyJes
 
44 - 14.08.19 - 11:58
(42) А может искать не по наименованию а по реквизиту?
   JuixyJes
 
45 - 14.08.19 - 11:59
(43) А как его использовать?
   JuixyJes
 
46 - 14.08.19 - 12:01
(43) Я знаю где оно находится, но как его использовать пока не разобралась
   НадюшаЯ
 
47 - 14.08.19 - 12:01
НайтиПоРеквизиту
   НадюшаЯ
 
48 - 14.08.19 - 12:01
ПланыВидовХарактеристик.ДополнительныеРеквизитыИСведения.НайтиПоРеквизиту("Имя", ТвоеИмя);
Мало ли
   JuixyJes
 
49 - 14.08.19 - 12:08
(48) Господи, я вас обожаю!


Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.