Вход | Регистрация
 
1С:Предприятие :: 1С:Предприятие 8 общая

ПВХ - отбор по справочнику

ПВХ - отбор по справочнику
Я
   Масянька
 
12.08.19 - 11:01
День добрый!
Внешний отчет. Задается группа номенклатуры и свойство (ПВХ).
Свойство - поле ввода.
Как сделать отбор в свойстве? Чтобы были свойства только (!!!) справочника номенклатуры.
Спасибо.
 
 
   НадюшаЯ
 
1 - 12.08.19 - 11:03
Какая конфа?
   Масянька
 
2 - 12.08.19 - 11:08
(1) УТ 10.3
   НадюшаЯ
 
3 - 12.08.19 - 11:10
ну наверно отбор по реквизиту назначениеСвойства
   Масянька
 
4 - 12.08.19 - 11:24
(3) Процедура СвойстваНоменклатурыНачалоВыбора(Элемент, СтандартнаяОбработка)

    СвойстваНоменклатуры.Отбор.НазначениеСвойства.Установить(Реквизит1);

КонецПроцедуры

Поле объекта не обнаружено (Отбор)
   МимохожийОднако
 
5 - 12.08.19 - 11:26
СвойстваНоменклатуры какого типа?
   МимохожийОднако
 
6 - 12.08.19 - 11:27
ПланВидовХарактеристикСсылка.СвойстваОбъектов
   Масянька
 
7 - 12.08.19 - 11:27
(5) ПланВидовХарактеристикСсылка.СвойстваОбъектов
   МимохожийОднако
 
8 - 12.08.19 - 11:28
Кнопка Выбора есть у реквизита?
   МимохожийОднако
 
9 - 12.08.19 - 11:30
ПараметрыВыбора в свойствах реквизита Назначение..
   Масянька
 
10 - 12.08.19 - 11:32
https://pastenow.ru/fe4185ec6f069676a8aa8c164cec9bc0
Красным - СвойстваОбъектов
Зеленым - НазначенияСвойствКатегорийОбъектов (уже от отчаяния воткнула)
   Масянька
 
11 - 12.08.19 - 11:32
(9) Пусто.
   НадюшаЯ
 
12 - 12.08.19 - 11:33
СтандартнаяОбработка = Ложь;
    ФормаВыбора = ПланыВидовХарактеристик.СвойстваОбъектов.ПолучитьФормуВыбора("ФормаВыбора");
    ФормаВыбора.ПланВидовХарактеристикСписок.Отбор.НазначениеСвойства.Значение = ПланыВидовХарактеристик.НазначенияСвойствКатегорийОбъектов.Справочник_Номенклатура;
    Реквизит1 = ФормаВыбора.ОткрытьМодально();
   МимохожийОднако
 
13 - 12.08.19 - 11:33
(11) Попробуй там выбрать
   Масянька
 
14 - 12.08.19 - 11:33
(13) Там вылазит - ПустаяСсылка.
   Масянька
 
15 - 12.08.19 - 11:35
(12) Ошибок нет, но выводит всё.
   МимохожийОднако
 
16 - 12.08.19 - 11:36
Попробуй выбрать в планах вида характеристик Назначение...вместо просто справочника
   МимохожийОднако
 
17 - 12.08.19 - 11:37
   НадюшаЯ
 
18 - 12.08.19 - 11:38
(17) это только для управляемых форм, в обычных постаринке как в (12)
   Масянька
 
19 - 12.08.19 - 11:39
(17) Ошибок нет, но выводит всё.
   Масянька
 
20 - 12.08.19 - 11:40
(18) Здесь винегрет: платформа 8.3.8.1784, УТ - 10.3.26.2
   НадюшаЯ
 
21 - 12.08.19 - 11:42
(20) без разницы каков винигрет, если форма "обычная", то только как в (12) если управляемая то можно и как в (17)
   Масянька
 
22 - 12.08.19 - 11:44
(21) Так какого банана не работает?
   НадюшаЯ
 
23 - 12.08.19 - 11:45
Читать (21) по появления просветления)
   МимохожийОднако
 
24 - 12.08.19 - 11:48
Можно попробовать при открытии формы заполнять реквизит формы списком значений, который получить запросом.
   Масянька
 
25 - 12.08.19 - 11:50
(24) Да, понятно, что можно много чего. Но почему стандарт (это же стандарт?) не работает?
   Масянька
 
26 - 12.08.19 - 11:51
(23) (12) не работает. Я же написала.
   НадюшаЯ
 
27 - 12.08.19 - 11:56
(26) Предлагаю исправить самостоятельно) подход думаю понятен. Даю наводку, не установлено одно свойство отбора, которое включает и отключает отбор)
   Масянька
 
28 - 12.08.19 - 11:58
(27) Спасибо за наводку. Но только там 2 свойства.
   НадюшаЯ
 
29 - 12.08.19 - 12:04
ФормаВыбора.ПланВидовХарактеристикСписок.Отбор.НазначениеСвойства.Использование = Истина;
   Масянька
 
30 - 12.08.19 - 12:09
(29)     ФормаВыбора.Отбор.НазначениеСвойства.Использование     = Истина;
    ФормаВыбора.Отбор.НазначениеСвойства.ВидСравнения     = ВидСравнения.Равно;
    ФормаВыбора.Отбор.НазначениеСвойства.Значение         = ПланыВидовХарактеристик.НазначенияСвойствКатегорийОбъектов.Справочник_Номенклатура;
 
 Рекламное место пустует
   bootini
 
31 - 12.08.19 - 12:13
&НаКлиенте
Процедура СписокСкладовDepartmentНачалоВыбора(Элемент, ДанныеВыбора, СтандартнаяОбработка)

    ВыбратьПВХ("Department", Элемент, ДанныеВыбора, СтандартнаяОбработка);
    
КонецПроцедуры

&НаКлиенте
Процедура ВыбратьПВХ(ЗаголовокПВХ, Элемент, ДанныеВыбора, СтандартнаяОбработка)

    СтандартнаяОбработка = Ложь;
       
    ПараметрыФормы = Новый Структура;
    ПараметрыФормы.Вставить("РежимВыбора", Истина);

    ЗначениеПВХ = ПолучитьЗначениеПВХ(ЗаголовокПВХ); 

    Если ЗначениеЗаполнено(ЗначениеПВХ) Тогда
        
        фиксНастройки = Новый НастройкиКомпоновкиДанных;
        эОтбор = фиксНастройки.Отбор.Элементы.Добавить(Тип("ЭлементОтбораКомпоновкиДанных"));
        эОтбор.ЛевоеЗначение = Новый ПолеКомпоновкиДанных("Владелец");
        эОтбор.ВидСравнения = ВидСравненияКомпоновкиДанных.Равно;
        эОтбор.ПравоеЗначение = ЗначениеПВХ;
        эОтбор.Применение = ТипПримененияОтбораКомпоновкиДанных.Элементы;
        эОтбор.Использование = Истина;
        
        ПараметрыФормы.Вставить("ФиксированныеНастройки", фиксНастройки);
        ПараметрыФормы.Вставить("Свойство", ЗначениеПВХ);
    КонецЕсли; 
    
    ПараметрыФормы.Вставить("РежимоткрытияОкна" , РежимОткрытияОкнаФормы.БлокироватьОкноВладельца);
    ОткрытьФорму("Справочник.ЗначенияСвойствОбъектов.ФормаВыбора", ПараметрыФормы, Элемент);
    

КонецПроцедуры


Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.