Вход | Регистрация
 

Не стартует автоматически сервер 1С на KDE Neon

Не стартует автоматически сервер 1С на KDE Neon
Я
   SiAl-chel
 
08.08.19 - 20:10
У меня такая проблема: сервер 1C автоматически не стартует при включении компа.
ОС - KDE neon 5.16 x86_64 Linux 5.0.0-23-generic
1С - 8.3.15.1534 x64
Запускаю 'sudo service srv1cv8 start' - ноль эффекта и вывод пустой, вывод команды 'ps aux | grep 1C' тоже пустой. Запускаю 'sudo /etc/init.d/srv1cv83 start' - сервер стартует. Символьные ссылки в подкаталогах /etc/init.d/rc_.d есть. В логах ОС где и что искать - не знаю. Что можно попробовать сделать?
 
 
   ДенисЧ
 
1 - 08.08.19 - 21:03
Удалить линух, в котором ты всё равно что я в ардуинах, поставить кошерно-трофейную винду и наслаждаться жизнью.
   SiAl-chel
 
2 - 08.08.19 - 21:07
(0) Нет.
   mrdc
 
3 - 09.08.19 - 03:42
1. Поставить в качестве ОС тот Linux, который рекомендует 1С, пусть даже и десктопную версию.
2. Пригласить спеца за деньги, который разбереться "почему не стартует".
3. Долго долго мучиться самостоятельно.

Символьные ссылки мало чем помогут, имхо. Там может быть что-то с PATH, к примеру... Не видя консоли, сложно что-то сказать. Анализ надо начинать со скрипта запуска и построчно смотреть, чего он там делает в этой твоей КДЕ Неон. Кстати, накойфиг она нужна на сервере 1С...
   arsik
 
4 - 09.08.19 - 07:06
(0) Там нет systemd?
   Йохохо
 
5 - 09.08.19 - 07:39
(4) +1, за "sudo /etc/init.d/srv1cv83 start" на винду пересаживать)
   SiAl-chel
 
6 - 09.08.19 - 08:06
(3) Это домашний комп. Нужен сервер 1С там для разработки, тестирования и обучения. Демон сам стартует, но не стартует автоматически. Пользователь usr1cv8 добавил в группу adm. Отказаться легко, и надеяться на другого - тоже легко, но как тогда приобрести новые проф.навыки?
(4) Вроде есть, но в выводах команды "service srv1cv83 start" что-то пишет про SysV.
(5) Почему? Так демон стартует, а вот "service start" - нет.
   Йохохо
 
7 - 09.08.19 - 08:12
(6) потому что при таком старте будет цгруп неуправляемая системд и сервис будет просто прибит при перезагрузке с потерей данных.
Разберись что у тебя, но сис5 нет вроде почти ни где, похоже какая то бунта, там системд должно быть
   SiAl-chel
 
8 - 09.08.19 - 08:14
(3) KDE Neon - та же Ubuntu LTS, только с быстро обновляемым KDE Plasma. А Ubuntu рекомендуема 1С. MS SQL Server и PostgeSQL от 1С встали нормально, и стартуют спокойно в автомате. Года два пробовал сервер 1С ставить на Linux Mint 18.1, который основан тоже на Ubuntu, там проблем не было с автозапуском.
Скрипт /etc/init.d/srv1cv83 сейчас выложить не смогу, вечером только. Он стандартный из deb-пакета от 1С, единственная правка - включил DEBUG режим.
   SiAl-chel
 
9 - 09.08.19 - 08:16
(7) Спасибо за инфу.
   arsik
 
10 - 09.08.19 - 08:24
(9) ну попробуй
systemctl start srv1cv83
systemctl status srv1cv83
systemctl enable srv1cv83
   SiAl-chel
 
11 - 09.08.19 - 11:51
(10) Хорошо. Попробую еще раз. Вчера тоже самое вводил, но в другой последовательности. Сначала включил, а потом запускал.
А в каких журналах Linux какие события отвечают за ошибки запуска сервисов systemd?
   arsik
 
12 - 09.08.19 - 12:25
(11) systemctl status srv1cv83 - ты все увидишь. И ошибки, почему не запустилось
   arsik
 
13 - 09.08.19 - 12:26
(11) Порядок неважен. start - запустить сервис, status - посмотреть, что с ним, enable - добавить в автозапуск
   Скиурус
 
14 - 09.08.19 - 13:58
А ключ от сервера 1С у тебя тоже в домашнем компьютере есть? А то если ставить 8.3 поломанную известной ломалкой под линуксом, там похожая реакция и происходит - демон молча завершает работу.
   SiAl-chel
 
15 - 11.09.19 - 19:51
(10) Вот такой выхлоп получился
sial@home-center:~$ sudo systemctl start srv1cv83
sial@home-center:~$ sudo systemctl status srv1cv83
● srv1cv83.service - LSB: Starts and stops the 1C:Enterprise daemons
   Loaded: loaded (/etc/init.d/srv1cv83; generated)
   Active: active (exited) since Wed 2019-09-11 21:49:41 +05; 8s ago
     Docs: man:systemd-sysv-generator(8)
  Process: 21798 ExecStop=/etc/init.d/srv1cv83 stop (code=exited, status=0/SUCCESS)
  Process: 21837 ExecStart=/etc/init.d/srv1cv83 start (code=exited, status=0/SUCCESS)

сен 11 21:49:36 home-center systemd[1]: Starting LSB: Starts and stops the 1C:Enterprise daemons...
сен 11 21:49:36 home-center su[21850]: Successful su for usr1cv8 by root
сен 11 21:49:36 home-center su[21850]: + ??? root:usr1cv8
сен 11 21:49:36 home-center su[21850]: pam_unix(su:session): session opened for user usr1cv8 by (uid=0)
сен 11 21:49:36 home-center su[21850]: pam_unix(su:session): session closed for user usr1cv8
сен 11 21:49:41 home-center srv1cv83[21837]: Starting 1C:Enterprise 8.3 server:   Error: service failed
сен 11 21:49:41 home-center srv1cv83[21837]: FAILED
сен 11 21:49:41 home-center systemd[1]: Started LSB: Starts and stops the 1C:Enterprise daemons.
sial@home-center:~$ sudo systemctl enable srv1cv83
srv1cv83.service is not a native service, redirecting to systemd-sysv-install.
Executing: /lib/systemd/systemd-sysv-install enable srv1cv83
   SiAl-chel
 
16 - 11.09.19 - 19:52
(14) Стоит ключ от какой-то основной поставки, драйвер hasp стоит и работает, проблем с запуском файловой 1С - нет.
   SiAl-chel
 
17 - 11.09.19 - 19:57
Установил в виртуалку Linux Mint 19.2, установил также 1С вместе с сервером, hasp не прокидывал, драйвер на него не ставил. Сервис srv1cv8 стартует нормально, без сообщения:
"Starting 1C:Enterprise 8.3 server:   Error: service failed"
То есть проблема не в юните сервера 1С, но вот в чем конкретно - у меня тямы не хватает. Ведь скрипт /etc/init.d/srv1cv83  отрабатывает нормально.
   Фрэнки
 
18 - 11.09.19 - 22:55
(17) А я все ждал, когда же ты потратишь полчаса времени, чтоб воспроизвести сервак в виртуальной машине.

Но ключ от основной поставки это же не ключ сервера.
Кстати, а такая хрень, что сервер 1С криво стартует, если там сидит клиентский ключ - что-то такое припоминается, что давно-давно где-то об этом в кулуарах говорилось... А сервак в линукс однозначно лучше спрятать в отдельную свою виртуалку если есть условие, что это экспериментально-тестовая установка, скажем так.
   SiAl-chel
 
19 - 12.09.19 - 11:34
(18) А чего ждать то? Я сразу попробовал, только на сайт попасть времени не было.
Попробую старт без USB ключа, хотя ключ нужен для старта файловых баз. Ппредполагаю, что делом не в хаспе. Скрипт из дистрибутива 1С то отрабатывает нормально, проблема с юнитом системд. Вот тут у меня проблема. Дистрибутив менять или виртуалку использовать - не хотелось бы, есть на то причины.
   SiAl-chel
 
20 - 14.09.19 - 07:43
Ап
   ssh2006
 
21 - 14.09.19 - 11:20
проверь права usr1cv8 на каталог куда 1с установилась
   ssh2006
 
22 - 14.09.19 - 11:22
в (10) все верно написали
   SiAl-chel
 
23 - 14.09.19 - 19:24
(21) Проверил. В какой инструкции написано для каких каталогов и каких файлов какие должны быть права?
(22) Сделал, вывод этих команд написал выше. Дальше то что? Это же было сразу использовано, еще до написания темы на форуме.
   ssh2006
 
24 - 14.09.19 - 21:37
   ssh2006
 
25 - 14.09.19 - 21:37
   ShAV
 
26 - 15.09.19 - 00:22
(0) Попробуй добавить в начало файла /etc/init.d/srv1cv83 строку:
#!/bin/bash
и перезагрузись
   SiAl-chel
 
27 - 16.09.19 - 07:30
(26) Она есть там. Эта ошибка была в дистрибутивах в RPM-пакетах, а у меня используется apt и DEB-пакеты.
(24) Читал. Делал все также как и в инструкции, только установку делал с помощью dpkg, а не - gdebi. Попробую конечно все снести, и заново поставить по инструкции, но чую, что не в этом дело.
   ssh2006
 
28 - 16.09.19 - 16:43
(23) на /opt/1C проверь права , поставь usr1cv8 владельцем
   SiAl-chel
 
29 - 18.09.19 - 07:39
(28) Сразу же. Скрипт то /etc/init.d/srv1cv8 под usr1cv8 отрабатывает ведь нормально.
   ssh2006
 
30 - 18.09.19 - 14:56
(29) сам себя пингует по имени?
если нет то добавить в /etc/hosts
запись 127.0.1.1 имя
 
 Рекламное место пустует
   SiAl-chel
 
31 - 23.09.19 - 12:58
(30) Пингует с самой установки. Запись в хостс есть.
   SiAl-chel
 
32 - 02.10.19 - 07:35
Всем спасибо. Тема закрыта. Ушел на Kubuntu LTS, нет времени больше разбиратсья с этой проблемой.


Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.