Вход | Регистрация
 

рушится приложение 1С при звонке

рушится приложение 1С при звонке
Я
   Pandoch
 
08.08.19 - 17:17
Здравствуйте. до обновления андроида вызовы проходили корректно из мобильного приложения. Сейчас на моей телефоне (а также телефоне другой марки у коллеги)  просто вываливается с ошибкой приложение (хотя вызов сам  в итоге телефон осуществляет..)
Вот стандартный вызов звонка:

#Если МобильноеПриложениеКлиент Тогда
        Если СредстваТелефонии.ПоддерживаетсяНаборНомера() Тогда
            СтруктураЗвонка.Номер = Номер;
            СредстваТелефонии.НабратьНомер(Номер, ВызватьСразу);
            
            
            Если СредстваТелефонии.ПоддерживаетсяОбработкаЗвонков() Тогда
                ПодпискаНаЗвонки = Новый ОписаниеОповещения("ОбработчикЗвонков", СтруктураЗвонка.Форма, Новый Структура("IDЗадачи", IDЗадачи));
                СредстваТелефонии.ПодключитьОбработчикЗвонков(ПодпискаНаЗвонки);
            КонецЕсли;
        КонецЕсли;    
    #КонецЕсли


ОШибка гигантская. Приведу часть текста:

java.lang.SecurityException: Permission Denial: opening provider com.android.providers.contacts.CallLogProvider from ProcessRecord{2807ce8d0 20685:storverk.CRM.mobile/u0a319} (pid=20685, uid=10319) requires android.permission.READ_CALL_LOG or android.permission.WRITE_CALL_LOG
at android.os.Parcel.createException(Parcel.java:1966)
at android.os.Parcel.readException(Parcel.java:1934)
at android.os.Parcel.readException(Parcel.java:1884)
at android.app.IActivityManager$Stub$Proxy.getContentProvider(IActivityManager.java:4031)
at android.app.ActivityThread.acquireProvider(ActivityThread.java:6414)
at android.app.ContextImpl$ApplicationContentResolver.acquireUnstableProvider(ContextImpl.java:2825)
at android.content.ContentResolver.acquireUnstableProvider(ContentResolver.java:1835)
at android.content.ContentResolver.query(ContentResolver.java:793)
at android.content.ContentResolver.query(ContentResolver.java:759)
at android.content.ContentResolver.query(ContentResolver.java:717)
at com.e1c.mobile.TelephonyToolsImpl.a(Unknown Source:90)

.......
Куда копать?((   на каком-то форуме говорят, что дело в разрешениях на список контактов, это при сборке значит нужно доп.разрешения устанавливать?
 
 
   Pandoch
 
1 - 08.08.19 - 17:24
релиз платформы 8.3.13
   Pandoch
 
2 - 08.08.19 - 17:28
Сейчас входящий звонок был и приложение опять порушилось, уже с новой ошибкой xDD

java.lang.SecurityException: Permission Denial: opening provider com.android.providers.contacts.CallLogProvider from ProcessRecord{2807ce8d0 20685:storverk.CRM.mobile/u0a319} (pid=20685, uid=10319) requires android.permission.READ_CALL_LOG or android.permission.WRITE_CALL_LOG
 at android.os.Parcel.createException(Parcel.java:1966)
 at android.os.Parcel.readException(Parcel.java:1934)
 at android.os.Parcel.readException(Parcel.java:1884)
 at android.app.IActivityManager$Stub$Proxy.getContentProvider(IActivityManager.java:4031)
 at android.app.ActivityThread.acquireProvider(ActivityThread.java:6414)
 at android.app.ContextImpl$ApplicationContentResolver.acquireUnstableProvider(ContextImpl.java:2825)
 at android.content.ContentResolver.acquireUnstableProvider(ContentResolver.java:1835)
 at android.content.ContentResolver.query(ContentResolver.java:793)
......
   Pandoch
 
3 - 08.08.19 - 17:28
ПамагитеСпасите
   yurikmellon2
 
4 - 08.08.19 - 17:29
я то не спец во всём этом, но, парни, Анжеле надо помочь )
   Pandoch
 
5 - 08.08.19 - 17:30
хотя нет, ошибка та же
   Pandoch
 
6 - 08.08.19 - 17:30
java.lang.RuntimeException: Error receiving broadcast Intent { act=android.intent.action.PHONE_STATE flg=0x1000010 (has extras) } in com.e1c.mobile.TelephonyToolsImpl$3@5f1f201
at android.app.LoadedApk$ReceiverDispatcher$Args.lambda$getRunnable$0(LoadedApk.java:1496)
at android.app.-$$Lambda$LoadedApk$ReceiverDispatcher$Args$_BumDX2UKsnxLVrE6UJsJZkotuA.run(Unknown Source:2)
 at android.os.Handler.handleCallback(Handler.java:873)
 at android.os.Handler.dispatchMessage(Handler.java:99)
 at android.os.Looper.loop(Looper.java:214)
 at android.app.ActivityThread.main(ActivityThread.java:7156)
at java.lang.reflect.Method.invoke(Native Method)
 at com.android.internal.os.RuntimeInit$MethodAndArgsCaller.run(RuntimeInit.java:494)
at com.android.internal.os.ZygoteInit.main(ZygoteInit.java:975)
Caused by: java.lang.NullPointerException: Attempt to invoke virtual method 'boolean java.lang.String.equals(java.lang.Object)' on a null object reference
at com.e1c.mobile.TelephonyToolsImpl$3.onReceive(Unknown Source:125)
   НадюшаЯ
 
7 - 08.08.19 - 17:35
Судя по переводчику, толи доступа куда-то нет, толи какой то библиотеки, как вариант пересобрать на новой платформе, хотя чем это поможет...
   Fram
 
8 - 08.08.19 - 19:30
(0) Проверь доступ приложения к журналу звонков
   palsergeich
 
9 - 08.08.19 - 19:37
Судя по тексту - нет разрешения на доскуп к коньактам
   palsergeich
 
10 - 08.08.19 - 19:38
Там в корневом узле конфигурации надо галочки поставить что эти разрешения потребуются
   Pandoch
 
11 - 08.08.19 - 19:52
(8) есть
   Pandoch
 
12 - 08.08.19 - 19:53
Попробую новую платформу скачать и на ней собрбать

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.