Вход | Регистрация
 
1С:Предприятие :: 1С:Предприятие 8 общая

Расчет ресурсов в СКД

Расчет ресурсов в СКД
Я
   del_sun
 
08.08.19 - 16:05
Добрый день.
Необходимо посчитать значение ресурса для определенного уровня группировки по следующему принципу:
Если Уровень = 1 тогда
Считаем ЗначениеГруппировкиУровень1
ИначеЕсли Уровень = 2 Тогда

Если ЗначениеГруппировкиУровень1 = 0 ТОгда 0
Иначе
Считаем ЗначениеГруппировкиУровень2
КонецЕсли
ИначеЕсли Уровень = 3 ТОгда

Если ЗначениеГруппировкиУровень2 = 0 ТОгда 0
Иначе
Считаем ЗначениеГруппировкиУровень3
КонецЕсли

КонецЕсли


Как мне на уровне 2 и все последующие получить значение группировки вышестоящего уровня ? Вычислить выражение выдает все время Null т.е. Корректно выводится только Уровень1.
 
 
   del_sun
 
1 - 08.08.19 - 16:12
Т.е. если просто поставить расчет 
Если Уровень = 1 тогда 
Считаем ЗначениеГруппировкиУровень1 
ИначеЕсли Уровень = 2 Тогда 
Считаем ЗначениеГруппировкиУровень2 
ИначеЕсли Уровень = 3 ТОгда 
Считаем ЗначениеГруппировкиУровень3 
КонецЕсли 

все отрабатывает, а если попытаться на уровне 2 посчитать значениегруппировкиУровень1 то 0
   bootini
 
2 - 08.08.19 - 16:17
а галочками в поле "рассычитать по..." нельзя это настроить?
   del_sun
 
3 - 08.08.19 - 16:22
к сожалению нельзя ...
   bootini
 
4 - 08.08.19 - 16:29
не понятно что надо, вот так считает по умолчанию:

Уровень1   5
 Уровень2  1
  Уровень3 1
 Уровень2  4
  Уровень3 2
  Уровень3 2 

как надо?
   del_sun
 
5 - 08.08.19 - 16:40
(4) представлено сумма
у меня отчет, который должен показать сколько необходимо произвести конкретной продукции, представленный в виде дерева.
И получается, что если уже выпущена продукция более высокого уровня нет необходимости производить все ниже лежащее, даже если система показывает что еще не выпускали.
И получается, что если происходит ситуация
Уровень 1 Нужно производить 10 Произвели 10 Осталось произвести 0
   Уровень 2 нужно производить 10 Произвели 2 осталось произвести 8
        Уровень 3 Нужно производить 10 Произвели 9 Осталось произвести 1
   Уровень 2 Нужно производить 10 Произвели 4 осталось произвести 6
 
ТО пользователю необходимо показать 

Уровень 1 Нужно производить 10 Произвели 10 Осталось произвести 0
   Уровень 2 нужно производить 10 Произвели 2 осталось произвести 0
        Уровень 3 Нужно производить 10 Произвели 9 Осталось произвести 0
   Уровень 2 Нужно производить 10 Произвели 4 осталось произвести 0
   bootini
 
6 - 08.08.19 - 16:54
Минимум(ОсталосьПроизвести) не?
   bootini
 
7 - 08.08.19 - 16:59
ок, понял. ща
   bootini
 
8 - 08.08.19 - 17:50
Вычисляемое поле

НужноПроизвести - ВычислитьВыражение("Сумма(ОсталосьПроизвести)", "Уровень",)
   del_sun
 
9 - 09.08.19 - 09:34
(8) Спасибо. Озадачилась.. Ушла думать как то вклинить в отчет ....

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.