Вход | Регистрация
 
1С:Предприятие :: 1С:Предприятие 7.7 и ранее

v7: Единица измерения в регламентированных отчетах

v7: Единица измерения в регламентированных отчетах
Я
   Asia2016
 
08.08.19 - 10:28
Как изменить денежную единицу в регламентированных отчетах, т.е. не в тысячах рублей, а в рублях
 
 
   johnnik
 
1 - 08.08.19 - 10:36
В шапке самого отчета есть поле "Ед.изм", варианты выбора: рубли, тыс. рублей, мил. рублей. И точность (дробь после запятой).
   Asia2016
 
2 - 08.08.19 - 10:54
(1) у нас в шапке не меняется. и в модуле не могу найти
   Asia2016
 
3 - 08.08.19 - 10:58
   Asia2016
 
4 - 08.08.19 - 11:06
Перем ГодОтчета;
Перем КварталОтчета;
Перем ДатаВКвартале;               
Перем Конт;

Функция НомерКвартала( ДляДаты )
    Возврат Цел( ( ДатаМесяц( ДляДаты ) - 1 )/3 ) + 1;
КонецФункции

Процедура Сформировать()                    
    СпрНсФ = СоздатьОбъект("Справочник.НалогиИотчисления");
    СпрНсФ.Найтипокоду("прибыль");
    прибыль = спрНСФ.текущийэлемент();
    СпрНсф.Найтипокоду("Подохналог");
    Подохналог = СпрНсф.текущийэлемент();
    СпрНсф.Найтипокоду("НДС");
    НДС = СпрНсф.текущийэлемент();
    
    СпрНсФ.Найтипокоду("инф");
    инф = спрНСФ.текущийэлемент();
    //СпрНсф.Найтипокоду("единналог");

    //единналог1 = СпрНсф.текущийэлемент();

    СпрНсф.Найтипокоду("имущество");
    имущество = СпрНсф.текущийэлемент();
    СпрНсф.Найтипокоду("земля");
    земля = СпрНсф.текущийэлемент();
    СпрНсф.Найтипокоду("Вода");
    Вода = СпрНсф.текущийэлемент();
    СпрНсф.Найтипокоду("Экология");
    Экология = СпрНсф.текущийэлемент();
    СпрНсф.Найтипокоду("Недра");
    Недра = СпрНсф.текущийэлемент();

    Ит = СоздатьОбъект("БухгалтерскиеИтоги");
     Ит.ПериодКВН(КварталОтчета,ГодОтчета);
                                              
    П28101 = ит.об(счетпокоду("98"), прибыль.счет); 
     П28102 = ит.об(прибыль.счет,Счетпокоду("51"))+ит.об(прибыль.счетаванса,Счетпокоду("51"));
    
    П28201 = ит.об(счетпокоду("67"), подохналог.счет); 
     П28202 = ит.об(подохналог.счет,Счетпокоду("51"))+ит.об(подохналог.счетаванса,Счетпокоду("51"));
     
     П3301 = Ит.ОБ("40",НДС.счет) + Ит.ОБ("92",НДС.счет) - Ит.ОБ(НДС.счетаванса,"60")
            + ит.об(счетпокоду("64.10"),НДС.счетаванса);
    П3302 = ит.об(НДС.счет,счетпокоду("51"))+ит.об(НДС.счетаванса,счетпокоду("51"));     
    
      П3501 = ит.об(счетпокоду("94"),недра.счет);
    П3502 = ит.об(недра.счет, счетпокоду("51"))+ит.об(недра.счетаванса, счетпокоду("51"));
     
    П3601 = ит.об(счетпокоду("94"),экология.счет);
    П3602 = ит.об(экология.счет, счетпокоду("51"))+ит.об(экология.счетаванса, счетпокоду("51"));
    
      П3701 = ит.об(счетпокоду("94"),вода.счет);
    П3702 = ит.об(вода.счет, счетпокоду("51"))+ит.об(вода.счетаванса, счетпокоду("51"));
      
    П3901 = ит.об(счетпокоду("94"),имущество.счет);
    П3902 = ит.об(имущество.счет, счетпокоду("51"))+ит.об(имущество.счетаванса, счетпокоду("51"));
       
    П4001 = ит.об(счетпокоду("94"),земля.счет);          
    П4002 = ит.об(земля.счет, счетпокоду("51"))+ит.об(земля.счетаванса, счетпокоду("51"));
       
     П4101 = ит.об(счетпокоду("98"),инф.счет);
    П4102 = ит.об(инф.счет, счетпокоду("51"))+ит.об(инф.счетаванса, счетпокоду("51"));
    
    П0103 = Ит.КО("90");
    П0204 = Ит.ОБ("91","28") + Ит.Об("91","29")+Ит.Об("91","60");
    П0504 = ит.до("94.1");
    П0604 = ит.до("94.2");
    П0704 = ит.до("94.3");
    П0903 = Ит.КО("93");
      
      П1203 = ит.ко("95.20");
    П1303 = ит.ко("95.30");
    П1403 = ит.ко("95.50");
    П1503 = ит.ко("95.40");
    П1603 = ит.ко("95")-П1203130314031503; 
    
    П1804 = ит.До("96.10");
    П1904 = 0;
    П2004 = ит.До("96.20");
    П2104 = ит.До("96")-П180419042004;

    П2303 = Ит.КО("97.10");
    П2304 = Ит.ДО("97.20")  ;
    П2504 = ит.об("98",прибыль.счет);
    П2604 = Ит.ОБ("98","64") - П2504 ;

     Ит.ПериодКВН(КварталОтчета,ГодОтчета-1);
 
     П3103 = Ит.КО("90");
    П3204 = Ит.ОБ("91","28") + Ит.Об("91","29")+Ит.Об("91","60");
    П3504 = ит.до("94.1");
    П3604 = ит.до("94.2");
    П3704 = ит.до("94.3");
    П3903 = Ит.КО("93");
      
      П4203 = ит.ко("95.20");
    П4303 = ит.ко("95.30");
    П4403 = ит.ко("95.50");
    П4503 = ит.ко("95.40");
    П4603 = ит.ко("95")-П4203430344034503; 
    
    П4804 = ит.До("96.10");
    П4904 = 0;
    П5004 = ит.До("96.20");
    П5104 = ит.До("96")-П480449045004;

    П5303 = Ит.КО("97.10");
    П5304 = Ит.ДО("97.20")  ;
    П5504 = ит.об("98",прибыль.счет);
    П5604 = Ит.ОБ("98","64") - П5504 ;
Конецпроцедуры         

Функция КварталОтчетаСтр( НомерКварталаОтчета, ГодОтч )
    ДатаВКвартале=Дата( ГодОтч, НомерКварталаОтчета*3, 1 );
    Возврат ПериодСтр( НачКвартала( ДатаВКвартале ), КонКвартала( ДатаВКвартале ) );
КонецФункции

Процедура ПриОткрытии()
    Форма.ИспользоватьСлой("Основной",2);
    КварталОтчета=ВосстановитьЗначение("Квартал отчета");
    Если ПустаяСтрока( Строка( КварталОтчета ) ) = 1 Тогда
        КварталОтчета = НомерКвартала( РабочаяДата() );
    КонецЕсли;
    ГодОтчета=ВосстановитьЗначение("Год отчета") ;
    Если ПустаяСтрока( Строка( ГодОтчета ) ) = 1 Тогда
        ГодОтчета=ДатаГод( РабочаяДата() );
    КонецЕсли;
    ПериодОтчета=КварталОтчетаСтр( КварталОтчета, ГодОтчета );
КонецПроцедуры    

Процедура ПлюсПериод()
        Если КварталОтчета=4 Тогда
            КварталОтчета=1;
            ГодОтчета=ГодОтчета+1;
        Иначе
            КварталОтчета=КварталОтчета+1;
        КонецЕсли;
        ПериодОтчета=КварталОтчетаСтр( КварталОтчета, ГодОтчета );
КонецПроцедуры

Процедура МинусПериод()
        Если КварталОтчета=1 Тогда
            КварталОтчета=4;
            ГодОтчета=ГодОтчета-1;
        Иначе
            КварталОтчета=КварталОтчета-1;
        КонецЕсли;
        ПериодОтчета=КварталОтчетаСтр( КварталОтчета, ГодОтчета );
КонецПроцедуры                              
                    
Процедура Прибыль()
    КаталогОтчетов=КаталогИБ()+"ExtForms\";
    КаталогГруппыОтчетов=ФС.НайтиПервыйФайл(КаталогОтчетов+"rp*.grp");  
    Файл = КаталогОтчетов+"\"+КаталогГруппыОтчетов+"\Profit.ert";
    Если ФС.СуществуетФайл(Файл) = 1 Тогда
        Конт = СоздатьОбъект("СписокЗначений");
        Конт.Установить("КварталОтчета",КварталОтчета);
        Конт.Установить("ГодОтчета",ГодОтчета);
        Прибыль = П2403 - П2404;
        Конт.Установить("Прибыль",Прибыль);
        ОткрытьФорму("Отчет",Конт,Файл);
    Иначе     
        Сообщить("Файл с расчетом налога на прибыль не найден!");
    КонецЕсли;
КонецПроцедуры

Процедура Инфраструктура()
    КаталогОтчетов=КаталогИБ()+"ExtForms\";
    КаталогГруппыОтчетов=ФС.НайтиПервыйФайл(КаталогОтчетов+"rp*.grp");  
    Файл = КаталогОтчетов+"\"+КаталогГруппыОтчетов+"\Infr.ert";
    Если ФС.СуществуетФайл(Файл) = 1 Тогда
        Конт = СоздатьОбъект("СписокЗначений");
        Конт.Установить("КварталОтчета",КварталОтчета);
        Конт.Установить("ГодОтчета",ГодОтчета);
        НалОблБаза = П2403 - П2404 - П2504;
        Конт.Установить("НалОблБаза",НалОблБаза);
        ОткрытьФорму("Отчет",Конт,Файл);
    Иначе     
        Сообщить("Файл с расчетом сбора на развитие инфраструктуры не найден!");
    КонецЕсли;
КонецПроцедуры
   Asia2016
 
5 - 08.08.19 - 11:06
это сам модуль
   Cthulhu
 
6 - 08.08.19 - 11:09
формат ячеек таблицы шаблона отчета смотри
   Asia2016
 
7 - 08.08.19 - 11:13
   Cthulhu
 
8 - 08.08.19 - 11:18
(7): и что тебе непонятно? меняй формат на тот, который нужен. или дописывай программу - этот формат можно менять и программно типа Таблица.Область("Разделы12").Формат("Ч017.1, ");
   Asia2016
 
9 - 08.08.19 - 11:19
поменяла длину 19, точность 3 формат Ч019.3,
   Asia2016
 
10 - 08.08.19 - 11:19
ничего не изменилось
   Asia2016
 
11 - 08.08.19 - 11:22
спасибо, получилось

Список тем форума
Рекламное место пустует  Рекламное место пустует
2 + 2 = 3.9999999999999999999999999999999...
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.