Вход | Регистрация
 
1С:Предприятие :: 1С:Предприятие 8 общая

Добавление контрагента по ИНН загружает диск на 100%

Добавление контрагента по ИНН загружает диск на 100%
Я
   Alex2411
 
08.08.19 - 09:54
добрый день, не могу понять почему???!!!! длится это 10 мин. потом заполняется, думал винт плохой поставил SSD, тоже самое, куда копать?
 
 
   olegves
 
1 - 08.08.19 - 09:59
(0) база файловая? Сколько оперативы? Что в диспетчере задач по загрузкам ресурсов?
   Alex2411
 
2 - 09.08.19 - 09:29
системник новый, база 4 гига файловая, оперативка 8 гиг проц i3 9-го покаления, вин SSD. в диспечере нагрузка на винт 100%, винт поменяли тоже самое(((( системник поменяли тоже самое(((
   piter3
 
3 - 09.08.19 - 09:31
Потому что нужно посмотреть для начала,замер производительности.И что еще параллельно делается,например регламентные задания
   MaxxiMiliSanM
 
4 - 09.08.19 - 09:59
   mikecool
 
5 - 09.08.19 - 10:05
(4) а решение узнать - только качать...
   Alex2411
 
6 - 13.08.19 - 13:08
Ребят я так и не понял как поменять запрос, тема интересная, не ужели она только у меня воспроизводиться??
   Alex2411
 
7 - 13.08.19 - 13:08
(5) - это платное решение
   piter3
 
8 - 13.08.19 - 13:12
(6) Сделать замер,поправить запрос или сказать сколько готов заплатить.
   Cyberhawk
 
9 - 13.08.19 - 13:19
(7) 1 стартмани. Но за лень приходится часто переплачивать, это да.
   Alex2411
 
10 - 13.08.19 - 13:25
(8) замер производительности зделал, все так как написано в (4)

ОК. Попробую сам запрос подшамать обязательно отпишусь, что бы другие не мучились!
   piter3
 
11 - 13.08.19 - 13:26
(10) А другие просто покупают или сами делают)
   Злопчинский
 
12 - 13.08.19 - 13:33
(10) верится с трудом. в подавляющем колве случаев набегающие задающие здесь вопрос потом исчезают
   Alex2411
 
13 - 13.08.19 - 15:09
(12) Обязательно отпишусь))
   Alex2411
 
14 - 13.08.19 - 15:09
(4) все же есть спортивный интерес как автор этой статьи зделал
   Йохохо
 
15 - 13.08.19 - 15:24
(14) институт интриги приглашает на интересное спортивное мероприятие
   Alex2411
 
16 - 14.08.19 - 13:41
Функция Расш1_СведенияОЗагрузкеСубъектовРФ() Экспорт
    Классификатор = РегистрыСведений.АдресныеОбъекты.КлассификаторСубъектовРФ();
    
    // Выбираем все возможные данные - и из регистра, и из классификатора.

    // Считаем, что уникальность обеспечивается не идентификатором (что правильно), а кодом субъекта

    // из-за особенностей платформы по передаче уникального идентификатора в таблицу-параметр запроса.

    
    Запрос = Новый Запрос("ВЫБРАТЬ
    |    Параметр.Наименование КАК Наименование,
    |    Параметр.Сокращение КАК Сокращение,
    |    Параметр.КодСубъектаРФ КАК КодСубъектаРФ
    |ПОМЕСТИТЬ Классификатор
    |ИЗ
    |    &Классификатор КАК Параметр
    |
    |ИНДЕКСИРОВАТЬ ПО
    |    КодСубъектаРФ
    |;
    |
    ////////////////////////////////////////////////////////////////////////////////

    |ВЫБРАТЬ
    |    Классификатор.Наименование + "" "" + Классификатор.Сокращение КАК Представление,
    |    Классификатор.КодСубъектаРФ КАК КодСубъектаРФ,
    |    ЗагруженныеВерсииАдресныхСведений.Версия КАК Версия,
    |    ЗагруженныеВерсииАдресныхСведений.ДатаВерсии КАК ДатаВерсии,
    |    ЗагруженныеВерсииАдресныхСведений.ДатаЗагрузки КАК ДатаЗагрузки,
    |    АдресныеОбъекты.Идентификатор КАК Идентификатор,
    |    НЕ ЗагруженныеВерсииАдресныхСведений.Версия ЕСТЬ NULL КАК Загружено,
    |    ДОБАВИТЬКДАТЕ(ЗагруженныеВерсииАдресныхСведений.ДатаЗагрузки, МЕСЯЦ, 1) < &ТекущаяДата КАК Устарело
    |ИЗ
    |    Классификатор КАК Классификатор
    |        ЛЕВОЕ СОЕДИНЕНИЕ РегистрСведений.АдресныеОбъекты КАК АдресныеОбъекты
    |        ПО (АдресныеОбъекты.КодСубъектаРФ = Классификатор.КодСубъектаРФ)
    |        ЛЕВОЕ СОЕДИНЕНИЕ РегистрСведений.ЗагруженныеВерсииАдресныхСведений КАК ЗагруженныеВерсииАдресныхСведений
    |        ПО Классификатор.КодСубъектаРФ = ЗагруженныеВерсииАдресныхСведений.КодСубъектаРФ    
    |ГДЕ
    |    АдресныеОбъекты.Уровень = 1
    |
    |УПОРЯДОЧИТЬ ПО
    |    КодСубъектаРФ");
    
    Запрос.УстановитьПараметр("Классификатор", Классификатор);
    Запрос.УстановитьПараметр("ТекущаяДата",   ТекущаяДатаСеанса());
    
    РезультатВыборкиЗагруженныхСведений = Запрос.Выполнить();
    Если РезультатВыборкиЗагруженныхСведений.Пустой() Тогда
        ВыполнитьНачальноеЗаполнение();
        РезультатВыборкиЗагруженныхСведений = Запрос.Выполнить();
    КонецЕсли;
    
    ЗагруженныеСведения = РезультатВыборкиЗагруженныхСведений.Выгрузить();
    
    ЗагруженныеСведения.Индексы.Добавить("Идентификатор");
    ЗагруженныеСведения.Индексы.Добавить("КодСубъектаРФ");
    ЗагруженныеСведения.Индексы.Добавить("Загружено");
    
    // Корректируем идентификаторы из-за особенностей платформы по передаче уникального

    // идентификатора в таблицу-параметр запроса.

    Для Каждого Строка Из ЗагруженныеСведения Цикл
        Если Не ЗначениеЗаполнено(Строка.Идентификатор) Тогда
            СтрокаКлассификатора = Классификатор.Найти(Строка.КодСубъектаРФ, "КодСубъектаРФ");
            Если СтрокаКлассификатора <> Неопределено Тогда
                Строка.Идентификатор = СтрокаКлассификатора.Идентификатор;
            КонецЕсли;
        КонецЕсли;
    КонецЦикла;
    
    Возврат ЗагруженныеСведения;
КонецФункции
   Alex2411
 
17 - 14.08.19 - 13:42
(16) готовое решение, работает хорошо
   piter3
 
18 - 14.08.19 - 13:51
Молодец
   MaxxiMiliSanM
 
19 - 14.08.19 - 16:56
(17) теперь никто и не скачает( пустил по миру

Список тем форума
Рекламное место пустует  Рекламное место пустует
Кaк может человек ожидaть, что его мольбaм о снисхождении ответит Тот, кто превыше, когдa сaм он откaзывaет в милосердии тем, кто ниже его? Петр Трубецкой
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.