Вход | Регистрация
 
1С:Предприятие :: 1С:Предприятие 7.7 и ранее

v7: Вывести справочник Номенклатура в ТабДок

v7: Вывести справочник Номенклатура в ТабДок
Я
   oqjawa
 
07.08.19 - 14:49
Процедура Сформировать()

Перем Запрос, ТекстЗапроса, Таб;

Запрос = СоздатьОбъект("Запрос");

ТекстЗапроса = "
|Артикул = Справочник.Номенклатура.Артикул;
|БазоваяЕдиница = Справочник.Номенклатура.БазоваяЕдиница;
|Весовой = Справочник.Номенклатура.Весовой;
|";
Если Запрос.Выполнить(ТекстЗапроса) = 0 Тогда
    Возврат;
КонецЕсли;

Таб = СоздатьОбъект("Таблица");
Таб.ИсходнаяТаблица("Таблица");
Таб.ВывестиСекцию("Заголовок");

Пока Запрос.Группировка(1) = 1 Цикл
      
    Таб.ВывестиСекцю("Номенклатура");
КонецЦикла;
Таб.Показать("Сформировать", "");


    
КонецПроцедуры
 
 
   oqjawa
 
1 - 07.08.19 - 14:51
Блин выводится только секция "Заголовок"

В секции "номенклатура" написал <Запрос.Артикул> <Запрос.БазоваяЕдиница>... Это правильно? или как там значение параметра назначить ячейки..?
   Ёпрст
 
2 - 07.08.19 - 14:53
(0) группировки нет - выборки нет..
   oqjawa
 
3 - 07.08.19 - 14:56
в конце запроса нужно 
Группировка = Справочник.Номенклатура.Артикул; ?
   oqjawa
 
4 - 07.08.19 - 15:08
(3) ответ точно нет))
   ДенисЧ
 
5 - 07.08.19 - 15:22
ТекстЗапроса = " 
|Товар = Справочник.Номенклатура.ТекущийЭлемент;
|Артикул = Справочник.Номенклатура.Артикул; 
|БазоваяЕдиница = Справочник.Номенклатура.БазоваяЕдиница; 
|Весовой = Справочник.Номенклатура.Весовой; 
|Группировка Товар;
|";
   oqjawa
 
6 - 07.08.19 - 15:40
(2),(5)  ребят спасибо большое..

 Таб.ВывестиСекцю("Номенклатура"); 

Поле агрегатного объекта не обнаружено (ВывестиСекцю) 

что это значит?
   hhhh
 
7 - 07.08.19 - 15:49
(6) нет такого метода ВывестиСекцю значит
   Ёпрст
 
8 - 07.08.19 - 15:50
(6)циЮ
   oqjawa
 
9 - 07.08.19 - 15:53
опечатка наверное была..
Скажите пожалуйста а параметр в 7.7 как создаётся на макете? я думал просто в <Запрос.Параметр>
но он мне выдал не значение параметра а как текст <Запрос.Параметр>
<Запрос.Параметр>
<Запрос.Параметр>
<Запрос.Параметр>
<Запрос.Параметр>
<Запрос.Параметр> и так пока весь список не выдаст
   Ёпрст
 
10 - 07.08.19 - 15:54
(9) тип ячейки - выражение поставь, хотя бы.
   Builder
 
11 - 07.08.19 - 15:57
(9) Любая переменная из модуля будет доступна в макете 7.7
Ну и открой для себя конструктор запроса, там все есть и печатная форма тоже. Слегка допилить только надо внешний вид.

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.