Вход | Регистрация
 

Не верная СНО из РКО

Не верная СНО из РКО
Я
   SunFox
 
07.08.19 - 14:32
Обновились до последнего релиза 10.3.55.2. драйвер 10.5.0.0 - обработка последняя.
Чеки ККМ печатаются со СНО ЕНВД - все ок.
А вот пробили РКО возврат - там выбилась УСН доход!
Не могу найти где передается СНО в ККТ. в ККТ в настройках стоит ЕНВД.
Куда копать?
 
 
   SunFox
 
1 - 07.08.19 - 14:47
Посмотрел лог драйвера - 1с-ка не верную СНО выдала.
   SunFox
 
2 - 07.08.19 - 15:05
Функция ПечатьЧекаПКОРКО(Идентификатор, ЭтоРКО, Пароль, НомерЧека, НомерСмены,
                         ОписаниеПлатежа, СуммаНал, СуммаБезнал)
    
    Обработка = Неопределено;
    Объект    = Неопределено;
    ВремНомерЧека = 0;
    Результат = ПолучитьОбъектДрайвера(Идентификатор, Обработка, Объект);

    Если НЕ ЗначениеЗаполнено(Результат) Тогда
        НомерОтдела = Неопределено;
        Результат   = Обработка.ПолучитьПараметрыНаличнойОплаты(Объект, НомерОтдела);

        Если НЕ ЗначениеЗаполнено(Результат) Тогда
            Результат = Обработка.ОткрытьЧек(Объект, Пароль, ЭтоРКО, ВремНомерЧека, НомерСмены, Истина);
            Если НЕ ЗначениеЗаполнено(Результат) Тогда
                Позиция = Неопределено;
                Для Каждого Позиция Из ОписаниеПлатежа Цикл
                    Результат = Обработка.ПечататьСтроку(Объект,
                                                         Позиция.Заголовок,
                                                         1,
                                                         Позиция.Сумма,
                                                         0,
                                                         НомерОтдела,
                                                         Позиция.НДС);

                    Если ЗначениеЗаполнено(Результат) Тогда
                        Прервать;
                    КонецЕсли;
                КонецЦикла;
                Если НЕ ЗначениеЗаполнено(Результат) Тогда
                    Результат = Обработка.ЗакрытьЧек(Объект, СуммаНал, СуммаБезнал);
                КонецЕсли;
            КонецЕсли;
        КонецЕсли;
        мОписаниеОшибки = Объект.ОписаниеОшибки;
    Иначе
        мОписаниеОшибки = ПолучитьТекстОшибкиПодключенияТО("ФР");
    КонецЕсли;

    Если НЕ ЗначениеЗаполнено(Результат) Тогда
        НомерЧека = ВремНомерЧека
    КонецЕсли;
    
    Возврат Результат;

КонецФункции// ПечатьЧекаПКО()


В обработке ТО СНО не определяется, где искать?
   SeriyP
 
3 - 07.08.19 - 16:02
(0) МенеджерОборудованияВызовСервера.ПодготовитьДанныеДляФискализацииЧека
   Kigo_Kigo
 
4 - 07.08.19 - 17:44
думаю надо искать здесь - ЭтоРКО

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.