Вход | Регистрация
 

ФСО = Новый COMОбъект("Scripting.FileSystemObject") через СОМ

ФСО = Новый COMОбъект("Scripting.FileSystemObject") через СОМ
Я
   bugug
 
05.08.19 - 10:42
Как в подключенной через СОM базе вызвать еще один COM объект?
 
 
   bugug
 
1 - 05.08.19 - 10:43
fso = ПодключеннаяБаза.NewObject("scripting.fileSystemObject") - Так не работает.
   bugug
 
2 - 05.08.19 - 11:06
Задача такая, нужно определить свободно место на удаленном сервере.
   hhhh
 
3 - 05.08.19 - 11:11
(2) сделать функцию в той фазе. и уже ее и вызывать.
   bugug
 
4 - 05.08.19 - 11:13
(3) да, но хотелось универсальное что-то.
   bugug
 
5 - 05.08.19 - 11:13
(4) много серверов
   bugug
 
6 - 05.08.19 - 11:14
(5) копипастить эту процедуру в кучу баз...  засмеете же)
   lodger
 
7 - 05.08.19 - 11:38
(6) а без FileSystemObject нашкодить не пробовал?
   GROOVY
 
8 - 05.08.19 - 11:40
Процедура КнопкаВыполнитьНажатие(Кнопка)
    НужнаяСтрока = "";    
    КомандаСистемы("dir \\serv\Archive > " + КаталогВременныхФайлов() + "freespace.txt");
    Текстфайла = Новый ЧтениеТекста(КаталогВременныхФайлов() + "freespace.txt",КодировкаТекста.OEM);
    СтрФайла = ТекстФайла.ПрочитатьСтроку();
    Пока СтрФайла <> Неопределено Цикл
        Если СтрНайти(СтрФайла, "свободно") > 0 Тогда
            НужнаяСтрока = СтрФайла;
            ОтсечениеСлево = СтрНайти(НужнаяСтрока,"папок") + 6;
            НужнаяСтрока = СтрЗаменить(НужнаяСтрока,"байт свободно","");
            НужнаяСтрока = СокрЛП(Сред(НужнаяСтрока,ОтсечениеСлево));
        КонецЕсли;
        СтрФайла = ТекстФайла.ПрочитатьСтроку();
    КонецЦикла;
    СвободноМб = Число(НужнаяСтрока)/1024/1024;
    Сообщить("Свободно " + СвободноМб + " Мб");
    
КонецПроцедуры

(с) не мое.
   GROOVY
 
9 - 05.08.19 - 11:41
Под линуксы будет ЗапуститьПриложение(" df | grep /home > /tmp/" + "freespace.txt", , Истина);
   Сияющий в темноте
 
10 - 05.08.19 - 11:46
Начнем с того,что обьект нужно создавать на сервере,если вы его создаете локально через вызов,то это все равно,что без базы
а создаваться должен через NewObject("ComObject","Scripting.FileSystemObject")
   bugug
 
11 - 05.08.19 - 11:52
(8) Это пробовал ранее, пишет КомандаСистемы неопределена
   bugug
 
12 - 05.08.19 - 11:53
(10) так тоже пробовал, не работает((
   bugug
 
13 - 05.08.19 - 11:53
(7) как?
   bugug
 
14 - 05.08.19 - 11:54
(11) делаю через регламентное задание, на сервере.
   GROOVY
 
15 - 05.08.19 - 12:04
(11) Ну так юзай ЗапуститьПриложение, а не КомандаСистемы.
   bugug
 
16 - 05.08.19 - 12:10
(15) ок. сейчас попробую
   bugug
 
17 - 05.08.19 - 12:23
(16) зависает, ни ответа, ни привета, ошибок не пишет, просто висит, мертво на строке ЗапуститьПриложение("dir \\sqllp\E$ > " + КаталогВременныхФайлов() + "freespace.txt");
   Вафель
 
18 - 05.08.19 - 12:30
свободное место лучше через какой нибудь заббикс контролирововать
   bugug
 
19 - 05.08.19 - 12:42
(18) это надо изучать, не работал с этим. Мне не дадут время(

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.