Вход | Регистрация
 
1С:Предприятие :: 1С:Предприятие 8 общая

Как в режиме 1С:Предприятия (тонкий клиент) карту маршрута сохранить в файл?

Как в режиме 1С:Предприятия (тонкий клиент) карту маршрута сохранить в файл?
Я
   VAVANSTR
 
05.08.19 - 09:29
Как в режиме 1С:Предприятия (тонкий клиент) карту маршрута сохранить в файл-картинку?
Карту маршрута уже поместил в графическую схему и могу видеть в режиме 1С:Предприятия. Кнопка "Файл-сохранить как" не работает для графической схемы.
 
 
   VAVANSTR
 
1 - 05.08.19 - 09:35
Хотя разобрался сам
   VAVANSTR
 
2 - 05.08.19 - 09:35
Создал команду на форме с таким обработчиком:

&НаКлиенте
Процедура СохранитьКакКартинку(Команда)
    
    //Схема = Элементы.ГрафическаяСхема.ПолучитьСхему();

    КартинкаСхемы = ГрафическаяСхема.ПолучитьКартинку(,,ФорматКартинки.PNG)//.BMP);

    Режим = РежимДиалогаВыбораФайла.Сохранение;
    ДиалогОткрытияФайла = Новый ДиалогВыбораФайла(Режим);
    ДиалогОткрытияФайла.ПолноеИмяФайла = "";
    Текст = "ru = ""Картинка""; en = ""Picture""";
    Фильтр = НСтр(Текст)+"(*.bmp)|*.bmp";
    ДиалогОткрытияФайла.Фильтр = Фильтр;
    ДиалогОткрытияФайла.МножественныйВыбор = Ложь;
    ДиалогОткрытияФайла.Заголовок = "Выберите путь";
    Если ДиалогОткрытияФайла.Выбрать() Тогда
    КонецЕсли; 

    КартинкаСхемы.Записать(ДиалогОткрытияФайла.ПолноеИмяФайла);
    
КонецПроцедуры
   VAVANSTR
 
3 - 05.08.19 - 09:36
Прекрасно сохраняет в картинку формата PNG
   МаксимНижегородец
 
4 - 05.08.19 - 09:52
(3) Думаю, что графическая схема - не картинка, а картина - не графическая схема. Нужно для начала конкретизировать задачу (приоритет картинка или графическая схема).
   МаксимНижегородец
 
5 - 05.08.19 - 10:26
(2)     Если ДиалогОткрытияФайла.Выбрать() Тогда
          КартинкаСхемы.Записать(ДиалогОткрытияФайла.ПолноеИмяФайла);
    КонецЕсли; 

//    КартинкаСхемы.Записать(ДиалогОткрытияФайла.ПолноеИмяФайла);


Вот так должно быть. В BMP - должно писаться (для 1с это даже проще и по умолчанию).

Синтаксис:

ПолучитьКартинку(<Ширина>, <Высота>, <ФорматКартинки>)
Параметры:

<Ширина> (необязательный)

Тип: Число.
Ширина картинки в пикселях. Если <Ширина> или <Высота> = 0, то на клиенте в неуправляемой форме используются текущие размеры графической схемы. В остальных случаях используются размеры по умолчанию.
Значение по умолчанию: 0. 
<Высота> (необязательный)

Тип: Число. 
Высота картинки в пикселях. Если <Высота> или <Ширина> = 0, то на клиенте в неуправляемой форме используются текущие размеры графической схемы. В остальных случаях используются размеры по умолчанию.
Значение по умолчанию: 0. 
<ФорматКартинки> (необязательный)

Тип: ФорматКартинки. 
Определяет формат картинки.
Допустимые значения для растровых картинок: BMP, PNG и исходный тип. Для векторных картинок допускается указывать только исходный тип.
Значение по умолчанию: BMP.
Возвращаемое значение:

Тип: Картинка.

Описание:

Получает изображение графической схемы в виде картинки.

Доступность:

Тонкий клиент, сервер, толстый клиент, внешнее соединение.

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.