Вход | Регистрация
 
1С:Предприятие :: 1С:Предприятие 8 общая

Как получить ссылку из одной процедуры и передать в другую

Как получить  ссылку из одной процедуры и передать в другую
Я
   bebibo
 
02.08.19 - 08:51
Вопрос такой. Расскажу на примере:
Есть процедура "процедура1", в ней переход на другую процедуру "процедура2".
В "процедура1" нужно получить ссылку, которая формируется в "процедура2".
В "процедура1" нужно сделать отбор в регистре сведений, чтобы его очистить. Но отбор не могу сделать, так как ссылка для отбора формируется в "процедура2"
В "процедура1" есть ссылка, но в "процедура2" она преобразуется немного (Название немного меняется) и по ней надо искать.
Как сделать?
 
 
   ДенисЧ
 
1 - 02.08.19 - 08:52
Сделать Процедура2() функцией и вернуть из неё нужную ссылку
   butterbean
 
2 - 02.08.19 - 08:52
какое отношение название имеет к ссылке?
   bebibo
 
3 - 02.08.19 - 08:56
(1) Мне перед "Процедура1" нужно очистить регистр сведений, даже если сделаю как вы написали, все равно не определяет
   catena
 
4 - 02.08.19 - 08:57
(3)А возврат в функции нужного параметра прописали?
   ДенисЧ
 
5 - 02.08.19 - 08:58
(3) Тогда может того, в слесари? Программирование это не твоё...
   bebibo
 
6 - 02.08.19 - 08:58
(2) Ну например в "Процедура1" у меня ссылка такая http://www.jjjadsfuj.com
А в "Процедура2" он ее преобразует в dfhujs.jpg
   Масянька
 
7 - 02.08.19 - 08:59
(6) Откуда в первой процедуре ссылка?
   bebibo
 
8 - 02.08.19 - 08:59
Стоп. Не то 
"Процедура1" - у меня это функция..Описалась
   ДенисЧ
 
9 - 02.08.19 - 08:59
(6) Это не ссылка. Это URL. Это немного разные вещи...
   Масянька
 
10 - 02.08.19 - 09:00
(8) И в личке тоже?
   Масянька
 
11 - 02.08.19 - 09:00
(9) До этого оно еще не дошло.
   bebibo
 
12 - 02.08.19 - 09:07
(9) Ну да, не так выразилась
   bebibo
 
13 - 02.08.19 - 09:07
Блин, как сделать то?
   bebibo
 
14 - 02.08.19 - 09:08
(6) и мне вот нужно искать по этому : dfhujs.jpg
Потому что в регистре сведений есть только эта ссылка
   bootini
 
15 - 02.08.19 - 09:14
Процедура Процедура1()
   
  ФормируемаяСсылка = Процедура2();  

КонецПроцедуры

Функция Процедура2()
   
ФормируемаяСсылка = "http://www.jjjadsfuj.com";;

   Возврат ФормируемаяСсылка;

КонецФункции
   bebibo
 
16 - 02.08.19 - 09:15
(15) Сейчас попробую
   bootini
 
17 - 02.08.19 - 09:18
""Процедура1" - у меня это функция..Описалась
Ну да, не так выразилась"

Пол:    Мужской


Что за мужики пошли?!
В женском роде пишут и не знают как значение и функции вернуть.
   bebibo
 
18 - 02.08.19 - 09:21
(17) Это общий акк)
Сейчас не мужчина пишет)
Вашим способом не получилось..
   Масянька
 
19 - 02.08.19 - 09:22
Афигеть... Их там много... Чужие!!!!!!!!!!!!!!!!!!!!!!!
   Fish
 
20 - 02.08.19 - 09:23
(19) Теперь надо просить групповое фото в купальниках :))
   bebibo
 
21 - 02.08.19 - 09:24
(20) ахаха
   bootini
 
22 - 02.08.19 - 09:29
А так?)

Процедура Процедура1()
 ФормируемаяСсылка = Неопределено;
 Процедура2(ФормируемаяСсылка );

 Если Не ФормируемаяСсылка = Неопределено Тогда
     отбор = ФормируемаяСсылка
 КонецЕсли
КонецПроцедуры

Процедура Процедура2(ФормируемаяСсылка)

 ФормируемаяСсылка = ссылка на каторгу;

КонецПроцедуры
   PiotrLoginov
 
23 - 04.08.19 - 18:44
(22) это на коленке что ли написано?
Попробуй элементарно это в конфигураторе проверить на наличие ошибок в синтаксисе. Подправишь - тогда уже на форум выкладывай.


Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.