Вход | Регистрация
 

Почему вызывается Outlook

Почему вызывается Outlook
Я
   Neirofun
 
01.08.19 - 16:03
Во время отладки почему-то вызывается Outlook хотя нигде не фигурирует. Может кто подсказать?

Процедура ЗагрузитьВРСНажатие(Элемент)
    Попытка
        
            Excell = Новый COMОбъект("Excel.Application");
        
    Исключение
        
            Сообщить(ОписаниеОшибки() + " Программа Exсel не установлена на данном компьютере!");
        
    Возврат;
    КонецПопытки;

    Книга = Excell.WorkBooks.Open(ПутьКФайлу); ///здесь необходимо указать путь к шаблону
    Лист = Книга.WorkSheets(1);
    ВсегоКолонок = Лист.Cells(1,1).SpecialCells(11).Column;
    ВсегоСтрок = Лист.Cells(1,1).SpecialCells(11).Row;
    НовДокРС = Документы.ИзменениеДополнительныхПараметровНоменклатуры.СоздатьДокумент();
    НовДокРС.Организация = Справочники.Организации.НайтиПоКоду("00001   ");   //Розничная сеть Торес
    НовДокРС.Дата = ТекущаяДата();
    НовДокРС.ХозОперация = Справочники.ХозОперации.УстановкаПараметровСистемыЗаказовВыборочная;
    НовДокРС.ВалютаДокумента = Справочники.Валюты.НайтиПоКоду("643");   //643 Рубли
    НовДокРС.Автор = ПараметрыСеанса.Пользователь;
    НовДокРС.ПодразделениеКомпании = Справочники.ПодразделенияКомпании.НайтиПоКоду("00001   ");  //Код розничной сети
    НовДокРС.УстановитьНовыйНомер();
        
    Для Строка = 1 По ВсегоСтрок Цикл
    
        //СтрокаТабличнойЧасти = НовДокРС.ТоварыДокумента.Добавить();
    
        Для Колонка = 1 По ВсегоКолонок Цикл
        
            Значение = СокрЛП(Лист.Cells(Строка,Колонка).Value);
                        
            Если Колонка = 1 тогда
                Если не    Значение = "" Тогда
                      Подразделение = (Справочники.ПодразделенияКомпании.НайтиПоНаименованию(Значение));
                      Если Подразделение.Организация =  Справочники.Организации.НайтиПоКоду("00001   ") Тогда
                          СтрокаТабличнойЧасти = НовДокРС.ТоварыДокумента.Добавить();
                          СтрокаТабличнойЧасти.ПодразделениеНазначения = Подразделение;
                          Иначе Прервать;
                      КонецЕсли;
            
                КонецЕсли;
            ИначеЕсли Колонка = 2 Тогда
                Если не    Значение = "" Тогда
                    Значение = Справочники.Номенклатура.НайтиПоКоду(Значение);
                    СтрокаТабличнойЧасти.Номенклатура = Справочники.Номенклатура.НайтиПоКоду(Значение);
                КонецЕсли;
            ИначеЕсли колонка = 4 Тогда
                Если не    Значение = "" Тогда
                    СтрокаТабличнойЧасти.ОсновнойПоставщик = Справочники.Контрагенты.НайтиПоНаименованию(Значение);
                КонецЕсли;
            ИначеЕсли колонка = 5 Тогда
                Если не    Значение = "" Тогда
                    СтрокаТабличнойЧасти.АльтернативныйПоставщик1 = Справочники.Контрагенты.НайтиПоНаименованию(Значение);
                    //СтрокаТабличнойЧасти.АльтернативныйПоставщик2 = Справочники.Контрагенты.НайтиПоНаименованию(Значение);    
                КонецЕсли;
            ИначеЕсли колонка = 6 Тогда
                Если не    Значение = "" Тогда
                    СтрокаТабличнойЧасти.Менеджер = Справочники.Сотрудники.НайтиПоНаименованию(Значение);
                КонецЕсли;
            ИначеЕсли колонка = 7 Тогда
                Если не    Значение = "" Тогда
                    СтрокаТабличнойЧасти.ПериодичностьЗаказа = Перечисления.ВидыПериодичностиЗаказов.Еженедельно;
                    //СтрокаТабличнойЧасти.КоличествоДнейПериодичности = Значение;
                КонецЕсли;
            ИначеЕсли колонка = 8 Тогда
                Если не    Значение = "" Тогда
                    СтрокаТабличнойЧасти.ДниНедели = Значение;
                КонецЕсли;
            ИначеЕсли колонка = 9 Тогда
                Если не    Значение = "" Тогда
                    СтрокаТабличнойЧасти.СрокПоставки = Число(Значение);        
                КонецЕсли;
            ИначеЕсли колонка = 10 Тогда
                    СтрокаТабличнойЧасти.ПараметрыКоличества = Перечисления.ВидыКоличестваЗаказа.АвтоматическийРассчет;
                    //СтрокаТабличнойЧасти.Количество = Число(Значение);
            ИначеЕсли колонка = 11 Тогда
                Если не    Значение = "" Тогда
                    СтрокаТабличнойЧасти.КвантПоставки = Число (Значение);
                КонецЕсли;
            ИначеЕсли колонка = 12 Тогда
                Если не    Значение = "" Тогда
                    СтрокаТабличнойЧасти.МинимальныйОстаток = Число (Значение);
                    СтрокаТабличнойЧасти.МаксимальныйЗапас = Число (Значение);
                КонецЕсли;
            ИначеЕсли колонка = 13 Тогда
                Если не    Значение = "" Тогда
                    СтрокаТабличнойЧасти.ПроцентОтходов = Число (Значение);
                КонецЕсли;
            КонецЕсли;

            Сообщить ("Товары Загружены", СтатусСообщения.Важное);
            
        КонецЦикла;
        КонецЦикла;
//Попытка    
    /////////////////////////////////////////////////
    Для каждого Строка Из НовДокРС.ТоварыДокумента Цикл
        
        КонецЦикла;
//НайденнаяСсылка = Справочники.Номенклатура.НайтиПоКоду(Значение);
//Если НайденнаяСсылка = Справочники.Номенклатура.ПустаяСсылка()Тогда
//    Сообщить ("Номенклатура """ + Значение + """ не найдено");
//КонецЕсли;
/////////////////////////////////////////////////
НовДокРС.Записать(РежимЗаписиДокумента.Запись);

//Исключение

Сообщить(""+ОписаниеОшибки());

//КонецПопытки;

КонецПроцедуры
 
 
   ДенисЧ
 
1 - 01.08.19 - 16:08
В какой момент он вызывается - мы должны угадать?
   Neirofun
 
2 - 01.08.19 - 16:11
http://prntscr.com/omzobd  Вот скрин в момент когда он вызывается
   dka80
 
3 - 01.08.19 - 16:22
Вероятно, просто переключается текущее активное окно
Посмотри тут, может поможет:
https://forum.infostart.ru/forum9/topic135806/
   Neirofun
 
4 - 01.08.19 - 16:41
Понял, буду пробовать

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.