Вход | Регистрация
 
1С:Предприятие :: 1С:Предприятие 8 общая

Выбирает не те значения

Выбирает не те значения
Я
   Neirofun
 
01.08.19 - 12:14
Может кто подсказать по коду?
Есть проблема с пустыми ячейками документа. Если по коду номенклатуры не находит номенклатуру, то в документ не записывается код номенклатуры и сама номенклатура
Решил через сообщить показать в какие ячейки не вводится номенклатура, но столкнулся с проблемой "Значение" выбирает не ту ячейку.

// поиска пустых ячеек

НайденнаяСсылка = Справочники.Номенклатура.НайтиПоКоду(Значение);
Если НайденнаяСсылка = Справочники.Номенклатура.ПустаяСсылка()Тогда
    Сообщить ("Номенклатура """ + Значение + """ не найдено");
КонецЕсли;

// Код откуда должен брать значение

ИначеЕсли Колонка = 2 Тогда
       Если не    Значение = "" Тогда
           СтрокаТабличнойЧасти.Номенклатура = Справочники.Номенклатура.НайтиПоКоду(Значение);
КонецЕсли;

// На деле берет отсюда

Если Колонка = 1 тогда
        Если не    Значение = "" Тогда
              Подразделение = (Справочники.ПодразделенияКомпании.НайтиПоНаименованию(Значение));
              Если Подразделение.Организация =  Справочники.Организации.НайтиПоКоду("00001   ") Тогда
                   СтрокаТабличнойЧасти = НовДокРС.ТоварыДокумента.Добавить();
                   СтрокаТабличнойЧасти.ПодразделениеНазначения = Подразделение;
                   Иначе Прервать;
              КонецЕсли;
 
 
   mikecool
 
1 - 01.08.19 - 12:19
заставь выбраться нужное значение, будь мужиком
   SleepyHead
 
2 - 01.08.19 - 12:24
(0) Код делает все точно так, как ты сказал. Но не так, как нужно!
   catena
 
3 - 01.08.19 - 12:35
Запускай отладчик и смотри все переменные.

Список тем форума
Рекламное место пустует  Рекламное место пустует
Здесь можно задать вопрос "Как сделать?" и получить кучу ответов, что тебе это делать не надо. Ymryn
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.