Вход | Регистрация
 
1С:Предприятие :: 1С:Предприятие 8 общая

Добавить колонки в обработку выгрузка/загрузка эксель

Добавить колонки в обработку выгрузка/загрузка эксель
Я
   bebibo
 
01.08.19 - 09:40
Здравствуйте, Есть обработка, которая выгружает номенклатуру в эксель и загружает. Нужно добавить 2 колонки, после добавления пишет: неверное имя колонки. Как мне ее добавить?
 
 
   ДенисЧ
 
1 - 01.08.19 - 09:41
Задать правильное имя колонки. Ваш Кэп.
   bebibo
 
2 - 01.08.19 - 09:43
(1) В смысле правильное? Я добавляю новую
   lepoissonherisson
 
3 - 01.08.19 - 09:46
Колонку то как добавляешь ?
   bebibo
 
4 - 01.08.19 - 09:48
(3) В модуле объекта добавил в список служебных колонок, и еще в модуле формы добавил, смотрю отладкой, в ТЗ они появились
   lepoissonherisson
 
5 - 01.08.19 - 09:50
ну отлично, а в том месте где пишет что неверное имя колонки отладчиком ты эти колонки видишь ? и если видишь, то точно ты к ней обращаешься так же как назвал ?
   bebibo
 
6 - 01.08.19 - 10:02
(5) Отладчиком вижу их там, да, точно к ней обращаюсь(
   lepoissonherisson
 
7 - 01.08.19 - 10:05
слушай ну чудес не бывает ..
если ты видишь глазами , значит у объекта есть некое свойство
значит есть метод может это свойство вернуть, то он это сделает ..
впрочем у меня ощущение, что ты к форме приляпал колонку , а не к объекту
   bebibo
 
8 - 01.08.19 - 10:05
Причем он ругается не на мои добавленные колонки
   bebibo
 
9 - 01.08.19 - 10:05
(8) я полагаю, что порядок сменился из-за того что добавлены новые колонки, но как это исправить?
   Масянька
 
10 - 01.08.19 - 10:11
(9) Коню понятно.
Либо добавляй в конец, либо меняй порядок там, где используется.
   bebibo
 
11 - 01.08.19 - 10:12
(10) В конец не надо, нужно в середину, а порядок где менять?
   bebibo
 
12 - 01.08.19 - 10:12
В модуле уже поменян порядок
   bebibo
 
13 - 01.08.19 - 10:13
(12) Прописан список служебных колонок с номером, и в середину добавил и порядок изменил как надо. Или где то еще менять надо?
   Масянька
 
14 - 01.08.19 - 10:14
(13) По-моему, штатные ванги в отпусках.
   bebibo
 
15 - 01.08.19 - 10:15
У меня есть 10 обязательных колонок, в них порядок нормальный, я туда и добавил свои новые колонки.
А после них идут необязательные колонки и вот почему то там меняется порядок колонок
   bebibo
 
16 - 01.08.19 - 10:24
Блин, ну кто нибудь подскажите
   Александр Б
 
17 - 01.08.19 - 10:32
(16) Мало конкретики, чтобы подсказать. На уровне угадывания.
   bebibo
 
18 - 01.08.19 - 10:39
(17) Что нужно для конкретики?
   bebibo
 
19 - 01.08.19 - 10:39
Вот где есть колонки и всё что с ними связано в коде, я везде добавил и изменил как надо
   Александр Б
 
20 - 01.08.19 - 10:43
(19) Ну раз изменил как надо, значит и работать должно как надо. А раз не работает как надо, значит сделал что-то не так. А что именно не так, мы можем лишь угадать.
   Сияющий в темноте
 
21 - 01.08.19 - 10:47
Неплохо бы посмотреть тот код,в котором получается неверное имя колонки,т.к.очень похоже,что не везде добавил
например,если таблица передается в запрос для анализа,то в коде запроса нужно написать выборку этих колонок и т.п.
особенно аккуратно нужно относиться к ЗаполнитьЗначенияСвойств,т.к.она предполагает добавление колонок в приемник.
   bebibo
 
22 - 01.08.19 - 10:48
(21) Вот здесь ошибка
Функция СформироватьТЗДляЗагрузки(Структура)
    
    ТЗ = Новый ТаблицаЗначений();
    
    Для Каждого Элемент Из Структура Цикл
        ТЗ.Колонки.Добавить(Элемент.Представление);        
    КонецЦикла;    
    
    Возврат ТЗ;    
    
КонецФункции
   bebibo
 
23 - 01.08.19 - 10:48
(22) На вот этой строчке:
ТЗ.Колонки.Добавить(Элемент.Представление);
   Масянька
 
24 - 01.08.19 - 10:51
(23) Посмотри, что в Структуре, а что в Элементе.
Ну, и (на всякий случай) - у Элемента прописано Представление?
   lepoissonherisson
 
25 - 01.08.19 - 10:51
может у тебя в представлении пробелы , второй раз добавляешь ?
   Александр Б
 
26 - 01.08.19 - 10:52
(23) Скорее всего Элемент.Представление имеет два слова, типа "Ставка НДС". А в качестве имени колонки может быть только одно слово, типа "СтавкаНДС".
В данном случае, если "Структура" - это список значений, то надо использовать Элемент.Имя
   bebibo
 
27 - 01.08.19 - 10:54
(24) В структуре все колонки, в том числе и мои новые
   bebibo
 
28 - 01.08.19 - 10:55
(24) у элемента прописано представление
   bebibo
 
29 - 01.08.19 - 10:55
(25) В представлении пробелов нет
   Масянька
 
30 - 01.08.19 - 10:56
Ощущение, что ТС решил взять измором...
 
 Рекламное место пустует
   hhhh
 
31 - 01.08.19 - 10:57
(29) ну показывай уже эти представления.
   bebibo
 
32 - 01.08.19 - 10:57
Блин, смотрю отладкой и у меня одну колонку 2 раза добавляет(не мою новую)
   lepoissonherisson
 
33 - 01.08.19 - 10:57
если второй раз колонку добавлять такая же ошибка будет.
   bebibo
 
34 - 01.08.19 - 10:58
(32) Как это исправить и почему так?
   lepoissonherisson
 
35 - 01.08.19 - 10:58
все же телепатам наверное лучше с телепатами жить .. не зря эту тему в люди Х развернули.
   lepoissonherisson
 
36 - 01.08.19 - 10:59
Представь на минуту, что мы не видим твоми глазами сейчас. Мы видим только что у нас на мониторе.
   bebibo
 
37 - 01.08.19 - 10:59
Теперь хоть понятно, из-за чего эта ошибка, что он добавляет колонку два раза, но почему..
   bebibo
 
38 - 01.08.19 - 10:59
(36) Представляю..
   Масянька
 
39 - 01.08.19 - 11:00
А если зайти с тыла?
   bebibo
 
40 - 01.08.19 - 11:02
Ну как исправить то блин?)
   bebibo
 
41 - 01.08.19 - 11:04
Ккак у меня в структуре задвоилась одна колонка?
   hhhh
 
42 - 01.08.19 - 11:07
(40) ну тупо в лоб исправляй
Если ТЗ.Колонки.Найти(Элемент.Представление) = Неопределено Тогда
     ТЗ.Колонки.Добавить(Элемент.Представление);
КонецЕсли;
   bebibo
 
43 - 01.08.19 - 11:09
(42) сейчас попробую
   bebibo
 
44 - 01.08.19 - 11:12
Теперь ошибки нет,спасибо, но как бы убрать в структуре откуда берутся элементы эту задублированную колонку?
   hhhh
 
45 - 01.08.19 - 11:16
(44) ну руки оторвать этому чуваку, который структуру заполнял?
   bebibo
 
46 - 01.08.19 - 11:17
(45) НУ не так жестко уж))
   bebibo
 
47 - 01.08.19 - 11:19
Просто интересно почему так


Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.