Вход | Регистрация
 

Не выводится штрих-код в макете

Не выводится штрих-код в макете
Я
   vladis222
 
01.08.19 - 09:30
Подскажите,пожалуйста,в печатном макете не выводится штрих код товаров,хотя он занесен. Возможно в коде в запросе что не так?

///Запрос выбирает инфу из регистра себестоимости+штрихкод на номенклатуру.
    ТабДок.Вывести(ШапкаТаблицы);
    Запрос = Новый Запрос;
    Запрос.УстановитьПараметр("Контрагент",Объект.Поставщик);
    Запрос.УстановитьПараметр("ДатаНач",Объект.ДатаНачала);
    Запрос.УстановитьПараметр("ДатаКон",КонецДня(Объект.ДатаКонец));
    Запрос.УстановитьПараметр("Договор",Объект.Договор);
    Запрос.Текст = "ВЫБРАТЬ
                   |    ПартииТоваровОрганизаций.Регистратор.Подразделение КАК ПодразделениеЦПС,
                   |    ШтрихкодыНоменклатуры.Штрихкод,
                   |    ПартииТоваровОрганизаций.Номенклатура,
                   |    ПартииТоваровОрганизаций.Характеристика,
                   |    СУММА(ПартииТоваровОрганизаций.Количество)КАК Количество,
                   |    СУММА(ПартииТоваровОрганизаций.Стоимость) КАК Стоимость
                   |ИЗ
                   |    РегистрНакопления.ПартииТоваровОрганизаций КАК ПартииТоваровОрганизаций
                   |        ЛЕВОЕ СОЕДИНЕНИЕ РегистрСведений.ШтрихкодыНоменклатуры КАК ШтрихкодыНоменклатуры
                   |        ПО ПартииТоваровОрганизаций.Номенклатура = ШтрихкодыНоменклатуры.Характеристика.Владелец
                   |            И ПартииТоваровОрганизаций.Характеристика = ШтрихкодыНоменклатуры.Характеристика
                   |ГДЕ
                   |    ПартииТоваровОрганизаций.ДокументПоступления.Контрагент = &Контрагент
                   |    И ПартииТоваровОрганизаций.Период МЕЖДУ &ДатаНач И &ДатаКон
                   |    И ПартииТоваровОрганизаций.ДокументПоступления.Договор = &Договор
                   |
                   |СГРУППИРОВАТЬ ПО
                   |    ПартииТоваровОрганизаций.Номенклатура,
                   |    ПартииТоваровОрганизаций.Характеристика,
                   |    ШтрихкодыНоменклатуры.Штрихкод,
                   |    ПартииТоваровОрганизаций.Регистратор.Подразделение
                   |
                   |УПОРЯДОЧИТЬ ПО
                   |    ПодразделениеЦПС,
                   |    ПартииТоваровОрганизаций.Номенклатура.Наименование
                   |ИТОГИ
                   |    СУММА(Количество),
                   |    СУММА(Стоимость)
                   | ПО
                   |    ПодразделениеЦПС КАК ПодразделениеЦПС";
    Результат = Запрос.Выполнить();
    ВыборкаЦПС = Результат.Выбрать(ОбходРезультатаЗапроса.ПоГруппировкам,"ПодразделениеЦПС");
    ИтогСумма = 0;
    ИтогКоличество = 0;
    НомерСтроки = 0;
    Пока ВыборкаЦПС.Следующий() Цикл
        ЦПС.Параметры.ЦПС = ВыборкаЦПС.ПодразделениеЦПС;
        ИтогСумма = ИтогСумма + ВыборкаЦПС.Стоимость;
        ИтогКоличество = ИтогКоличество + ВыборкаЦПС.Количество;
        ЦПС.Параметры.Количество = ВыборкаЦПС.Количество;
        ЦПС.Параметры.Сумма  = ВыборкаЦПС.Стоимость;
        ТабДок.Вывести(ЦПС);
        ВыборкаНоменклатура = ВыборкаЦПС.Выбрать();
        ТабДок.НачатьГруппуСтрок();
        Пока ВыборкаНоменклатура.Следующий() Цикл
            НомерСтроки = НомерСтроки +1;
            Таблица.Параметры.НомерСтроки = НомерСтроки;
            <b>Таблица.Параметры.Штрихкод = ВыборкаНоменклатура.Штрихкод;</b>
            Таблица.Параметры.Номенклатура = ВыборкаНоменклатура.Номенклатура;
            Таблица.Параметры.Характеристика = ВыборкаНоменклатура.Характеристика;
            Таблица.Параметры.Количество = ВыборкаНоменклатура.Количество;
            Таблица.Параметры.Сумма =  ВыборкаНоменклатура.Стоимость;
            ТабДок.Вывести(Таблица);
        КонецЦикла;
        ТабДок.ЗакончитьГруппуСтрок();
    КонецЦикла;    
    Итог.Параметры.ИтогКоличество = ИтогКоличество;
    Итог.Параметры.ИтогСумма      = ИтогСумма;
    ТабДок.Вывести(Итог);
    
    Подвал.Параметры.ИтогСумма = ИтогСумма;
    //Если Выборка.Количество()> 0 Тогда
        Подвал.Параметры.Менеджер = КонтактноеЛицо.Наименование;
        Подвал.Параметры.Должность = КонтактноеЛицо.ДолжностьПоВизитке ;
    //Иначе
    //    Подвал.Параметры.Менеджер  = "";
    //    Подвал.Параметры.Должность = "";
    //КонецЕсли;
    //
    ТабДок.Вывести(Подвал);
    
    Возврат ТабДок;
 
 
   mikecool
 
1 - 01.08.19 - 09:31
проверь - картинка ШК не выходит ли за границы области макета?
   vladis222
 
2 - 01.08.19 - 09:31
(1) всмысле?
   dka80
 
3 - 01.08.19 - 09:32
Возможно штрихкод выходит за границы макета, возможно ты его слишком маленьким сделал
   vladis222
 
4 - 01.08.19 - 09:32
(1) там не картинка а набор цифр...
   vladis222
 
5 - 01.08.19 - 11:30
(1) Дело было в строке запроса - ПО ПартииТоваровОрганизаций.Номенклатура = ШтрихкодыНоменклатуры.Характеристика.Владелец нужно было заменить на артииТоваровОрганизаций.Номенклатура = ШтрихкодыНоменклатуры.Номенклатура

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.