Вход | Регистрация
 
1С:Предприятие :: 1С:Предприятие 8 общая

Подключение ФР через DrvFR

Подключение ФР через DrvFR
Я
   Валерия
 
31.07.19 - 12:39
Здравствуйте! Может кто ещё помнит работу с динозаврами. Пытаюсь программно подключить ФР ШтрихМ через DrvFR.Пишет ошибку подключения. вот код:
ПодключитьВнешнююКомпоненту("AddIn.DrvFR");
FR = Новый COMОбъект ("AddIn.DrvFR");
рез=FR.Connect();
FR.Password = 30;
    Если рез<>0 Тогда
        Сообщить("ПодключитьФР, ошибка собственно подключения: "+FR.ResultCodeDescription);
        Возврат Ложь;
    Иначе
         Сообщить("ПодключитьФР, собственно подключение успешно.");
    КонецЕсли;
Логикой понимаю, что где-то нужно задать параметры, типа компорта и скорости и т.д. Не врубаюсь как.
У меня это подключение идет сразу после отключения ФР на DrvFR1С.
 
 
   Garykom
 
1 - 31.07.19 - 12:44
Не надо ничего задавать если через "тест драйвера" порт настроен и сохранено оно и так подцепляет сохраненные настройки.

Попробуй "сразу после отключения ФР на DrvFR1С2 через тест драйвера подключиться, имхается что порт не освободился нифига после DrvFR1С.
   Масянька
 
2 - 31.07.19 - 13:03
(0) В Тис: в глобальнике ПриНачалеРаботыСистемы - ОткрытьФормуМодально("Обработка.ТорговоеОборудование", "Подключить");
Далее - открываем обработку, смотрим команду Подключить, которая нас отправляет обратно в глобальник:
Функция глОборудованиеКоманда(Вид, Обработка, Параметры) Экспорт
    Рез = "";

    
    Если ПустоеЗначение(Обработка) = 1 Тогда
        // внутренняя обработка

        Если Метаданные.Обработка("Обслуживание" + Вид ).Выбран() = 1 Тогда
            ОткрытьФормуМодально("Обработка.Обслуживание" + Вид, Параметры);
        Иначе
            Параметры.Установить("ОписаниеРезультата", "Отсутствует обработка обслуживания");
        КонецЕсли;
    Иначе
        Если ФС.СуществуетФайл(глКаталогОписаний + Обработка) = 0 Тогда
            Параметры.Установить("ОписаниеРезультата", "Отсутствует обработка обслуживания");
        Иначе
            ОткрытьФормуМодально("Отчет", Параметры, глКаталогОписаний + Обработка);
        КонецЕсли;
    КонецЕсли;
    
    Возврат Рез;
КонецФункции// глОборудованиеКоманда


Никаких портов, скоростей и пр. в коде трогать не надо.
Нужно сначала подключить кассу в режиме предприятия (!!!).
А когда она (касса) подключится (в режиме предприятия) - в Сервис -> Параметры появится усеченный драйвер RRN/ Вот там и меняйте скорость, порты и пр.
   Валерия
 
3 - 31.07.19 - 13:06
(1) У меня на компе два фискальника висят. Один ккт онлайн и обычный. Поэтому мне нужно как-то параметры задать. Правда работа идет из одной базы, но под разными пользователями.
   Валерия
 
4 - 31.07.19 - 13:07
(2) Попробую сейчас.
   Масянька
 
5 - 31.07.19 - 13:10
(3) По идее - при правильном подключении (и если: звезды встанут в ряд, солнце взойдет, луна уйдет, мировой океан, моря, острова и пр. :( ) - должно быть 2 драйвера (экземпляра) в эске.
   Валерия
 
6 - 31.07.19 - 13:12
(5) Спасибо, огромное! Всё подключилось!
   Масянька
 
7 - 31.07.19 - 13:14
(6) Семерка - это вещь!
   Валерия
 
8 - 31.07.19 - 13:16
(7) Вот прям 100%
   Garykom
 
9 - 31.07.19 - 14:13
"Собрались две блондинки ..."
   Garykom
 
10 - 31.07.19 - 14:14
Интересно хоть одна читала:
https://www.shtrih-m.ru/docs/download.php?file=30901&iblock=21
   Валерия
 
11 - 31.07.19 - 14:15
(10) Что бы мы делали без таких умов, как вы...
   Масянька
 
12 - 31.07.19 - 14:16
(11) Не обращай внимания.
У него комплекс (с блондинками).
   Garykom
 
13 - 31.07.19 - 14:23
А еще меня бесят недоадмины, которые драйвер не могут нормально инсталлятором установить и начинается шаманство с копированием dll в разные папочки 1С/bin или базы и regsvr32
   Garykom
 
14 - 31.07.19 - 14:24
(11) Ты (1) выполнила?
У тебя "Тест драйвера ККТ" подключается штатно? Знаешь что это такое?

А как менять порт написано в (10)
   Масянька
 
15 - 31.07.19 - 14:27
(13) А меня бесят понаехавшие дятлы, которые в левом ряду едут по навигатору.

Список тем форума
Рекламное место пустует  Рекламное место пустует
Выдавать глобальные идеи — это удовольствие; искать сволочные маленькие ошибки - вот настоящая работа.
Фредерик Брукс-младший
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.