Вход | Регистрация
 

Не регистрируются данные в плане обмена

Не регистрируются данные в плане обмена
Я
   inkvizitr
 
31.07.19 - 09:14
Моя обработка запускается в базе бух и должна зарегистрировать данные в базе ЗУП через COM, данные почему то не регистрируются, что делаю не так, подскажите? вроде все данные я получаю на стороне базы ЗУП и регистрирую там же.
СоединениеСЗУП это подключение через com к базе зарплаты

ВыборкаУзлов = СоединениеСЗУП.ПланыОбмена.ЗиУП_БП_КОРП.Выбрать();
    Пока ВыборкаУзлов.Следующий() Цикл
        Если ВыборкаУзлов.Ссылка<>СоединениеСЗУП.ПланыОбмена.ЗиУП_БП_КОРП.ЭтотУзел() Тогда
            Узел = ВыборкаУзлов.ПолучитьОбъект();
        КонецЕсли;    
    КонецЦикла;    
    Пока Выборка.Следующий() Цикл
        НаборЗаписей = СоединениеСЗУП.РегистрыСведений.РаботникиОрганизаций.СоздатьНаборЗаписей();
        НаборЗаписей.Отбор.Регистратор.Установить(Выборка.Регистратор);
        НаборЗаписей.Прочитать();
        
        СоединениеСЗУП.ПланыОбмена.ЗарегистрироватьИзменения(Узел.Ссылка, НаборЗаписей);
        СоединениеСЗУП.ПланыОбмена.ЗарегистрироватьИзменения(Узел.Ссылка, Выборка.Сотрудник);
        СоединениеСЗУП.ПланыОбмена.ЗарегистрироватьИзменения(Узел.Ссылка, Выборка.Физлицо);
    КонецЦикла;
КонецПроцедуры
 
 
   Индиго
 
1 - 31.07.19 - 09:21
(0)Как вариант данные не входят в состав плана обмена
   inkvizitr
 
2 - 31.07.19 - 09:23
входят, хотя погодь, щас гляну
   Cyberhawk
 
3 - 31.07.19 - 09:34
Код нелогичный - регистрируешь только на каком-то одном из узлов
   Cyberhawk
 
4 - 31.07.19 - 09:35
Хотя если ожидается, что узел (кроме собственного) всегда только один, то понятно
   inkvizitr
 
5 - 31.07.19 - 09:37
(4) а мне и нужно на одном зарегистрировать, да.. все в план обмена входит, но блин не регистрируется
   inkvizitr
 
6 - 31.07.19 - 09:39
(4) вроде получаю ссылку на стороне зупа, и на стороне зупа эту же ссылку и регистрирую,  может через com ссылки не проходят, чета не могу по ссылкам инфу найти
   Индиго
 
7 - 31.07.19 - 09:40
(5)А что есть Выборка?
в 
Пока Выборка.Следующий() Цикл
   Галахад
 
8 - 31.07.19 - 09:47
Может сначала попробовать один элемент справочника зарегистрировать?
НайтиПоКоду ...
   inkvizitr
 
9 - 31.07.19 - 09:47
(7) это результат запроса, полученных данных из ЗУП

Запрос = СоединениеСЗУП.NewObject("Запрос");
    Запрос.TEXT = "текст запроса";
    Запрос.УстановитьПараметр("Наименование", МассивСотрудниковНаименование);
    Запрос.Установитьпараметр("Код",МассивСотрудниковТабНомер);
    
    Выборка = Запрос.Выполнить().Выбрать();
   Индиго
 
10 - 31.07.19 - 09:49
(9)Проверь не пустой ли результат у запроса.
   inkvizitr
 
11 - 31.07.19 - 09:51
(10) щас попробую одиночный зарегить, результат запроса нормальный, проверял
   hhhh
 
12 - 31.07.19 - 10:02
(11) МассивСотрудниковНаименование  что там? массивы той базы?
   inkvizitr
 
13 - 31.07.19 - 10:05
(12) да той
(8) ты прав, он и одиночно не регистрирует
 Сотр = СоединениеСЗУП.Справочники.СотрудникиОрганизаций.НайтиПоНаименованию("Иванов Иван Иванович");
     СоединениеСЗУП.ПланыОбмена.ЗарегистрироватьИзменения(Узел.Ссылка, Сотр);

ща буду разбираться, че за мазафака такая
   inkvizitr
 
14 - 31.07.19 - 10:08
(3) (12) (10) (8) Коллеги спасибо, походу лыжи ехали, это со мной что-то, походу я понял в чем дело, я пытался регить на предопределенный узел плана обмена
   inkvizitr
 
15 - 31.07.19 - 10:08
щас чуть алгоритм переработаю, поиска нужного плана обмена
   Cyberhawk
 
16 - 31.07.19 - 10:11
А как же условие на неравенство, должно отрабатывать верно
   aleks_default
 
17 - 31.07.19 - 10:12
Узел = ВыборкаУзлов.ПолучитьОбъект();
   aleks_default
 
18 - 31.07.19 - 10:13
нахрена?
   inkvizitr
 
19 - 31.07.19 - 10:15
(18) а как?
   Cyberhawk
 
20 - 31.07.19 - 10:18
(19) ВыборкаУзлов.Ссылка
   Cyberhawk
 
21 - 31.07.19 - 10:19
Но все-таки непонятно почему его код на неравенство не отрабатывает
   inkvizitr
 
22 - 31.07.19 - 10:20
(21) вот так сработал
ВыборкаУзлов.Ссылка.Code<>СоединениеСЗУП.ПланыОбмена.ЗиУП_БП_КОРП.ЭтотУзел().Code
   inkvizitr
 
23 - 31.07.19 - 10:20
все заработала ребята, спасибо
   inkvizitr
 
24 - 31.07.19 - 10:20
все зарегилось, низкий поклон сообществу
   Cyberhawk
 
25 - 31.07.19 - 10:20
Давай в табло показывай что у тебя в старом коде по обеим сторонам неравенства
   Cyberhawk
 
26 - 31.07.19 - 10:22
Может у тебя баг платформы какой, когда этот узел дублировался после обновления
   Галахад
 
27 - 31.07.19 - 10:25
Кстати да. Это всегда было. Не нужно сравнивать ссылки по COM.
   inkvizitr
 
28 - 31.07.19 - 10:26
(26) щас скину
   inkvizitr
 
29 - 31.07.19 - 10:29
   Cyberhawk
 
30 - 31.07.19 - 10:52
(27) Т.е. сравнение на неравенство всегда выдает истину, а на равенство - ложь?
 
 Рекламное место пустует
   Галахад
 
31 - 31.07.19 - 11:04
(30) Есть такое.


Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.