Вход | Регистрация
 
1С:Предприятие :: 1С:Предприятие 8 общая

При записи объекта реквизит есть, а в ссылке пустой.

При записи объекта реквизит есть, а в ссылке пустой.
Я
   SuperVasek
 
30.07.19 - 17:14
Доброго времени суток, товарищи!
В расширении вместо "ПриЗаписи" заполняю некий реквизит документа объекта.
После того как проходит ДокументОбъект.Записать() смотрю в отладчике:
В ДокументОбъект этот реквизит заполнен, а в ДокументОбъект.Ссылка реквизит пустой. Соответственно, когда открываешь форму этого документа, реквизит также пустой.
Запись документа ведется не из его формы, а с помощью обработки программно.
Есть у кого-нибудь идеи на этот счёт? Почему так происходит? Заранее благодарен за ответ.
PS. Когда перепроводишь документ, реквизиты заполняются.
 
 
   lodger
 
1 - 30.07.19 - 17:25
поменяй ПриЗаписи на Передзаписью
   SuperVasek
 
2 - 30.07.19 - 17:34
(1) Акей, спасибо, сейчас попробую.
   PiotrLoginov
 
3 - 30.07.19 - 17:38
(2) ну а ты понял, почему был сабж, или просто последуешь совету, не заморачиваясь, что было не так?
   mikecool
 
4 - 30.07.19 - 17:53
(3) некогда точить, рубить надо
   1Сергей
 
5 - 30.07.19 - 17:54
(4) пилой рубить?
   mikecool
 
6 - 30.07.19 - 17:54
(5) и шурупы забивать!
   Cyberhawk
 
7 - 30.07.19 - 18:12
"Когда перепроводишь документ, реквизиты заполняются" // Вроде в более-менее свежих платформах это пофиксили - теперь в обработке проведения изменения в объекте также уже не фиксируются в БД
   SuperVasek
 
8 - 31.07.19 - 10:23
(3) Да, понял. Это был мой пробел в знаниях.
   SuperVasek
 
9 - 31.07.19 - 10:24
(1) Спасибо за подсказку!

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.