Вход | Регистрация
 
1С:Предприятие :: 1С:Предприятие 8 общая

Как перестроить цикл с массивом

Как перестроить цикл с массивом
Я
   progaoff
 
30.07.19 - 12:55
Если Не СуммаРаспределения = Неопределено Тогда    
        Для Каждого СтрокаТЧ Из ЭтотОбъект.Товары Цикл    
            Для i = 0 По ЭтотОбъект.Товары.Количество()-1 Цикл    
                ЭлементМассива= СуммаРаспределения[i];
                Проводка = Проводки.Добавить();
                Проводка.Период                   = ЭтотОбъект.Дата;
                Проводка.Организация              = ЭтотОбъект.Организация;        
                Проводка.СчетДт       = Счет15_02;
                Курс                               = МодульВалютногоУчета.ПолучитьКурсВалюты(ВалютаДокумента, Дата);
                    Проводка.Сумма            =    Окр(СтрокаТЧ.Сумма*Курс.Курс/Курс.Кратность,4)-(ЭлементМассива);    
                    
            КонецЦикла;
    КонецЦикла;        
    КонецЕсли;
Добрый день. Подскажите пожалуйста как мне переделать цикл, что бы обойти ТЗ и одновременно по ней распределить элементы массива в один заход?
 
 
   Жан Пердежон
 
1 - 30.07.19 - 13:00
а чем сложность?
   progaoff
 
2 - 30.07.19 - 13:01
(1)  Для i = 0 По ЭтотОбъект.Товары.Количество()-1 Цикл вот в этом.
   catena
 
3 - 30.07.19 - 13:05
(2)Чем это мешает?
   Garykom
 
4 - 30.07.19 - 13:05
Задачу нормально опиши и попробуй СЛОВАМИ описать АЛГОРИТМ как предполагаешь решать
   progaoff
 
5 - 30.07.19 - 13:06
(4) Есть некая сумма, она распределяется относительно строкам в таб части, возвращает массив, в нем суммы которые мне нужно отминусовать от строк в ТЧ.
   catena
 
6 - 30.07.19 - 13:12
ЭлементМассива= СуммаРаспределения[СтрокаТЧ.НомерСтроки-1];
   progaoff
 
7 - 30.07.19 - 13:12
Без этого  Для i = 0 По ЭтотОбъект.Товары.Количество()-1 Цикл  ?
   lodger
 
8 - 30.07.19 - 13:15
(7) без.
   progaoff
 
9 - 30.07.19 - 13:15
Спасибо огромное)

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.