Вход | Регистрация
 
1С:Предприятие :: 1С:Предприятие 8 общая

ОбработкаПроверкиЗаполнения и Отказ

ОбработкаПроверкиЗаполнения и Отказ
Я
   gugolovski
 
30.07.19 - 05:19
Предположим в справочнике есть реквизит, у которого в "проверке заполнения" стоит "выдавать ошибку".
Как сделать чтобы процедура ОбработкаПроверкиЗаполнения() игнорировала пустое поле этого реквизита и позволила записать элемент справочника?

Нечто вроде:
Процедура ОбработкаПроверкиЗаполнения(Отказ, ПроверяемыеРеквизиты)
Отказ = Ложь;
КонецПроцедуры

только элемент все равно не записывается..
 
 
   SleepyHead
 
1 - 30.07.19 - 07:39
(0) А почему бы не снять "выдавать ошибку" у реквизита?
   catena
 
2 - 30.07.19 - 07:45
   gugolovski
 
3 - 30.07.19 - 08:34
(1) потому что хочется понять зачем параметр "отказ", как он работает
   gugolovski
 
4 - 30.07.19 - 08:37
что-то у меня не так идет))
Процедура ОбработкаПроверкиЗаполнения(Отказ, ПроверяемыеРеквизиты)
        если  ЭтоГруппа() Тогда
            возврат;
КонецЕсли;
КонецПроцедуры

Проверка модуля выдает ошибку: {Справочник.Номенклатура.МодульОбъекта(18,9)}: Процедура или функция с указанным именем не определена (ЭтоГруппа)
        если  <<?>>ЭтоГруппа() Тогда (Проверка: Сервер)

...почему так?
   hhhh
 
5 - 30.07.19 - 08:38
(4) семерочник что ли?
   gugolovski
 
6 - 30.07.19 - 08:42
ага
   gugolovski
 
7 - 30.07.19 - 08:43
нашел видеоурок, там код переписал буква в букву, а не заходит))
   hhhh
 
8 - 30.07.19 - 08:51
(7) ты забыл функцию определить ЭтоГруппа(). Есть у тебя эта функция и чем она занимается?
   gugolovski
 
9 - 30.07.19 - 08:59
(8) Да.. надо ЭтоГруппа, а не ЭтоГруппа()

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.